[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / heimdal

Annotation of pkgsrc/security/heimdal/Makefile, Revision 1.123

1.123   ! adam        1: # $NetBSD: Makefile,v 1.122 2016/12/04 05:17:11 ryoon Exp $
1.1       jlam        2:
1.101     adam        3: DISTNAME=      heimdal-1.5.3
1.123   ! adam        4: PKGREVISION=   14
1.15      jlam        5: CATEGORIES=    security
1.65      jlam        6: MASTER_SITES=  http://www.h5l.org/dist/src/
1.15      jlam        7:
1.79      wiz         8: MAINTAINER=    pkgsrc-users@NetBSD.org
1.65      jlam        9: HOMEPAGE=      http://www.h5l.org/
1.15      jlam       10: COMMENT=       Kerberos 5 implementation
1.73      wiz        11: LICENSE=       modified-bsd
1.1       jlam       12:
1.51      wiz        13: CONFLICTS+=    arla-[0-9]*
1.15      jlam       14: CONFLICTS+=    mit-krb5-[0-9]*
1.52      wiz        15: CONFLICTS+=    openafs-[0-9]*
1.56      jlam       16: CONFLICTS+=    gss-[0-9]*
1.92      cheusov    17: CONFLICTS+=    kth-krb4-[0-9]*
1.3       jlam       18:
1.102     joerg      19: MAKE_JOBS_SAFE=        no
                     20:
1.1       jlam       21: USE_LIBTOOL=           yes
1.113     fhajny     22: USE_TOOLS+=            bison flex:run
1.65      jlam       23: PKGCONFIG_OVERRIDE+=   tools/heimdal-gssapi.pc.in
1.45      jlam       24: MAKE_ENV+=             INSTALL_CATPAGES=no
1.1       jlam       25:
1.65      jlam       26: .include "../../mk/bsd.prefs.mk"
                     27: .include "options.mk"
                     28:
                     29: HEIMDAL_HDB_DIR=       ${VARBASE}/heimdal
1.1       jlam       30:
                     31: GNU_CONFIGURE=         yes
1.80      adam       32: CONFIGURE_ARGS+=       --enable-kcm
                     33: CONFIGURE_ARGS+=       --enable-pthread-support
1.1       jlam       34: CONFIGURE_ARGS+=       --includedir=${PREFIX}/include/krb5
1.80      adam       35: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFDIR}
1.88      shattere   36: CONFIGURE_ARGS+=       --with-hdbdir=${HEIMDAL_HDB_DIR}
1.80      adam       37: CONFIGURE_ARGS+=       --with-openssl=${SSLBASE:Q}
                     38: CONFIGURE_ARGS+=       --with-sqlite3=${BUILDLINK_PREFIX.sqlite3}
1.1       jlam       39: CONFIGURE_ARGS+=       --without-x
1.65      jlam       40: CONFIGURE_ARGS+=       ${ABI:D--with-mips-abi=${ABI}}
                     41: CONFIGURE_ENV+=                COMPILE_ET=no   # build Heimdal's compile_et(1)
1.80      adam       42: # XXX Grand Central Dispatch is broken in 1.4
                     43: CONFIGURE_ENV+=                ac_cv_funclib_dispatch_async_f=no
1.1       jlam       44:
1.101     adam       45: .include "../../mk/bdb.buildlink3.mk"
                     46:
                     47: # XXX Don't detect db1 when a newer version is available; otherwise build fails
                     48: .if ${BDB_TYPE} != "db1"
                     49: CONFIGURE_ENV+=                ac_cv_funclib_dbopen=no
                     50: .endif
                     51:
1.45      jlam       52: CFLAGS.Darwin+=                -DBIND_8_COMPAT
1.39      yyamano    53:
1.121     jperkin    54: # Newer illumos has extended functions in glob(3C) but it's easier to
                     55: # say it doesn't for simpler PLIST.glob handling.
                     56: CONFIGURE_ENV.SunOS+=  ac_cv_func_glob_working=no
                     57:
1.44      rillig     58: # Though Solaris has a <vis.h> header, it does something very unrelated
                     59: # to the BSD <vis.h> header.
                     60: CONFIGURE_ENV.SunOS+=  ac_cv_header_vis_h=no
                     61:
1.100     jperkin    62: .include "../../mk/readline.buildlink3.mk"
                     63:
                     64: .if ${READLINE_TYPE} == "readline"
1.99      ryoon      65: CONFIGURE_ARGS+=       --with-readline=${BUILDLINK_PREFIX.editlinereadline}
1.100     jperkin    66: .elif ${READLINE_TYPE} == "editline"
                     67: CONFIGURE_ARGS+=       --with-libedit=${BUILDLINK_PREFIX.editlinereadline}
                     68: .endif
1.1       jlam       69:
1.102     joerg      70: PLIST_VARS+=           glob vis
1.103     richard    71: .if ${OPSYS} == "SunOS"
                     72: PLIST.vis=     yes
                     73: PLIST.glob=    yes
                     74: .endif
1.102     joerg      75:
1.105     ryoon      76: # Linux does not have include/vis.h and expected include/glob.h.
                     77: .if ${OPSYS} == "Linux"
                     78: PLIST.vis=     yes
                     79: PLIST.glob=    yes
1.119     tnn        80: # Without this I get undefined references to pthread_getspecific
                     81: PTHREAD_AUTO_VARS=     yes
1.105     ryoon      82: .endif
                     83:
1.71      jwise      84: PLIST_VARS+=           afskauth hcrypto
1.63      rillig     85: .if ${OPSYS} == "IRIX"
1.69      jlam       86: PLIST.afskauth=                yes
1.63      rillig     87: .endif
1.89      fhajny     88:
1.83      sbd        89: OWN_DIRS_PERMS=                ${HEIMDAL_HDB_DIR} ${REAL_ROOT_USER} ${REAL_ROOT_GROUP} 0700
1.65      jlam       90: SPECIAL_PERMS+=                ${PREFIX}/bin/otp ${SETUID_ROOT_PERMS}
1.45      jlam       91: SPECIAL_PERMS=         ${PREFIX}/bin/${KRB5_PREFIX}su ${SETUID_ROOT_PERMS}
                     92: RCD_SCRIPTS=           kadmind kcm kdc kpasswdd
1.72      shattere   93: INFO_FILES=            yes
1.1       jlam       94:
1.86      asau       95: TEST_TARGET=           check
                     96:
1.80      adam       97: # remove manpages conficting with OpenSSL keeping only the important ones
                     98: pre-configure:
                     99:        cd ${WRKSRC}/doc/doxyout/hcrypto && \
                    100:        ${GREP} -e /hcrypto_ -e /page_ manpages > manpages.new && \
                    101:        mv manpages.new manpages
                    102:
1.91      jperkin   103: # Avoid 'cat: cannot open ./localefiles: No such file or directory'
                    104: pre-build:
                    105:        ${TOUCH} ${WRKSRC}/po/localefiles
                    106:
1.80      adam      107: .include "../../databases/sqlite3/buildlink3.mk"
1.65      jlam      108: .include "../../security/openssl/buildlink3.mk"
1.109     obache    109: CHECK_BUILTIN.openssl:=        yes
                    110: .include "../../security/openssl/builtin.mk"
                    111: CHECK_BUILTIN.openssl:=no
                    112: .if ${MACHINE_PLATFORM:MNetBSD-[1-3]*} != "" || \
                    113:     (${OPSYS} == "SunOS" && !empty(USE_BUILTIN.openssl:Myes) &&        \
                    114:                !empty(BUILTIN_LIB_FOUND.crypto:M[Nn][Oo]))
                    115: PLIST.hcrypto=         yes
                    116: .endif
                    117:
1.111     bsiegert  118: .if ${OPSYS} == "MirBSD"
                    119: .if !empty(USE_BUILTIN.openssl:Myes)
                    120: PLIST.hcrypto=         yes
                    121: .endif
                    122: PLIST.vis=             yes
                    123: # all of the tools need to link against pthread, force it.
                    124: PTHREAD_AUTO_VARS=     yes
                    125: .endif
                    126:
1.104     roy       127: .include "../../mk/termcap.buildlink3.mk"
1.80      adam      128: .include "../../mk/pthread.buildlink3.mk"
1.101     adam      129: .include "../../mk/readline.buildlink3.mk"
1.1       jlam      130: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>