[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / gsasl

File: [cvs.NetBSD.org] / pkgsrc / security / gsasl / Makefile (download)

Revision 1.28, Thu Jun 4 18:38:30 2009 UTC (14 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.27: +3 -5 lines

Changes 1.1:
* Reading integrity protected data from server now works.
* The --quality-of-protection parameter now works.
* Only detect sufficiently recent GnuTLS versions.

Changes 1.0:
* New parameter --priority to specify GnuTLS priority strings.
* Print web page links in --help, per new GNU coding standard.
* New self-test for the gsasl_client_suggest_mechanism function.
* Modernize doxygen configuration.
* Use permissive license for man pages.
* Change license on the manual to GFDLv1.3+.

# $NetBSD: Makefile,v 1.28 2009/06/04 18:38:30 adam Exp $

DISTNAME=	gsasl-1.1
CATEGORIES=	security
MASTER_SITES=	${MASTER_SITE_GNU:=gsasl/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.gnu.org/software/gsasl/
COMMENT=	GNU implementation of the Simple Authentication and Security Layer

PKG_DESTDIR_SUPPORT=	user-destdir

USE_TOOLS+=		msgfmt pkg-config
USE_LIBTOOL=		yes
USE_PKGLOCALEDIR=	yes
GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--disable-gtk-doc
CONFIGURE_ARGS+=	--with-gssapi-impl=${GSSIMPL.${KRB5_TYPE}}
CONFIGURE_ARGS+=	--with-html-dir=${PREFIX}/share/doc/html
CONFIGURE_ARGS+=	--with-libgcrypt
GSSIMPL.heimdal=	heimdal
GSSIMPL.mit-krb5=	mit

PKGCONFIG_OVERRIDE+=	lib/libgsasl.pc.in
INFO_FILES=		yes
TEST_TARGET=		check

.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/libidn/buildlink3.mk"
.include "../../devel/libntlm/buildlink3.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../security/gnutls/buildlink3.mk"
.include "../../security/libgcrypt/buildlink3.mk"
.include "../../mk/krb5.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"