File:
[cvs.NetBSD.org] /
pkgsrc /
security /
gpgme /
Makefile
Revision
1.111:
download - view:
text,
annotated -
select for diffs
Tue Jul 11 07:12:43 2023 UTC (18 months ago) by
adam
Branches:
MAIN
CVS tags:
HEAD
gpgme: updated to 1.21.0
Noteworthy changes in version 1.21.0 (2023-07-07)
-------------------------------------------------
* Extended gpgme_op_encrypt, gpgme_op_encrypt_sign, and gpgme_op_sign
to allow writing the output directly to a file. [T6530]
* Extended gpgme_op_decrypt and gpgme_op_verify to allow reading the
input data directly from files. [T6530]
* For key signing and uid revoking allow an empty user id.
[rMfbc3963d62]
* Pass an input-size-hint also to the gpgsm engine. [T6534]
* qt: Allow writing the created archives directly to a
file. [T6530]
* qt: Allow reading the signed/encrypted archive to decrypt
or verify directly from a file. [T6530]
* qt: Qt Jobs working with QIODeviceDataProvider now properly
handle input-size hints and progress for files larger.
2^32 bytes in 32 bit builds. [T6534]
* cpp: Error::isCanceled now also returns true for error code
GPG_ERR_FULLY_CANCELED. [T6510]
* python: Fix wrong use of write. [T6501]
# $NetBSD: Makefile,v 1.111 2023/07/11 07:12:43 adam Exp $
DISTNAME= gpgme-1.21.0
CATEGORIES= security
MASTER_SITES= https://www.gnupg.org/ftp/gcrypt/gpgme/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://www.gnupg.org/related_software/gpgme/
COMMENT= GnuPG Made Easy
LICENSE= gnu-gpl-v2
USE_LANGUAGES+= c99 c++
USE_LIBTOOL= yes
USE_TOOLS+= gmake
GNU_CONFIGURE= yes
PTHREAD_OPTS+= require
INFO_FILES= yes
CONFIGURE_ARGS+= --enable-languages="cl cpp"
# configure: error: A compiler with c++11 support is required for the c++ binding.
GCC_REQD+= 4.8
SUBST_CLASSES+= pthread
SUBST_FILES.pthread= src/gpgme-config.in
SUBST_SED.pthread+= -e 's,@PTHREAD_LIBS@,${PTHREAD_LDFLAGS} ${PTHREAD_LIBS},g'
SUBST_VARS.pthread= PTHREAD_CFLAGS
SUBST_STAGE.pthread= pre-configure
CPPFLAGS.Darwin= -D_POSIX_C_SOURCE=200809L
LIBS.SunOS+= -lnsl -lsocket
BUILDLINK_TRANSFORM+= rm:-Wsuggest-override
TEST_TARGET= all
TEST_DIRS= tests
.include "options.mk"
.include "../../security/libassuan2/buildlink3.mk"
BUILDLINK_API_DEPENDS.libgpg-error+= libgpg-error>=1.28
.include "../../security/libgpg-error/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>