[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / gpg2dot

File: [cvs.NetBSD.org] / pkgsrc / security / gpg2dot / Makefile (download)

Revision 1.15, Tue Oct 23 18:16:29 2012 UTC (10 years, 7 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.14: +1 -3 lines

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.15 2012/10/23 18:16:29 asau Exp $
#

DISTNAME=	gpg2dot-1.5
PKGREVISION=	1
CATEGORIES=	security
MASTER_SITES=	# empty
DISTFILES=	# empty

MAINTAINER=	lukem@NetBSD.org
HOMEPAGE=	ftp://ftp.NetBSD.org/pub/NetBSD/packages/pkgsrc/doc/pkgsrc.html
COMMENT=	Converts your GnuPG keyring to a graph of associations

USE_LANGUAGES=	# empty
USE_TOOLS+=	perl:run

NO_CONFIGURE=	yes

DISTVER=	${DISTNAME:S/gpg2dot-//}
WRKSRC=		${WRKDIR}

INSTALLATION_DIRS=	bin

do-extract:
	${CP} ${FILESDIR}/gpg2dot.pl ${WRKSRC}/gpg2dot.pl
#	${CP} ${FILESDIR}/gpg2dot.1 ${WRKSRC}/gpg2dot.1.in

do-build:
.for FILE in gpg2dot
	${SED} -e 's|@PREFIX@|${PREFIX}|g'		\
		-e 's|@DISTVER@|${DISTVER}|g'		\
		< ${WRKSRC}/${FILE}.pl 			\
		> ${WRKSRC}/${FILE}
.endfor
#.for FILE in gpg2dot
#	${SED} -e ''					\
#		< ${WRKSRC}/${FILE}.1.in		\
#		> ${WRKSRC}/${FILE}.1
#.endfor

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/gpg2dot ${DESTDIR}${PREFIX}/bin/gpg2dot
#	${INSTALL_MAN} ${WRKSRC}/gpg2dot.1 ${PREFIX}/${PKGMANDIR}/man1

.include "../../mk/bsd.pkg.mk"