[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / gnutls

Annotation of pkgsrc/security/gnutls/Makefile, Revision 1.190.2.1

1.190.2.1! spz         1: # $NetBSD$
1.1       salo        2:
1.190.2.1! spz         3: DISTNAME=      gnutls-3.6.4
1.1       salo        4: CATEGORIES=    security devel
1.176     wiz         5: MASTER_SITES=  ftp://ftp.gnutls.org/gcrypt/gnutls/v3.6/
1.114     drochner    6: EXTRACT_SUFX=  .tar.xz
1.1       salo        7:
1.43      jlam        8: MAINTAINER=    pkgsrc-users@NetBSD.org
1.1       salo        9: HOMEPAGE=      http://www.gnutls.org/
                     10: COMMENT=       GNU Transport Layer Security library
1.84      wiz        11: LICENSE=       gnu-gpl-v3 AND gnu-lgpl-v2.1
1.1       salo       12:
1.180     youri      13: USE_LANGUAGES=                 c c++
                     14: USE_LIBTOOL=                   yes
                     15: USE_PKGLOCALEDIR=              yes
1.187     wiz        16: USE_TOOLS+=                    gmake gsed perl pkg-config bash
1.180     youri      17: GNU_CONFIGURE=                 yes
1.102     adam       18: # this library duplicates (and conflicts with) openssl
1.180     youri      19: CONFIGURE_ARGS+=               --disable-openssl-compatibility
                     20: CONFIGURE_ARGS+=               --disable-guile
                     21: CONFIGURE_ARGS+=               --disable-libdane
1.190     tnn        22: CONFIGURE_ARGS+=               --without-idn
1.180     youri      23: CONFIGURE_ARGS+=               --without-tpm
                     24: CONFIGURE_ARGS+=               --disable-valgrind-tests
                     25: CONFIGURE_ARGS+=               --with-libintl-prefix=${BUILDLINK_PREFIX.gettext}
1.181     leot       26: CONFIGURE_ARGS+=               --enable-local-libopts
1.170     adam       27: # Assembler support is broken for SunOS in 3.2.9.
1.180     youri      28: CONFIGURE_ARGS.SunOS+=         --disable-hardware-acceleration
                     29: CONFIGURE_ARGS.FreeBSD+=       ac_cv_type_max_align_t=yes
1.102     adam       30:
1.169     wiz        31: # as of 3.5.8, 0 test failures
1.26      wiz        32: TEST_TARGET=           check
1.169     wiz        33: # without the USE_TOOLS line below, the fastopen.sh test fails
1.163     wiz        34: # but when this line is added, the tool path for bash is embedded
                     35: # in to the binaries, so only enable this for testing and
                     36: # disable before commit
                     37: #USE_TOOLS+=           bash
1.166     wiz        38:
1.58      tron       39: INFO_FILES=            yes
1.24      wiz        40:
1.185     wiz        41: REPLACE_BASH+=         tests/cert-tests/certtool
1.168     maya       42: REPLACE_BASH+=         tests/danetool.sh
1.185     wiz        43: REPLACE_BASH+=         tests/fastopen.sh
1.184     wiz        44: REPLACE_BASH+=         tests/gnutls-cli-debug.sh
1.168     maya       45: REPLACE_BASH+=         tests/ocsp-tests/ocsp-must-staple-connection
                     46: REPLACE_BASH+=         tests/ocsp-tests/ocsp-tls-connection
1.185     wiz        47: REPLACE_BASH+=         tests/starttls.sh
                     48: REPLACE_BASH+=         tests/suite/cbc-record-check.sh
                     49: REPLACE_BASH+=         tests/suite/testcompat-main-openssl
1.168     maya       50: REPLACE_BASH+=         tests/suite/testcompat-main-polarssl
1.189     wiz        51: REPLACE_BASH+=         tests/cert-tests/pkcs12-utf8
1.163     wiz        52:
1.185     wiz        53: REPLACE_PERL+=         doc/scripts/gdoc doc/scripts/sort2.pl
1.101     drochner   54:
1.22      jmmv       55: PKGCONFIG_OVERRIDE=    lib/gnutls.pc.in
1.133     wiz        56: PKGCONFIG_OVERRIDE+=   libdane/gnutls-dane.pc.in
1.22      jmmv       57:
1.35      wiz        58: MAKE_ENV+=             RM=${RM:Q}
1.25      wiz        59: MAKE_ENV+=             TZ=UTC
1.17      grant      60:
1.187     wiz        61: SUBST_CLASSES+=                shell
                     62: SUBST_SED.shell+=      -e 's,define POSIX_SHELL .*,define POSIX_SHELL "'${TOOLS_PATH.bash}'",'
                     63: SUBST_STAGE.shell=     post-configure
                     64: SUBST_FILES.shell+=    config.h
                     65: SUBST_MESSAGE.shell=   Fixing path to bash.
                     66:
1.1       salo       67: EGDIR=         ${PREFIX}/share/examples/gnutls
                     68:
1.173     jlam       69: INSTALLATION_DIRS=     ${EGDIR} include/gnutls
1.15      jmmv       70:
1.1       salo       71: post-install:
1.53      joerg      72:        cd ${WRKSRC}/doc/examples && ${INSTALL_DATA} *.c ${DESTDIR}${EGDIR}
1.1       salo       73:
1.32      adam       74: .include "../../archivers/lzo/buildlink3.mk"
1.39      adam       75: .include "../../converters/libiconv/buildlink3.mk"
1.10      jlam       76: .include "../../devel/gettext-lib/buildlink3.mk"
1.180     youri      77: BUILDLINK_API_DEPENDS.gmp+=            gmp>=5.0
1.170     adam       78: .include "../../devel/gmp/buildlink3.mk"
1.33      adam       79: .include "../../devel/libcfg+/buildlink3.mk"
1.160     dbj        80: # Avoid creating a fake zlib.pc, because if it does
                     81: # gnutls will add a Requires.private for it in its .pc file
                     82: CHECK_BUILTIN.zlib:=yes
1.10      jlam       83: .include "../../devel/zlib/buildlink3.mk"
1.170     adam       84: # guile is useful for selftests, but bindings should be separate pkgs
                     85: #.include "../../lang/guile20/buildlink3.mk"
1.169     wiz        86: BUILDLINK_API_DEPENDS.libtasn1+=       libtasn1>=4.9
1.10      jlam       87: .include "../../security/libtasn1/buildlink3.mk"
1.163     wiz        88: BUILDLINK_API_DEPENDS.nettle+=         nettle>=3.1
1.99      adam       89: .include "../../security/nettle/buildlink3.mk"
1.177     wiz        90: BUILDLINK_API_DEPENDS.p11-kit+=        p11-kit>=0.23.1
                     91: .include "../../security/p11-kit/buildlink3.mk"
1.169     wiz        92: .include "../../textproc/libunistring/buildlink3.mk"
1.170     adam       93: .include "../../mk/readline.buildlink3.mk"
1.1       salo       94: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>