[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / security / fprot-workstation-bin

File: [cvs.NetBSD.org] / pkgsrc / security / fprot-workstation-bin / Attic / Makefile (download)

Revision 1.25, Thu Jan 26 04:48:26 2006 UTC (18 years, 2 months ago) by ben
Branch: MAIN
Changes since 1.24: +2 -2 lines

Update fprot-workstation-bin to version 4.6.5.

This addresses pr/32620, using the patch provided by Christian Gall.

Notable changes include:
* Fixed an endless loop encountered in a corrupted WMF sample.
* A bug in the ELF scanner could cause a crash.
* Using a symlink as a path element to f-protd could cause f-protd not to
  start.
* A race issue with startproc (start-stop-daemon in LSB terms) could lead
  to old DEF files being used by f-protd even after updates.
* UPX packed files could cause crash on Solaris/sparc.
* Better handling for corrupt mime files.
* A bug in MS office scanner on big-endian platforms was fixed.
* Anomy extended to do content-type fingerprinting which allows
  scan-mail.pl to block attachments with false extension based on their
  'real' extensions,
  e.g. .wmf files claiming to be .jpg or .png files.
* A bug in scan-mail.pl's rc-script, which could cause problems in Debian
  when shutting scan-mail.pl down, has been fixed.
* Tweaks and optimizations should improve scanning speed by appr. 15-40%
  over previous releases.
* Engine version 3.16.10 will now try to scan zip files which falsly claim
  to use 64-bit compression methods. 64 bit compression is not supported,
  but the scanner will now try to scan those files using 32 bit methods.
* Improved handling of some types of corrupt files, which were previously
  skipped with I/O error.
* A corrupt arj file could crash the scanner. This has been fixed.
* Fixed a bug in scan-mail.pl where attachments would sometimes be left in
  quarantine.
* Trying to scan a device special file now results in non-zero exit code.
* Scanning of redirected stdin is now possible, e.g. 'f-prot /dev/fd/0 <
  /path/to/file'

# $NetBSD: Makefile,v 1.25 2006/01/26 04:48:26 ben Exp $
#

DISTNAME=		#defined
PKGNAME=		fprot-workstation-bin-4.6.5
CATEGORIES=		security

MAINTAINER=		ben@NetBSD.org
HOMEPAGE=		http://www.f-prot.com/products/home_use/bsd/
COMMENT=		F-prot antivirus for home users

DEPENDS+=		p5-libwww>=5.69:../../www/p5-libwww
DEPENDS+=		unzip-[0-9]*:../../archivers/unzip

PKG_INSTALLATION_TYPES= overwrite pkgviews

ONLY_FOR_PLATFORM=	NetBSD-*-i386 Linux-*-i386 SunOS-*-sparc
RESTRICTED=		"Redistribution not permitted"
NO_SRC_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_FTP=		${RESTRICTED}
NO_SRC_ON_FTP=		${RESTRICTED}
LICENSE=		fprot-workstation-license

WRKSRC=			${WRKDIR}/f-prot
NO_BUILD=		yes
USE_TOOLS+=		perl:run

DATDIR=			${PREFIX}/share/fprot-workstation-bin
DOCDIR=			${PREFIX}/share/doc/fprot-workstation-bin
FPDIR=			${PREFIX}/libexec/fprot-workstation-bin
CONF_FILES=		${DATDIR}/MACRO.DEF ${FPDIR}/MACRO.DEF
CONF_FILES+=		${DATDIR}/SIGN.DEF ${FPDIR}/SIGN.DEF
CONF_FILES+=		${DATDIR}/SIGN2.DEF ${FPDIR}/SIGN2.DEF
OWN_DIRS=               ${FPDIR}

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "NetBSD"
MASTER_SITES=		ftp://ftp.f-prot.com/pub/bsd/
DISTNAME=		fp-netbsd-ws-${PKGVERSION}
.endif

.if ${OPSYS} == "Linux"
MASTER_SITES=		ftp://ftp.f-prot.com/pub/linux/
DISTNAME=		fp-linux-ws-${PKGVERSION}
.endif

.if ${OPSYS} == "SunOS"
MASTER_SITES=		ftp://ftp.f-prot.com/pub/solaris/
DISTNAME=		fp-solaris-sparc-ws-${PKGVERSION}
.endif

DIST_SUBDIR=		${DISTNAME}

SUBST_CLASSES+=		f-prot
SUBST_MESSAGE.f-prot=	"Configuring f-prot location."
SUBST_STAGE.f-prot=	post-patch
SUBST_FILES.f-prot=	f-prot.sh
SUBST_SED.f-prot=	-e "s,^exec \`.*\`,exec ${FPDIR}/f-prot,g"

SUBST_CLASSES+=		paths
SUBST_MESSAGE.paths=	"Configuring default paths."
SUBST_STAGE.paths=	post-patch
SUBST_FILES.paths=	tools/check-updates.pl
SUBST_SED.paths=	-e "s,XXXFPDIRXXX,${FPDIR}," \
			-e "s,/usr/bin/perl,${PREFIX}/bin/perl,g"

INSTALLATION_DIRS=	bin man/man1 man/man8 sbin

do-install:
	${INSTALL_SCRIPT} ${WRKSRC}/f-prot.sh ${PREFIX}/bin/f-prot
	${INSTALL_SCRIPT} ${WRKSRC}/tools/check-updates.pl ${PREFIX}/sbin
	${INSTALL_MAN} ${WRKSRC}/man_pages/check-updates.pl.8 ${PREFIX}/man/man8
	${INSTALL_MAN} ${WRKSRC}/man_pages/f-prot.1 ${PREFIX}/man/man1
	${INSTALL_DATA_DIR} ${DATDIR}
	${INSTALL_DATA} ${WRKSRC}/*.DEF ${DATDIR}
	${INSTALL_DATA_DIR} ${DOCDIR}
	${INSTALL_DATA} ${WRKSRC}/LICENSE* ${WRKSRC}/README ${WRKSRC}/CHANGES \
		${WRKSRC}/doc_ws/* ${DOCDIR}
	${INSTALL_PROGRAM_DIR} ${FPDIR}
	${INSTALL_DATA} ${WRKSRC}/ENGLISH.TX0 ${FPDIR}
	${INSTALL_PROGRAM} ${WRKSRC}/f-prot ${FPDIR}

.include "../../mk/bsd.pkg.mk"