The NetBSD Project

CVS log for pkgsrc/security/cyrus-sasl/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / security / cyrus-sasl

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.81 / (download) - annotate - [select for diffs], Tue Jun 28 11:35:34 2022 UTC (7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, HEAD
Changes since 1.80: +2 -1 lines
Diff to previous 1.80 (colored)

*: recursive bump for perl 5.36

Revision 1.80 / (download) - annotate - [select for diffs], Thu Feb 24 11:00:03 2022 UTC (11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.79: +1 -2 lines
Diff to previous 1.79 (colored)

cyrus-sasl: update to 2.1.28

New in 2.1.28

    build:
        configure - Restore LIBS after checking gss_inquire_sec_context_by_oid
        makemd5.c - Fix potential out of bound writes
        fix build with isable-shared nable-static
        Dozens of fixes for Windows specific builds
        Fix cross platform builds with SPNEGO
        Do not try to build broken java subtree
        Fix build error with nable-auth-sasldb
    common:
        plugin_common.c:
            Ensure size is always checked if called repeatedly (#617)
    documentation:
        Fixed generation of saslauthd(8) man page
        Fixed installation of saslauthd(8) and testsaslauthd(8) man pages (#373)
        Updates for additional SCRAM mechanisms
        Fix sasl_decode64 and sasl_encode64 man pages
        Tons of fixes for Sphinx
    include:
        sasl.h:
            Allow up to 16 bits for security flags
    lib:
        checkpw.c:
            Skip one call to strcat
            Disable auxprop-hashed (#374)
        client.c:
            Use proper length for fully qualified domain names
        common.c:
            CVE-2019-19906 Fix off by one error (#587)
        external.c:
            fix EXTERNAL with non-terminated input (#689)
        saslutil.c:
            fix index_64 to be a signed char (#619)
    plugins:
        gssapi.c:
            Emit debug log only in case of errors
        ntlm.c:
            Fail compile if MD4 is not available (#632)
        sql.c:
            Finish reading residual return data (#639)
            CVE-2022-24407 Escape password for SQL insert/update commands.
    sasldb:
        db_gdbm.c:
            fix gdbm_errno overlay from gdbm_close
    DIGEST-MD5 plugin:
        Prevent double free of RC4 context
        Use OpenSSL RC4 implementation if available
    SCRAM plugin:
        Return BADAUTH on incorrect password (#545)
        Add -224, -384, -512 (#552)
        Remove SCRAM_HASH_SIZE
        Add function to return SCRAM auth method name
        Allocate enough memory in scam_setpass()
        Add function to sort SCRAM methods by hash strength
        Update windows build for newer SCRAM options
    saslauthd:
        auth_httpform.c:
            Avoid signed overflow with non-ascii characters (#576)
        auth_krb5.c:
            support setting an explicit auth_krb5 server name
            support setting an explicit servername with Heimdal
            unify the MIT and Heimdal auth_krb5 implementations
            Remove call to krbtf
        auth_rimap.c:
            provide native memmem implementation if missing
        lak.c:
            Allow LDAP_OPT_X_TLS_REQUIRE_CERT to be 0 (no certificate verification)
        lak.h:
            Increase supported DN length to 4096 (#626)

Revision 1.79 / (download) - annotate - [select for diffs], Mon May 24 19:53:51 2021 UTC (20 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.78: +2 -2 lines
Diff to previous 1.78 (colored)

*: recursive bump for perl 5.34

Revision 1.76.2.1 / (download) - annotate - [select for diffs], Fri May 15 16:38:30 2020 UTC (2 years, 8 months ago) by bsiegert
Branch: pkgsrc-2020Q1
Changes since 1.76: +2 -1 lines
Diff to previous 1.76 (colored) next main 1.77 (colored)

Pullup ticket #6196 - requested by nia
security/cyrus-sasl: security fix

Revisions pulled up:
- security/cyrus-sasl/Makefile                                  1.77
- security/cyrus-sasl/distinfo                                  1.38
- security/cyrus-sasl/patches/patch-CVE-2019-19906              1.1

---
   Module Name:	pkgsrc
   Committed By:	nia
   Date:		Thu May 14 14:27:32 UTC 2020

   Modified Files:
   	pkgsrc/security/cyrus-sasl: Makefile distinfo
   Added Files:
   	pkgsrc/security/cyrus-sasl/patches: patch-CVE-2019-19906

   Log Message:
   cyrus-sasl: Fix CVE-2019-19906

Revision 1.78 / (download) - annotate - [select for diffs], Thu May 14 14:31:16 2020 UTC (2 years, 8 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.77: +3 -3 lines
Diff to previous 1.77 (colored)

cyrus-sasl: Resolve some pkglint warnings

Revision 1.77 / (download) - annotate - [select for diffs], Thu May 14 14:27:31 2020 UTC (2 years, 8 months ago) by nia
Branch: MAIN
Changes since 1.76: +2 -1 lines
Diff to previous 1.76 (colored)

cyrus-sasl: Fix CVE-2019-19906

Revision 1.76 / (download) - annotate - [select for diffs], Mon Nov 4 21:12:52 2019 UTC (3 years, 2 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Branch point for: pkgsrc-2020Q1
Changes since 1.75: +2 -2 lines
Diff to previous 1.75 (colored)

security: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.

Revision 1.75 / (download) - annotate - [select for diffs], Sun Dec 9 21:05:35 2018 UTC (4 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.74: +1 -2 lines
Diff to previous 1.74 (colored)

Removed commented-out PKGREVISIONs

Revision 1.74 / (download) - annotate - [select for diffs], Tue Apr 17 01:57:17 2018 UTC (4 years, 9 months ago) by christos
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.73: +3 -3 lines
Diff to previous 1.73 (colored)

upgrade to 2.1.27-rc7 so that we can use it with openssl-1.1

Revision 1.73 / (download) - annotate - [select for diffs], Sun Jan 28 20:11:03 2018 UTC (5 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.72: +2 -2 lines
Diff to previous 1.72 (colored)

Bump PKGREVISION for gdbm shlib major bump

Revision 1.71.6.1 / (download) - annotate - [select for diffs], Mon May 1 09:36:49 2017 UTC (5 years, 9 months ago) by bsiegert
Branch: pkgsrc-2017Q1
Changes since 1.71: +2 -2 lines
Diff to previous 1.71 (colored) next main 1.72 (colored)

Pullup ticket #5381 - requested by sevan
security/cyrus-sasl: build fix

Revisions pulled up:
- security/cy2-anonymous/Makefile                               1.10
- security/cy2-crammd5/Makefile                                 1.10
- security/cy2-digestmd5/Makefile                               1.20
- security/cy2-gssapi/Makefile                                  1.26
- security/cy2-ldapdb/Makefile                                  1.12
- security/cy2-login/Makefile                                   1.17
- security/cy2-ntlm/Makefile                                    1.28
- security/cy2-otp/Makefile                                     1.21
- security/cy2-plain/Makefile                                   1.10
- security/cy2-scram/Makefile                                   1.8
- security/cy2-sql/Makefile                                     1.34
- security/cyrus-sasl/Makefile                                  1.72
- security/cyrus-sasl/Makefile.common                           1.26
- security/cyrus-saslauthd/Makefile                             1.52

---
   Module Name:    pkgsrc
   Committed By:   jperkin
   Date:           Thu Apr 27 13:56:47 UTC 2017

   Modified Files:
           pkgsrc/security/cy2-anonymous: Makefile
           pkgsrc/security/cy2-crammd5: Makefile
           pkgsrc/security/cy2-digestmd5: Makefile
           pkgsrc/security/cy2-gssapi: Makefile
           pkgsrc/security/cy2-ldapdb: Makefile
           pkgsrc/security/cy2-login: Makefile
           pkgsrc/security/cy2-ntlm: Makefile
           pkgsrc/security/cy2-otp: Makefile
           pkgsrc/security/cy2-plain: Makefile
           pkgsrc/security/cy2-scram: Makefile
           pkgsrc/security/cy2-sql: Makefile
           pkgsrc/security/cyrus-sasl: Makefile Makefile.common
           pkgsrc/security/cyrus-saslauthd: Makefile

   Log Message:
   Fix to use PKG_SYSCONFDIR.  Bump PKGREVISION for all packages using the
   shared Makefile.common.

Revision 1.72 / (download) - annotate - [select for diffs], Thu Apr 27 13:56:47 2017 UTC (5 years, 9 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.71: +2 -2 lines
Diff to previous 1.71 (colored)

Fix to use PKG_SYSCONFDIR.  Bump PKGREVISION for all packages using the
shared Makefile.common.

Revision 1.71 / (download) - annotate - [select for diffs], Sun Sep 11 06:11:15 2016 UTC (6 years, 4 months ago) by richard
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Branch point for: pkgsrc-2017Q1
Changes since 1.70: +2 -2 lines
Diff to previous 1.70 (colored)

Add 'db6' to supported bdb versions and finally commit ipctype 'doors'
for SunOS, while fixing a declaration prototype to match the definition.
PR pkg/47436
bump PKGREVISION

Revision 1.70 / (download) - annotate - [select for diffs], Thu Oct 9 13:44:53 2014 UTC (8 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.69: +1 -2 lines
Diff to previous 1.69 (colored)

Remove SVR4_PKGNAME, per discussion on tech-pkg.

Revision 1.69 / (download) - annotate - [select for diffs], Wed May 7 15:41:08 2014 UTC (8 years, 8 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.68: +2 -2 lines
Diff to previous 1.68 (colored)

Fix the pkg-config file provided (exec_prefix was undefined).
Bump PKGREVISION.

Revision 1.68 / (download) - annotate - [select for diffs], Fri Jul 12 10:45:02 2013 UTC (9 years, 6 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.67: +2 -2 lines
Diff to previous 1.67 (colored)

Bump PKGREVISION of all packages which create users, to pick up change of
sysutils/user_* packages.

Revision 1.67 / (download) - annotate - [select for diffs], Wed Mar 13 03:31:40 2013 UTC (9 years, 10 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.66: +3 -17 lines
Diff to previous 1.66 (colored)

Convert SASL_DBTYPE variable to option framework, and add gdbm support.
Fixes db name extension in DEINSTALL script for other than ndbm.

Bump PKGREVISION.

Revision 1.66 / (download) - annotate - [select for diffs], Thu Dec 20 22:52:37 2012 UTC (10 years, 1 month ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.65: +2 -1 lines
Diff to previous 1.65 (colored)

sasl.h needs stddef.h to be self-contained. Bump revision.

Revision 1.65 / (download) - annotate - [select for diffs], Sun Dec 16 01:36:44 2012 UTC (10 years, 1 month ago) by obache
Branch: MAIN
Changes since 1.64: +3 -3 lines
Diff to previous 1.64 (colored)

Update cyrus-sasl to 2.1.26.

New in 2.1.26
-------------

* Modernize SASL malloc/realloc callback prototypes
* Added sasl_config_done() to plug a memory leak when using an application
  specific config file
* Fixed PLAIN/LOGIN authentication failure when using saslauthd
  with no auxprop plugins (bug # 3590).
* unlock the mutex in sasl_dispose if the context was freed by another thread
* MINGW32 compatibility patches
* Fixed broken logic in get_fqhostname() when abort_if_no_fqdn is 0
* Fixed some memory leaks in libsasl
* GSSAPI plugin:
 - Fixed a segfault in gssapi.c introduced in 2.1.25.
 - Code refactoring
 - Added support for GSS-SPNEGO SASL mechanism (Unix only), which is also
   HTTP capable
* GS2 plugin:
 - Updated GS2 plugin not to lose minor GSS-API status codes on errors
* DIGEST-MD5 plugin:
 - Correctly send "stale" directive to prevent clients from (re)promtping
   for password
 - Better handling of HTTP reauthentication cases
 - fixed some memory leaks
* SASLDB plugin:
 - Added support for BerkleyDB 5.X or later
* OTP plugin:
 - Removed calling of EVP_cleanup() on plugin shutdown in order to prevent
   TLS from failing in calling applications
* SRP plugin:
 - Removed calling of EVP_cleanup() on plugin shutdown in order to prevent
   TLS from failing in calling applications
* saslauthd:
 - auth_rimap.c: qstring incorrectly appending the closing double quote,
   which might be causing crashes
 - auth_rimap.c: read the whole IMAP greeting
 - better error reporting from some drivers
 - fixed some memory leaks

Revision 1.64 / (download) - annotate - [select for diffs], Tue Oct 23 18:16:24 2012 UTC (10 years, 3 months ago) by asau
Branch: MAIN
Changes since 1.63: +1 -3 lines
Diff to previous 1.63 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.63 / (download) - annotate - [select for diffs], Sat Mar 3 12:54:21 2012 UTC (10 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1
Changes since 1.62: +3 -1 lines
Diff to previous 1.62 (colored)

More pcre PKGREVISION bumps.

Revision 1.62 / (download) - annotate - [select for diffs], Wed Feb 22 15:39:44 2012 UTC (10 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.61: +0 -2 lines
Diff to previous 1.61 (colored)

Revert unintended commits.

Revision 1.61 / (download) - annotate - [select for diffs], Wed Feb 22 15:31:34 2012 UTC (10 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.60: +3 -1 lines
Diff to previous 1.60 (colored)

Mention putty-devel successor.

Revision 1.60 / (download) - annotate - [select for diffs], Fri Feb 10 15:34:10 2012 UTC (10 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.59: +0 -2 lines
Diff to previous 1.59 (colored)

Revert previous on popular request.

Revision 1.59 / (download) - annotate - [select for diffs], Thu Feb 9 11:37:10 2012 UTC (10 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.58: +3 -1 lines
Diff to previous 1.58 (colored)

Compile with PIC flags.
Needed on my 5.99.64/amd64 inside a pbulk (manual build outside
doesn't need it, go figure).

Revision 1.57.2.1 / (download) - annotate - [select for diffs], Thu Oct 20 03:59:45 2011 UTC (11 years, 3 months ago) by tron
Branch: pkgsrc-2011Q3
Changes since 1.57: +2 -2 lines
Diff to previous 1.57 (colored) next main 1.58 (colored)

Pullup ticket #3572 - requested by sbd
lang/python24: build fix
lang/python25: build fix
lang/python26: build fix
lang/python27: build fix
lang/python31: build fix
security/cyrus-sasl: build fix

Revisions pulled up:
- lang/python24/distinfo                                        1.36
- lang/python24/patches/patch-am                                1.7
- lang/python25/distinfo                                        1.18
- lang/python25/patches/patch-am                                1.8
- lang/python26/distinfo                                        1.39
- lang/python26/patches/patch-am                                1.17
- lang/python27/distinfo                                        1.10
- lang/python27/patches/patch-am                                1.4
- lang/python31/distinfo                                        1.4
- lang/python31/patches/patch-am                                1.3
- security/cyrus-sasl/Makefile                                  1.58

---
   Module Name:	pkgsrc
   Committed By:	sbd
   Date:		Tue Oct 18 21:59:19 UTC 2011

   Modified Files:
   	pkgsrc/lang/python24: distinfo
   	pkgsrc/lang/python24/patches: patch-am
   	pkgsrc/lang/python25: distinfo
   	pkgsrc/lang/python25/patches: patch-am
   	pkgsrc/lang/python26: distinfo
   	pkgsrc/lang/python26/patches: patch-am
   	pkgsrc/lang/python27: distinfo
   	pkgsrc/lang/python27/patches: patch-am
   	pkgsrc/lang/python31: distinfo
   	pkgsrc/lang/python31/patches: patch-am
   	pkgsrc/security/cyrus-sasl: Makefile

   Log Message:
   Deal with the fact that if /usr/include/ndbm.h exists on Linux it probably
   belongs to gdbm_compat.  I.E. _don't_ use ndbm on Linux.

Revision 1.58 / (download) - annotate - [select for diffs], Tue Oct 18 21:59:18 2011 UTC (11 years, 3 months ago) by sbd
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.57: +2 -2 lines
Diff to previous 1.57 (colored)

Deal with the fact that if /usr/include/ndbm.h exists on Linux it probably
belongs to gdbm_compat.  I.E. _don't_ use ndbm on Linux.

Revision 1.57 / (download) - annotate - [select for diffs], Sat Sep 17 11:32:02 2011 UTC (11 years, 4 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base
Branch point for: pkgsrc-2011Q3
Changes since 1.56: +15 -4 lines
Diff to previous 1.56 (colored)

Update cyrus-sasl to 2.1.25.
Take maintainership.

New in 2.1.25
-------------

* Make sure that a failed authorization doesn't preclude
  further server-side SASL authentication attempts from working.
* Fixed a crash caused by aborted SASL authentication
  and initiation of another one using the same SASL context.
* (Windows) Fixed the random number generator to actually produce random
  output on each run.
* Be protective against calling sasl_server_step once authentication
  has failed (multiple SASL plugins)
* Fixed several bugs in the mech_avail callback handling
  in the server side code.
* Added support for channel bindings
* Added support for ordering SASL mechanisms by strength (on the client side),
  or using the "client_mech_list" option.
* server_idle needs to obey server's SASL mechanism list from the server
  context.
* Better server plugin API mismatch reporting
* Build:
 - Updated config to the latest GNU snapshot
 - Fixed SASL's libtool MacOS/X 64-bit file magic
* New SASL plugin: SCRAM
* New SASL plugin: GS2
* DIGEST-MD5 plugin:
 -  Allow DIGEST-MD5 plugin to be used for client-side and
    server-side HTTP Digest, including running over non-persistent
    connections (RFC 2617)
 - Use the same username for reauthentication cache lookup and update
 - Minimize the number of auxprop lookups in the server side DIGEST-MD5
   plugin for the most common case when authentication and authorization
   identities are the same.
 - Updated digestmd5_server_mech_step2() to be more defensive against
   empty client input.
 - Fixed some memory leaks on failed plugin initialization.
   Prevent potential race condition when freeding plugin state.
   Set the freed reauthentication cache mutex to NULL, to make errors
   due to mutex access after free more obvious.
 - Test against broken UTF-8 based hashes if calculation using special
   ISO-8859-1 code fails.
 - Fixed an interop problem with some LDAP clients ignoring server
   advertised realm and providing their own.
* GSSAPI plugin:
 - Fix to build GSSAPI with Heimdal
 - Properly set serveroutlen to 0 in one place.
   Don't send empty challenge once server context establishment is done,
   as this is in violation of the RFC 2222 and its successor.
 - Don't send maxbuf, if no security layer can be established.
   Added additional checks for buffer lengths.
* LDAPDB plugin:
 - build fixes

New in 2.1.24
-------------

* Order advertised server-side SASL mechanisms per the specified 'mech_list'
  option or by relative "strength"
* Make sure that sasl_set_alloc() has no effect once sasl_client_init()
  or sasl_server_init() is called
* Fixed sasl_set_mutex() to disallow changing mutex management functions
  once sasl_server_init()/sasl_client_init() is called (bug # 3083)
* Removed unused mutexes in lib/client.c and lib/server.c (bug # 3141)
* Added direct support for hashed password to auxprop API
* Don't treat a constraint violation as an error to store an auxprop property
* Extended libsasl (auxprop) to support user deletion
* Extended SASL auxprop_lookup to return error code
* Updated sasl_user_exists() so that it can handle passwordless accounts (e.g. disabled)
* (Windows) Free handles of shared libraries on Windows that were loaded
  but are not SASL plugins (bug # 2089)
* Prevent freeing of common state on a subsequent call to _sasl_common_init.
  Make sure that the last global callback always wins.
* Implemented sasl_client_done()/sasl_server_done()
* Added automatic hostname canonicalization inside libsasl
* Made sasl_config_init() public
* Strip trailing spaces from server config file option values (bug # 3139, bug # 3041)
* Fixed potential buffer overflow in saslautd_verify_password().
* Fixed segfault in dlclose() on HPUX
* Various bugfixes for 64bit platforms
* Fixed bug # 2895 (passing LF to sasl_decode64) in sample/sample-client.c,
  sample/sample-server.c, utils/smtptest.c
* pluginviewer: Code cleanup, improved human readable messages
* Build:
 - (Windows) Updated makefiles to build with VC 8.0 (VC++ 2005)
 - (Windows) Added Windows64 build
 - Updated to use .plugin extension on MacOS
 - Changed 64bit HP-UX build to use .so for shared libraries
* saslauthd:
 - Fixed bug counting double-quotes in username/password in
   auth_rimap.c. Also fixed bug zeroing password.
 - auth_krb.c: improved diagnostic in the k5support_verify_tgt() function.
 - auth_sasldb.c: pid_file_lock is created with a mask of 644 instead of 0644
 - auth_shadow.c: Define _XOPEN_SOURCE before including unistd.h,
   so that crypt is correctly defined
 - auth_getpwent.c: Fixed Solaris build
* SASLDB plugin:
 - Fixed spurious 'user not found' errors caused by an attempt
   to delete a non-existent property
 - Added direct support for hashed password to auxprop API
 - Sleepycat driver:  Return SASL_NOUSER instead of SASL_FAIL when the database
   file doesn't exist
 - Ignore properties starting with '*' in the auxprop store function
* SQL plugin:
 - Added support for SQLITE3
 - Uninitialized variables can cause crash when the searched user is not found
 - Added direct support for hashed password
 - Ignore properties starting with '*' in the auxprop store function
* LDAPDB plugin:
 - Added code to extend LDAPDB into a canon_user plugin in addition
   to its existing auxprop plugin functionality
* PLAIN plugin:
 - Advertise SASL_SEC_PASS_CREDENTIALS feature
* LOGIN plugin:
 - Advertise SASL_SEC_PASS_CREDENTIALS feature
* DIGEST-MD5 plugin:
 - Fixed a memory leak in the DIGEST-MD5 security layer
 - Fixed memory leaks in client-side reauth and other places
 - More detailed error reporting.
 - Fixed parsing of challenges/responses with extra commas.
 - Allow for multiple qop options from the server and require
   a single qop option from the client.
* GSSAPI plugin:
 - Check that params->serverFQDN is not NULL before using strlen on it
 - Make auxprop lookup calls optional
* EXTERNAL plugin:
 - Make auxprop lookup calls optional
* NTLM plugin:
 - allow a comma separated list of servernames in 'ntlm_server' option
 - Fixed crash in calculating NTv2 reponse
* OTP plugin:
 - Don't use a stack variable for an OTP prompt (bug # 2822)
 - Downgrade the failure to store OTP secret to debug level
* KERBEROS_V4 plugin:
 - Make auxprop lookup calls optional

Revision 1.56 / (download) - annotate - [select for diffs], Tue Aug 12 10:16:54 2008 UTC (14 years, 5 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, cube-native-xorg-base, cube-native-xorg
Changes since 1.55: +7 -5 lines
Diff to previous 1.55 (colored)

Add DESTDIR support.

Revision 1.55 / (download) - annotate - [select for diffs], Wed Jul 4 20:54:57 2007 UTC (15 years, 7 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, cwrapper
Changes since 1.54: +3 -2 lines
Diff to previous 1.54 (colored)

Make it easier to build and install packages "unprivileged", where
the owner of all installed files is a non-root user.  This change
affects most packages that require special users or groups by making
them use the specified unprivileged user and group instead.

(1) Add two new variables PKG_GROUPS_VARS and PKG_USERS_VARS to
    unprivileged.mk.  These two variables are lists of other bmake
    variables that define package-specific users and groups.  Packages
    that have user-settable variables for users and groups, e.g. apache
    and APACHE_{USER,GROUP}, courier-mta and COURIER_{USER,GROUP},
    etc., should list these variables in PKG_USERS_VARS and PKG_GROUPS_VARS
    so that unprivileged.mk can know to set them to ${UNPRIVILEGED_USER}
    and ${UNPRIVILEGED_GROUP}.

(2) Modify packages to use PKG_GROUPS_VARS and PKG_USERS_VARS.

Revision 1.54 / (download) - annotate - [select for diffs], Thu Feb 22 19:27:07 2007 UTC (15 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.53: +2 -2 lines
Diff to previous 1.53 (colored)

Whitespace cleanup, courtesy of pkglint.
Patch provided by Sergey Svishchev in private mail.

Revision 1.53 / (download) - annotate - [select for diffs], Thu Nov 2 13:02:39 2006 UTC (16 years, 3 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.52: +2 -1 lines
Diff to previous 1.52 (colored)

Force to detect correct library when ${SASL_DBTYPE}=="berkeley".
Reported by David Carrel in pkgsrc-users@.

Revision 1.52 / (download) - annotate - [select for diffs], Sun Apr 23 00:12:41 2006 UTC (16 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.51: +3 -2 lines
Diff to previous 1.51 (colored)

Modify packages that set PKG_USERS and PKG_GROUPS to follow the new
syntax as specified in pkgsrc/mk/install/bsd.pkginstall.mk:1.47.

Revision 1.51 / (download) - annotate - [select for diffs], Tue Apr 18 17:41:30 2006 UTC (16 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.50: +2 -3 lines
Diff to previous 1.50 (colored)

Updated security/cyrus-sasl to 2.1.21.  Changes from version 2.1.20 include:

* lib/dlopen.c: log the reason for opendir() failure
  when loading plugin.
* lib/common.c: honor log level setting
* sample/sample-client.c, sample/sample-server.c: Fixed several
  64 bit portability warnings.
* utils/testsuite.c: Fixed several 64 bit portability warnings.
* utils/saslpasswd.c: Fixed typo in an auxprop name.
* include/saslplug.h, lib/common.c, lib/saslint.h,
  lib/server.c: Added sasl_server_plugin_info().
* lib/common.c: initialize path in case caller didn't.

Revision 1.50 / (download) - annotate - [select for diffs], Thu Apr 13 21:32:40 2006 UTC (16 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.49: +51 -37 lines
Diff to previous 1.49 (colored)

Add current contents of security/cyrus-sasl2, starting its move
to security/cyrus-sasl (to make PKGNAME match directory name).

Revision 1.49, Mon Mar 28 09:39:57 2005 UTC (17 years, 10 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1, pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.48: +1 -1 lines
FILE REMOVED

Remove security/cyrus-sasl and security/cy-login.  These packages
tracked the Cyrus SASL 1.5.x releases, which are no longer maintained.
Adjust packages to use security/cyrus-sasl2 instead for SASL support.
This closes PR pkg/28218 and PR pkg/29736.

Revision 1.48 / (download) - annotate - [select for diffs], Fri Jan 14 05:15:39 2005 UTC (18 years ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1
Changes since 1.47: +3 -3 lines
Diff to previous 1.47 (colored)

Create a pam.buildlink3.mk file that is used by PAM-using packages.
It includes the correct buildlink3.mk file from either Linux-PAM
(security/PAM) or OpenPAM (security/openpam) and eventually will
support solaris-pam.  pam.buildlink3.mk will:

	* set PAMBASE to the base directory of the PAM files;
	* set PAM_TYPE to the PAM implementation used.

There are two variables that can be used to tweak the selection of
the PAM implementation:

PAM_DEFAULT is a user-settable variable whose value is the default
	PAM implementation to use.

PAM_ACCEPTED is a package-settable list of PAM implementations
	that may be used by the package.

Modify most packages that include PAM/buildlink3.mk to include
pam.buildlink3.mk instead.

Revision 1.47 / (download) - annotate - [select for diffs], Tue Dec 28 02:47:48 2004 UTC (18 years, 1 month ago) by reed
Branch: MAIN
Changes since 1.46: +2 -2 lines
Diff to previous 1.46 (colored)

The default location of the pkgsrc-installed rc.d scripts is now
under share/examples/rc.d. The variable name already was named
RCD_SCRIPTS_EXAMPLEDIR.

This is from ideas from Greg Woods and others.

Also bumped PKGREVISION for all packages using RCD_SCRIPTS mechanism
(as requested by wiz).

Revision 1.46 / (download) - annotate - [select for diffs], Sun Oct 3 00:18:08 2004 UTC (18 years, 4 months ago) by tv
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.45: +2 -2 lines
Diff to previous 1.45 (colored)

Libtool fix for PR pkg/26633, and other issues.  Update libtool to 1.5.10
in the process.  (More information on tech-pkg.)

Bump PKGREVISION and BUILDLINK_DEPENDS of all packages using libtool and
installing .la files.

Bump PKGREVISION (only) of all packages depending directly on the above
via a buildlink3 include.

Revision 1.45 / (download) - annotate - [select for diffs], Sun Aug 22 19:32:52 2004 UTC (18 years, 5 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3
Changes since 1.44: +3 -14 lines
Diff to previous 1.44 (colored)

Change the way that legacy USE_* and FOO_USE_* options are converted
into the bsd.options.mk framework.  Instead of appending to
${PKG_OPTIONS_VAR}, it appends to PKG_DEFAULT_OPTIONS.  This causes
the default options to be the union of PKG_DEFAULT_OPTIONS and any
old USE_* and FOO_USE_* settings.

This fixes PR pkg/26590.

Revision 1.44 / (download) - annotate - [select for diffs], Fri Jul 30 21:05:41 2004 UTC (18 years, 6 months ago) by jlam
Branch: MAIN
Changes since 1.43: +34 -14 lines
Diff to previous 1.43 (colored)

Convert to use bsd.options.mk.  The relevant options variable to set
for each package can be determined by invoking:

	make show-var VARNAME=PKG_OPTIONS_VAR

The old options are still supported unless the variable named in
PKG_OPTIONS_VAR is set within make(1) (usually via /etc/mk.conf).

Revision 1.43 / (download) - annotate - [select for diffs], Fri Mar 26 02:27:52 2004 UTC (18 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2004Q2-base, pkgsrc-2004Q2, pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.42: +2 -2 lines
Diff to previous 1.42 (colored)

PKGREVISION bump after openssl-security-fix-update to 0.9.6m.
Buildlink files: RECOMMENDED version changed to current version.

Revision 1.42 / (download) - annotate - [select for diffs], Tue Mar 23 06:13:30 2004 UTC (18 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.41: +7 -5 lines
Diff to previous 1.41 (colored)

bl3ify and convert to use krb5.buildlink3.mk for proper Kerberos
detection and linkage.  This fixes PR 24498.

Revision 1.41 / (download) - annotate - [select for diffs], Wed Nov 12 03:39:42 2003 UTC (19 years, 2 months ago) by jschauma
Branch: MAIN
CVS Tags: pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.40: +2 -2 lines
Diff to previous 1.40 (colored)

PKGREVISION++ after openssl update.

Revision 1.40 / (download) - annotate - [select for diffs], Sat Aug 30 22:51:34 2003 UTC (19 years, 5 months ago) by jlam
Branch: MAIN
Changes since 1.39: +4 -1 lines
Diff to previous 1.39 (colored)

Add definitions for DEINSTALL_EXTRA_TMPL and INSTALL_EXTRA_TMPL if
USE_PKGINSTALL is "YES".  bsd.pkg.install.mk will no longer automatically
pick up a INSTALL/DEINSTALL script in the package directory and assume that
you want it for the corresponding *_EXTRA_TMPL variable.

Revision 1.39 / (download) - annotate - [select for diffs], Wed Mar 19 21:02:00 2003 UTC (19 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.38: +18 -64 lines
Diff to previous 1.38 (colored)

Rearrange some of the Makefile logic so that we can create Cyrus SASL
plugin packages.

Revision 1.38 / (download) - annotate - [select for diffs], Tue Jan 28 22:04:04 2003 UTC (20 years ago) by jlam
Branch: MAIN
CVS Tags: netbsd-1-6-1-base, netbsd-1-6-1
Changes since 1.37: +2 -3 lines
Diff to previous 1.37 (colored)

Instead of including bsd.pkg.install.mk directly in a package Makefile,
have it be automatically included by bsd.pkg.mk if USE_PKGINSTALL is set
to "YES".  This enforces the requirement that bsd.pkg.install.mk be
included at the end of a package Makefile.  Idea suggested by Julio M.
Merino Vidal <jmmv at menta.net>.

Revision 1.37 / (download) - annotate - [select for diffs], Mon Dec 16 10:55:03 2002 UTC (20 years, 1 month ago) by martti
Branch: MAIN
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

On NetBSD use /dev/urandom insted of /dev/random (PR#19275).

Bump PKGREVISION.

Revision 1.36 / (download) - annotate - [select for diffs], Mon Oct 21 06:03:41 2002 UTC (20 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.35: +2 -2 lines
Diff to previous 1.35 (colored)

Fix sasl-config script so that "sasl-config --libs" returns the full list
of libraries and linker flags needed to link against libsasl.  Bump
PKGREVISION and bump the BUILDLINK_DEPENDS as packages will be needing to
use a version of cyrus-sasl with a correct sasl-config.

Revision 1.35 / (download) - annotate - [select for diffs], Mon Oct 7 19:16:46 2002 UTC (20 years, 3 months ago) by seb
Branch: MAIN
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

Use int32_t while dealing with sasldb version not long! This fix cyrus sasl
on sparc64.
Bump PKGREVISION.

Revision 1.34 / (download) - annotate - [select for diffs], Thu Sep 19 09:04:21 2002 UTC (20 years, 4 months ago) by jlam
Branch: MAIN
Changes since 1.33: +1 -11 lines
Diff to previous 1.33 (colored)

Take advantage of the auto-generation and installation of rc.d scripts.

Revision 1.33 / (download) - annotate - [select for diffs], Wed Sep 18 21:15:16 2002 UTC (20 years, 4 months ago) by jlam
Branch: MAIN
Changes since 1.32: +1 -4 lines
Diff to previous 1.32 (colored)

When using bsd.pkg.install.mk, if a DEINSTALL or INSTALL file already
exists, then use it as the default value of DEINSTALL_EXTRA_TMPL or
INSTALL_EXTRA_TMPL.

Revision 1.32 / (download) - annotate - [select for diffs], Sat Sep 7 07:37:37 2002 UTC (20 years, 4 months ago) by jlam
Branch: MAIN
Changes since 1.31: +1 -9 lines
Diff to previous 1.31 (colored)

Remove dependency on autoconf/automake and finish buildlink2 conversion.

Revision 1.31 / (download) - annotate - [select for diffs], Sun Aug 25 18:39:50 2002 UTC (20 years, 5 months ago) by jlam
Branch: MAIN
Changes since 1.30: +7 -6 lines
Diff to previous 1.30 (colored)

Merge changes in packages from the buildlink2 branch that have
buildlink2.mk files back into the main trunk.  This provides sufficient
buildlink2 infrastructure to start merging other packages from the
buildlink2 branch that have already been converted to use the buildlink2
framework.

Revision 1.28.2.3 / (download) - annotate - [select for diffs], Thu Aug 22 11:12:15 2002 UTC (20 years, 5 months ago) by jlam
Branch: buildlink2
Changes since 1.28.2.2: +20 -12 lines
Diff to previous 1.28.2.2 (colored) to branchpoint 1.28 (colored) next main 1.29 (colored)

Merge changes from pkgsrc-current into the buildlink2 branch for the
packages that have buildlink2.mk files.

Revision 1.30 / (download) - annotate - [select for diffs], Wed Jul 31 03:23:06 2002 UTC (20 years, 6 months ago) by jlam
Branch: MAIN
CVS Tags: netbsd-1-6-RELEASE-base, netbsd-1-6, buildlink2-base
Changes since 1.29: +20 -12 lines
Diff to previous 1.29 (colored)

Build and install "saslauthd", a daemon running as root that performs
plaintext password authentication for Cyrus SASL.  This will allow daemons
_not_ running as root to perform SASL PLAIN authentication (including
getpwent and PAM).  Bump PKGREVISION to 1.

Revision 1.29 / (download) - annotate - [select for diffs], Mon Jul 22 19:19:39 2002 UTC (20 years, 6 months ago) by jlam
Branch: MAIN
Changes since 1.28: +2 -2 lines
Diff to previous 1.28 (colored)

Use correct homepage.

Revision 1.28.2.2 / (download) - annotate - [select for diffs], Fri Jun 21 23:05:39 2002 UTC (20 years, 7 months ago) by jlam
Branch: buildlink2
Changes since 1.28.2.1: +2 -2 lines
Diff to previous 1.28.2.1 (colored) to branchpoint 1.28 (colored)

Rename USE_BUILDLINK2_ONLY to USE_BUILDLINK2 for less verbosity.  Also
convert a few more packages to use the buildlink2 framework.

Revision 1.28.2.1 / (download) - annotate - [select for diffs], Thu Jun 6 06:54:48 2002 UTC (20 years, 8 months ago) by jlam
Branch: buildlink2
Changes since 1.28: +7 -6 lines
Diff to previous 1.28 (colored)

* Convert some more packages to use the buildlink2 framework.
* Re-add EVAL_PREFIX lines that I shouldn't have removed from the
  buildlink2.mk files.
* Add several more new buildlink2.mk files to facilitate converting more
  packages.

Revision 1.28 / (download) - annotate - [select for diffs], Thu Jan 31 20:42:09 2002 UTC (21 years ago) by jlam
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews, netbsd-1-5-PATCH003
Branch point for: buildlink2
Changes since 1.27: +7 -5 lines
Diff to previous 1.27 (colored)

* Create the link /usr/lib/sasl -> ${PREFIX}/lib/sasl as it's where SASL-
  aware applications look for authentication mechanisms by default.
* Warn package admin if ${PREFIX}/lib/sasl is non-empty after
  deinstallation, as it may contain service config files.
* Purge use of PKGDIR.

Revision 1.27 / (download) - annotate - [select for diffs], Thu Jan 31 19:52:02 2002 UTC (21 years ago) by jlam
Branch: MAIN
Changes since 1.26: +3 -2 lines
Diff to previous 1.26 (colored)

Add USE_PAM to the BUILD_DEFS if it is defined.

Revision 1.26 / (download) - annotate - [select for diffs], Sun Jan 13 14:23:37 2002 UTC (21 years ago) by skrll
Branch: MAIN
Changes since 1.25: +2 -3 lines
Diff to previous 1.25 (colored)

Update to 1.5.27. Changes are mostly bugfixes including a fix for the
format string vulnerability described in

        http://www.securityfocus.com/bid/3498

Closes pkg/15149 from <naoki@fukaumi.org>

Revision 1.25 / (download) - annotate - [select for diffs], Mon Dec 10 12:43:21 2001 UTC (21 years, 1 month ago) by martti
Branch: MAIN
Changes since 1.24: +5 -13 lines
Diff to previous 1.24 (colored)

Added optional GSSAPI support. To activate this feature, please set
SASL_USE_GSSAPI=YES in /etc/mk.conf

Revision 1.24 / (download) - annotate - [select for diffs], Tue Dec 4 06:15:00 2001 UTC (21 years, 2 months ago) by jlam
Branch: MAIN
Changes since 1.23: +1 -2 lines
Diff to previous 1.23 (colored)

By default, prevent invocation of GNU "auto*" driven by the generated
Makefiles during the build process by touching various auto{conf,make}
source files to make them up-to-date.  Packages that require regenerating
the configure script and Makefile.in files should make the appropriate
calls to auto{conf,make} in a pre-configure target.  This allows the
various targets listed in ${_CONFIG_PREREQ} to modify the generated files
without triggering the GNU auto* tools and having the modifications be
overwritten.

Revision 1.23 / (download) - annotate - [select for diffs], Sun Dec 2 06:56:43 2001 UTC (21 years, 2 months ago) by jlam
Branch: MAIN
Changes since 1.22: +1 -3 lines
Diff to previous 1.22 (colored)

bsd.pkg.install.mk calls the INSTALL script at the right times
automatically, so no need to do it ourselves.

Revision 1.22 / (download) - annotate - [select for diffs], Thu Nov 29 01:12:46 2001 UTC (21 years, 2 months ago) by hubertf
Branch: MAIN
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

Get rid of manually adding "nbX" to PKGNAME when a pkg was changed in
pkgsrc. Instead, a new variable PKGREVISION is invented that can get
bumped independent of DISTNAME and PKGNAME.

Example #1:
        DISTNAME=       foo-X.Y
        PKGREVISION=    Z
     => PKGNAME=        foo-X.YnbZ

Example #2:
        DISTNAME=       barthing-X.Y
        PKGNAME=        bar-X.Y
        PKGREVISION=    Z
     => PKGNAME=        bar=X.YnbZ (!)

On subsequent changes, only PKGREVISION needs to be bumped, no more risk
of getting DISTNAME changed accidentally.

Revision 1.21 / (download) - annotate - [select for diffs], Mon Nov 26 20:38:32 2001 UTC (21 years, 2 months ago) by jlam
Branch: MAIN
Changes since 1.20: +5 -5 lines
Diff to previous 1.20 (colored)

Use PKG_{USERS,GROUPS} instead of PKG_{USER,GROUP}.

Revision 1.20 / (download) - annotate - [select for diffs], Sun Nov 25 18:59:47 2001 UTC (21 years, 2 months ago) by jlam
Branch: MAIN
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

PKG_SYSCONFDIR is where the configuration files for a package may be found.
This value may be customized in various ways:

PKG_SYSCONFBASE is the main config directory under which all package
	configuration files are to be found.

PKG_SYSCONFSUBDIR is the subdirectory of PKG_SYSCONFBASE under which the
	configuration files for a particular package may be found.

PKG_SYSCONFDIR.${PKGBASE} overrides the value of ${PKG_SYSCONFDIR} for a
	particular package.

Users will typically want to set PKG_SYSCONFBASE to /etc, or accept the
default location of ${PREFIX}/etc.

This obsoletes the use of CONFDIR, which was active for only 6 days, so no
need to have a workaround to still accept old CONFDIR settings.

Revision 1.19 / (download) - annotate - [select for diffs], Wed Nov 21 22:22:10 2001 UTC (21 years, 2 months ago) by jlam
Branch: MAIN
Changes since 1.18: +33 -50 lines
Diff to previous 1.18 (colored)

Buildlinkify, respect ${CONFDIR}, use general INSTALL/DEINSTALL scripts,
and make sasl_passwd into a real rc.d script.

Revision 1.18 / (download) - annotate - [select for diffs], Thu Oct 18 15:20:34 2001 UTC (21 years, 3 months ago) by veego
Branch: MAIN
Changes since 1.17: +2 -1 lines
Diff to previous 1.17 (colored)

SVR4 packages have a limit of 9 chars for a package name.
The automatic truncation in gensolpkg doesn't work for packages which
have the same package name for the first 5-6 chars.
e.g. amanda-server and amanda-client would be named amanda and amanda.
Now, we add a SVR4_PKGNAME and use amacl for amanda-client and amase for
amanda-server.
All svr4 packages also have a vendor tag, so we have to reserve some chars
for this tag, which is normaly 3 or 4 chars. Thats why we can only use 6
or 5 chars for SVR4_PKGNAME. I used 5 for all the packages, to give the
vendor tag enough room.
All p5-* packages and a few other packages have now a SVR4_PKGNAME.

Revision 1.17 / (download) - annotate - [select for diffs], Thu Sep 27 23:18:37 2001 UTC (21 years, 4 months ago) by jlam
Branch: MAIN
Changes since 1.16: +3 -3 lines
Diff to previous 1.16 (colored)

Mechanical changes to 375 files to change dependency patterns of the form
foo-* to foo-[0-9]*.  This is to cause the dependencies to match only the
packages whose base package name is "foo", and not those named "foo-bar".
A concrete example is p5-Net-* matching p5-Net-DNS as well as p5-Net.  Also
change dependency examples in Packages.txt to reflect this.

Revision 1.16 / (download) - annotate - [select for diffs], Sun Aug 26 10:32:23 2001 UTC (21 years, 5 months ago) by skrll
Branch: MAIN
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Update automake to 1.4-p5 (1.5 is available)

Include a bugfix for lisp_LISP independently discovered by me that has
been pulled up to the automake-1-4 branch of automake cvs.

Changes are:
New in 1.4-p5:
* Allow AM_PROG_LIBTOOL again.
* Diagnose AC_CONFIG_HEADERS the same as AC_CONFIG_HEADER.
* Display distributed file list correctly in usage message.
* Allow numbers in macro names.
* Bugfixes.

New in 1.4-p4:
* Deal with configure.ac as well as configure.in -- this time for real!
* The version numbering system now allows three point version numbers,
  such as 1.4.4, without thinking they are alpha release numbers.

New in 1.4-p3:
* Deal with configure.ac as well as configure.in.
* Don't complain if `version.texi' is included in multiple places.

New in 1.4-p2:
* Deal with AC_CONFIG_FILES from autoconf-2.50.
* Improvements to f77 support.
* DESTDIR now works for script targets.
* distcheck-hook works correctly.

New in 1.4-p1:
* The version numbering system now allows fork identifiers (such as
  the p1 in this version of automake).
* Cope gracefully with various versions of libtool which may or may not
  require ltconfig, ltcf-c.sh, ltcf-cxx.sh or ltcf-gcj.sh.
* Bugfixes.

Revision 1.15 / (download) - annotate - [select for diffs], Tue Aug 14 03:41:39 2001 UTC (21 years, 5 months ago) by jlam
Branch: MAIN
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

grep isn't used anymore, so don't substitute for @GREP@ in the INSTALL
files.  Substitute for @ID@ instead of directly using 'id', and use the
value of ${ID} already set in defs.*.mk.

Revision 1.14 / (download) - annotate - [select for diffs], Tue Mar 27 03:20:15 2001 UTC (21 years, 10 months ago) by hubertf
Branch: MAIN
CVS Tags: netbsd-1-5-PATCH001
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Change BUILD_DEPENDS semantics:
first component is now a package name+version/pattern, no more
executable/patchname/whatnot.

While there, introduce BUILD_USES_MSGFMT as shorthand to pull in
devel/gettext unless /usr/bin/msgfmt exists (i.e. on post-1.5 -current).

Patch by Alistair Crooks <agc@netbsd.org>

Revision 1.13 / (download) - annotate - [select for diffs], Sun Mar 4 03:26:51 2001 UTC (21 years, 11 months ago) by assar
Branch: MAIN
Changes since 1.12: +7 -10 lines
Diff to previous 1.12 (colored)

turn KERBEROS into a binary switch

Revision 1.12 / (download) - annotate - [select for diffs], Sat Feb 17 17:49:41 2001 UTC (21 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.11: +2 -1 lines
Diff to previous 1.11 (colored)

Update to new COMMENT style: COMMENT var in Makefile instead of pkg/COMMENT.

Revision 1.11 / (download) - annotate - [select for diffs], Mon Feb 5 09:01:03 2001 UTC (21 years, 11 months ago) by tron
Branch: MAIN
Changes since 1.10: +3 -3 lines
Diff to previous 1.10 (colored)

Use full pathname "${LOCALBASE}/bin/auto..." in dependences and make
targets. This includes a fix for PR pkg/12125 by Tomasz Luchowski.

Revision 1.10 / (download) - annotate - [select for diffs], Wed Jan 31 22:52:21 2001 UTC (22 years ago) by jlam
Branch: MAIN
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Bump version number to 1.5.24nb3 as a result of checking for /dev/urandom
instead of /dev/random if the former exists.

Revision 1.9 / (download) - annotate - [select for diffs], Wed Jan 31 22:40:49 2001 UTC (22 years ago) by jlam
Branch: MAIN
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

Update HOMEPAGE.

Revision 1.8 / (download) - annotate - [select for diffs], Wed Dec 13 16:24:50 2000 UTC (22 years, 1 month ago) by jlam
Branch: MAIN
Changes since 1.7: +4 -3 lines
Diff to previous 1.7 (colored)

Rename `pwcheck' rc.d control script to `sasl_pwcheck' to avoid name clash
with NetBSD 1.5's existing /etc/rc.d/pwcheck script.

Revision 1.7 / (download) - annotate - [select for diffs], Mon Dec 11 09:04:52 2000 UTC (22 years, 1 month ago) by jlam
Branch: MAIN
Changes since 1.6: +3 -1 lines
Diff to previous 1.6 (colored)

Replace a few more utilities with their paths from bsd.pkg.mk.

Revision 1.6 / (download) - annotate - [select for diffs], Mon Dec 11 08:59:29 2000 UTC (22 years, 1 month ago) by jlam
Branch: MAIN
Changes since 1.5: +2 -1 lines
Diff to previous 1.5 (colored)

Replace @ADDGROUP@ in pkg/INSTALL file.

Revision 1.5 / (download) - annotate - [select for diffs], Sun Dec 10 09:43:36 2000 UTC (22 years, 1 month ago) by jlam
Branch: MAIN
Changes since 1.4: +105 -30 lines
Diff to previous 1.4 (colored)

Update cyrus-sasl to 1.5.24nb2:

* Move headers to ${PREFIX}/include and get rid of need for the MD5
  headers.
* Move creation of cyrus user and mail group from cyrus-imapd to cyrus-sasl.
* Always compile support for pwcheck.
* Supply a ${PREFIX}/etc/rc.d/pwcheck script that drops in the rc.d startup
  scheme.
* Supply a sasl-config script that can return compiler flags needed for
  linking against -lsasl.
* Install documentation.
* Supply DEINSTALL/INSTALL scripts to manage the /var/pwcheck directory
  and /etc/sasldb shared secrets database.
* Improve the descriptions in the COMMENT and DESCR files.
* Make me the maintainer.

Revision 1.4 / (download) - annotate - [select for diffs], Fri Dec 8 14:32:00 2000 UTC (22 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.3: +2 -4 lines
Diff to previous 1.3 (colored)

Fix kerberos4 recognition if ${PREFIX} != /usr/local.
Also change libdes recognition so that it builds with openssl. Fixes pkg/11170.

Revision 1.3 / (download) - annotate - [select for diffs], Wed Oct 25 08:00:24 2000 UTC (22 years, 3 months ago) by rh
Branch: MAIN
Changes since 1.2: +19 -2 lines
Diff to previous 1.2 (colored)

Update cyrus-sasl to 1.5.24nb1.  Changes are:
	* enable pwcheck method if CYRUS_USE_PWCHECK is set (closes
	  PR 11305 by David Edmondson <dme@dme.org>)
	* only enable Kerberos 4 if KERBEROS is set to 4 (depends on
	  kth-krb4, in this case), otherwise explicitly disable Kerberos

Revision 1.2 / (download) - annotate - [select for diffs], Sat Oct 21 18:50:49 2000 UTC (22 years, 3 months ago) by rh
Branch: MAIN
Changes since 1.1: +6 -1 lines
Diff to previous 1.1 (colored)

Add optional PAM support if USE_PAM is defined

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Fri Aug 25 15:23:49 2000 UTC (22 years, 5 months ago) by jlam
Branch: TNF
CVS Tags: pkgsrc-base, netbsd-1-5-RELEASE, netbsd-1-4-PATCH003
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Reimport cyrus-sasl under security, since it's an authentication and
security library.

Revision 1.1 / (download) - annotate - [select for diffs], Fri Aug 25 15:23:49 2000 UTC (22 years, 5 months ago) by jlam
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>