The NetBSD Project

CVS log for pkgsrc/security/courier-authlib/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / security / courier-authlib

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.64 / (download) - annotate - [select for diffs], Wed Jan 25 19:31:05 2023 UTC (8 days, 18 hours ago) by bsiegert
Branch: MAIN
CVS Tags: HEAD
Changes since 1.63: +2 -3 lines
Diff to previous 1.63 (colored)

courier-authlib: update to 0.72.0

Upstream does not supply a meaningful changelog.

Revision 1.63 / (download) - annotate - [select for diffs], Tue Jun 28 11:35:34 2022 UTC (7 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.62: +2 -2 lines
Diff to previous 1.62 (colored)

*: recursive bump for perl 5.36

Revision 1.62 / (download) - annotate - [select for diffs], Wed Jun 23 20:33:16 2021 UTC (19 months, 1 week ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.61: +2 -2 lines
Diff to previous 1.61 (colored)

Revbump for MySQL default change

Revision 1.61 / (download) - annotate - [select for diffs], Mon May 24 19:53:51 2021 UTC (20 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.60: +2 -2 lines
Diff to previous 1.60 (colored)

*: recursive bump for perl 5.34

Revision 1.60 / (download) - annotate - [select for diffs], Thu May 6 08:45:00 2021 UTC (20 months, 4 weeks ago) by wiz
Branch: MAIN
Changes since 1.59: +1 -6 lines
Diff to previous 1.59 (colored)

courier-authlib: fix options

Fix post-install target handling. Fix file name for ldap config.
Clean up pkglint.

Revision 1.59 / (download) - annotate - [select for diffs], Fri Dec 4 04:56:11 2020 UTC (2 years, 2 months ago) by riastradh
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.58: +2 -2 lines
Diff to previous 1.58 (colored)

Revbump for openpam cppflags change months ago, belatedly.

Revision 1.58 / (download) - annotate - [select for diffs], Mon Aug 31 18:11:07 2020 UTC (2 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.57: +2 -1 lines
Diff to previous 1.57 (colored)

*: bump PKGREVISION for perl-5.32.

Revision 1.57 / (download) - annotate - [select for diffs], Mon Apr 13 19:11:07 2020 UTC (2 years, 9 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.56: +7 -14 lines
Diff to previous 1.56 (colored)

Update courier-authlib to 0.69.1. Changes unknown, but necessary for
maildrop.

Revision 1.56 / (download) - annotate - [select for diffs], Sun Jan 26 17:32:02 2020 UTC (3 years ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.55: +2 -2 lines
Diff to previous 1.55 (colored)

all: migrate homepages from http to https

pkglint -r --network --only "migrate"

As a side-effect of migrating the homepages, pkglint also fixed a few
indentations in unrelated lines. These and the new homepages have been
checked manually.

Revision 1.55 / (download) - annotate - [select for diffs], Sat Jan 18 21:50:34 2020 UTC (3 years ago) by jperkin
Branch: MAIN
Changes since 1.54: +2 -2 lines
Diff to previous 1.54 (colored)

*: Recursive revision bump for openssl 1.1.1.

Revision 1.54 / (download) - annotate - [select for diffs], Sun Aug 11 13:22:45 2019 UTC (3 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.53: +2 -2 lines
Diff to previous 1.53 (colored)

Bump PKGREVISIONs for perl 5.30.0

Revision 1.53 / (download) - annotate - [select for diffs], Wed Aug 22 09:46:17 2018 UTC (4 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.52: +2 -2 lines
Diff to previous 1.52 (colored)

Recursive bump for perl5-5.28.0

Revision 1.52 / (download) - annotate - [select for diffs], Thu May 11 09:22:36 2017 UTC (5 years, 8 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.51: +3 -2 lines
Diff to previous 1.51 (colored)

Requires iconv.  Try to reduce the include craziness a little bit.

Revision 1.51 / (download) - annotate - [select for diffs], Sun Oct 9 21:42:02 2016 UTC (6 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.50: +2 -2 lines
Diff to previous 1.50 (colored)

Recursive bump for all users of pgsql now that the default is 95.

Revision 1.50 / (download) - annotate - [select for diffs], Sat Jul 9 06:38:54 2016 UTC (6 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.49: +2 -2 lines
Diff to previous 1.49 (colored)

Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.

Revision 1.49 / (download) - annotate - [select for diffs], Sat Mar 5 11:29:18 2016 UTC (6 years, 11 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.48: +2 -2 lines
Diff to previous 1.48 (colored)

Bump PKGREVISION for security/openssl ABI bump.

Revision 1.48 / (download) - annotate - [select for diffs], Fri Jun 12 10:51:01 2015 UTC (7 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.47: +2 -2 lines
Diff to previous 1.47 (colored)

Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.

Revision 1.47 / (download) - annotate - [select for diffs], Sat Jun 14 10:15:59 2014 UTC (8 years, 7 months ago) by wiedi
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.46: +2 -2 lines
Diff to previous 1.46 (colored)

fix SMF Manifest installation by not overwriting INSTALLATION_DIRS

Revision 1.46 / (download) - annotate - [select for diffs], Thu May 29 23:37:19 2014 UTC (8 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.45: +2 -2 lines
Diff to previous 1.45 (colored)

Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

Revision 1.45 / (download) - annotate - [select for diffs], Wed Feb 12 23:18:31 2014 UTC (8 years, 11 months ago) by tron
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.44: +2 -2 lines
Diff to previous 1.44 (colored)

Recursive PKGREVISION bump for OpenSSL API version bump.

Revision 1.44 / (download) - annotate - [select for diffs], Fri May 31 12:41:50 2013 UTC (9 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.43: +2 -2 lines
Diff to previous 1.43 (colored)

Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

Revision 1.43 / (download) - annotate - [select for diffs], Sat Mar 2 20:33:32 2013 UTC (9 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.42: +2 -2 lines
Diff to previous 1.42 (colored)

Bump PKGREVISION for mysql default change to 55.

Revision 1.42 / (download) - annotate - [select for diffs], Wed Feb 6 23:23:34 2013 UTC (9 years, 11 months ago) by jperkin
Branch: MAIN
Changes since 1.41: +2 -2 lines
Diff to previous 1.41 (colored)

PKGREVISION bumps for the security/openssl 1.0.1d update.

Revision 1.41 / (download) - annotate - [select for diffs], Sun Dec 16 01:52:32 2012 UTC (10 years, 1 month ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.40: +2 -2 lines
Diff to previous 1.40 (colored)

recursive bump from cyrus-sasl libsasl2 shlib major bump.

Revision 1.40 / (download) - annotate - [select for diffs], Tue Oct 23 18:16:22 2012 UTC (10 years, 3 months ago) by asau
Branch: MAIN
Changes since 1.39: +1 -3 lines
Diff to previous 1.39 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.39 / (download) - annotate - [select for diffs], Wed Oct 3 21:57:23 2012 UTC (10 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.38: +2 -1 lines
Diff to previous 1.38 (colored)

Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.

Revision 1.38 / (download) - annotate - [select for diffs], Sat Jun 9 11:57:20 2012 UTC (10 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.37: +2 -2 lines
Diff to previous 1.37 (colored)

Changes 0.64.0:
* authpam.c (callback_pam): Call pam_end() after an authentication attempt.
* Makefile.am: Renamed authstaticlist.h to courierauthstaticlist.h, and
added it to the list of header files that 'make install' puts into
includedir.
* Fix gcc 4.6 warnings
* courier.spec.in: switch to systemd.
* Fix autoconf warnings.
* courier-authlib.spec: Make rmplint happy.

Revision 1.37 / (download) - annotate - [select for diffs], Sun May 13 15:23:33 2012 UTC (10 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.36: +3 -3 lines
Diff to previous 1.36 (colored)

"Convert" to destdir by moving one line higher up.

Revision 1.36 / (download) - annotate - [select for diffs], Tue Jun 15 23:10:44 2010 UTC (12 years, 7 months ago) by pettai
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.35: +2 -3 lines
Diff to previous 1.35 (colored)

courier-authlib-0.63.0:

* authldapescape.c: Factor out LDAP string escape function.
* authldap.schema: Various fixes
* authldap.ldif (olcObjectClasses): Create LDIF format schema from
  authldap.schema
* authoption.c (auth_getoptionenvint): For account options that
  are parsed to an int, an option value that begins with t, T, y, or Y
  is evaluated as 1, other alphabetic values as 0; so that 'true'
  or 'yes' get evaluated as 1.

(See the Changelog for the previous releases)

Based on patch(es) from PR pkg/42989 by Brian Candler

Revision 1.35 / (download) - annotate - [select for diffs], Sun Mar 21 16:29:43 2010 UTC (12 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

Reset maintainer, developer lost his commit bit.

Revision 1.34 / (download) - annotate - [select for diffs], Tue Dec 15 22:10:38 2009 UTC (13 years, 1 month ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.33: +2 -1 lines
Diff to previous 1.33 (colored)

Recursive bump for libltdl

Revision 1.33 / (download) - annotate - [select for diffs], Thu Jul 2 12:23:44 2009 UTC (13 years, 7 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2
Changes since 1.32: +2 -2 lines
Diff to previous 1.32 (colored)

Update courier-authlib to 0.62.2.
Include security fix for CVE-2008-2380 and requested by PR#41023
(approved by wiz@).

0.62.2

This release corrects a makefile compatibility problem with bash 4.

0.62.1

This release correct a couple of minor compiler warnings and errors.

  * cryptpassword.c: Fix compiler warnings

  * checkpasswordsha1.c: Fix compiler warnings.

  * authldaplib.c (auth_ldap_enumerate): Fix typo.

0.62.0

This release adds support for additional hash functions, and an
update to the Postgres driver that removes potentional SQL injection
vulnerabilities in some circumstances.

  * authpgsqllib.c: Use PQescapeStringConn() instead of removing all
    apostrophes from query parameters. This fixes a potential SQL injection
    vulnerability if the Postgres database uses a non-Latin locale.

  * Added support for {SSHA}-encrypted passwords. Based on a patch
    by Zou bin <zb@bisp.com>.

  * Added support for {SHA512} hash function

Revision 1.32 / (download) - annotate - [select for diffs], Sat Jun 27 04:16:57 2009 UTC (13 years, 7 months ago) by obache
Branch: MAIN
Changes since 1.31: +2 -1 lines
Diff to previous 1.31 (colored)

Add ${TRUE} to end of the GENERATE_PLIST to avoid picked up exit code of last
test command.

Revision 1.31 / (download) - annotate - [select for diffs], Sun Jun 14 22:58:08 2009 UTC (13 years, 7 months ago) by joerg
Branch: MAIN
Changes since 1.30: +1 -7 lines
Diff to previous 1.30 (colored)

Remove @dirrm related logic.

Revision 1.30 / (download) - annotate - [select for diffs], Tue May 19 08:59:30 2009 UTC (13 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.29: +2 -3 lines
Diff to previous 1.29 (colored)

Use standard location for LICENSE line (in MAINTAINER/HOMEPAGE/COMMENT
block). Uncomment some commented out LICENSE lines while here.

Revision 1.29 / (download) - annotate - [select for diffs], Sun Sep 28 22:15:30 2008 UTC (14 years, 4 months ago) by tonnerre
Branch: MAIN
CVS Tags: pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3
Changes since 1.28: +17 -14 lines
Diff to previous 1.28 (colored)

Upgrade courier-authlib to version 0.61.0 in order to fix CVE-2008-2667,
finally. While here, fix PLIST and depkglint a bit. Also, fix the horrid
abuse of libtool.

Changes since 0.60.2:
 * courier-authlib.spec: Dummy provides: for symlinks, to allow upgrade
   with older packages that require <libname>.so.0.
 * Makefile.am: Switch to versionless shared libraries.
   Install all shared libraries just as <libname>.so. make install manually
   removes *.so.0.0 files that were left over from previous versions,
   and installs a temporary *.so.0 symlink to *.so, for temporary
   binary ABI compatibility with 0.60. The symlinks will be removed in
   0.62.
 * Cleanup: always compile md5, sha* and hmac stuff, and remove all
   conditionally-compiled cruft. Move SASL list to an internal header.
   Add client-side support for AUTH EXTERNAL.
 * authsasl.c (auth_sasl_ex): auth_sasl_ex() supercedes auth_sasl(),
   invokes auth_sasl() for non-EXTERNAL SASL methods, implements EXTERNAL
   by going through the motions, then setting up a dummy authentication
   request.
 * authdaemon.c (auth_generic): Check for the dummy EXTERNAL
   authentication request, and handle it by invoking auth_getuserinfo(),
   rather than sending it down the pipe. This avoid having to implement
   a stub in every authentication module.
 * authmysqllib.c: Use mysql_set_character_set() instead of SET NAMES
 * authmysqllib.c: Fix domain-less queries.
 * Makefile: Drop the unmaintained authvchkpw module.
 * authmysqllib.c: Cleanup. Use mysql_real_escape_string instead of
   crude filtering.
 * Makefile.am: Use _LIBADD properly.
 * configure.in: More portability fixes.

Revision 1.28 / (download) - annotate - [select for diffs], Mon Feb 18 20:26:33 2008 UTC (14 years, 11 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.27: +15 -11 lines
Diff to previous 1.27 (colored)

+ Add full DESTDIR support.

+ Create any required directories with the right ownership and permissions
  as a "prestart" action in the authdaemond rc.d script.

Bump the PKGREVISION to 1.

Revision 1.27 / (download) - annotate - [select for diffs], Wed Oct 31 14:22:55 2007 UTC (15 years, 3 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

Comment out LICENSE=gnu-gpl-v3 for now as part of transition to switching
pkgsrc to using license.mk.  This will eventually be turned back on.

Revision 1.26 / (download) - annotate - [select for diffs], Mon Oct 15 15:37:01 2007 UTC (15 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.25: +4 -2 lines
Diff to previous 1.25 (colored)

Update security/courier-authlib to 0.60.1.  Changes from version 0.59.3
include:

* MYSQL_CHARACTER_SET option.

* Allow underscores, colons and plusses, in account names.

* Add {MD5RAW} hash method.

* Fix runtime problems with hardcoded file descriptors in the daemon
  code by using OPEN_MAX instead.

Revision 1.25 / (download) - annotate - [select for diffs], Thu Aug 30 20:11:08 2007 UTC (15 years, 5 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.24: +2 -1 lines
Diff to previous 1.24 (colored)

Skip the interpreter check on authsystem.passwd as we don't want to
depend on the tcl-expect package.  The package MESSAGE file already
tells the user what to do.

Revision 1.24 / (download) - annotate - [select for diffs], Fri Aug 10 17:57:21 2007 UTC (15 years, 5 months ago) by jlam
Branch: MAIN
Changes since 1.23: +5 -7 lines
Diff to previous 1.23 (colored)

Update security/courier-authlib to 0.59.3.  Changes from version 0.58
include:

* authpipe.c (auth_pipe_pre): Fix leak when authpipe module is
  enabled, but the actual authpipe script/external prog is not
  installed.

* authmysqlrc: Implement SSL-encrypted MySQL connections

* authldaplib.c (l_simple_bind_s): Fix anon binds.

* authldaplib.c (auth_ldap_enumerate): Fix LDAP account enumeration

* userdb/makeuserdb.in: Added the -f option to makeuserdb

* authldaplib.c: Try to recover when the LDAP server closes the
  persistent socket, for inactivity.

Revision 1.23 / (download) - annotate - [select for diffs], Sun Jul 2 10:34:55 2006 UTC (16 years, 7 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3
Changes since 1.22: +3 -2 lines
Diff to previous 1.22 (colored)

This package needs expect(1). Bumped PKGREVISION.

Revision 1.22 / (download) - annotate - [select for diffs], Tue May 9 17:58:46 2006 UTC (16 years, 9 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.21: +2 -1 lines
Diff to previous 1.21 (colored)

Uses C++.

Revision 1.21 / (download) - annotate - [select for diffs], Tue Mar 14 01:14:33 2006 UTC (16 years, 10 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.20: +1 -3 lines
Diff to previous 1.20 (colored)

Modify the pkginstall framework so that it manages all aspects of
INSTALL/DEINSTALL script creation within pkgsrc.

If an INSTALL or DEINSTALL script is found in the package directory,
it is automatically used as a template for the pkginstall-generated
scripts.  If instead, they should be used simply as the full scripts,
then the package Makefile should set INSTALL_SRC or DEINSTALL_SRC
explicitly, e.g.:

	INSTALL_SRC=	${PKGDIR}/INSTALL
	DEINSTALL_SRC=	# emtpy

As part of the restructuring of the pkginstall framework internals,
we now *always* generate temporary INSTALL or DEINSTALL scripts.  By
comparing these temporary scripts with minimal INSTALL/DEINSTALL
scripts formed from only the base templates, we determine whether or
not the INSTALL/DEINSTALL scripts are actually needed by the package
(see the generate-install-scripts target in bsd.pkginstall.mk).

In addition, more variables in the framework have been made private.
The *_EXTRA_TMPL variables have been renamed to *_TEMPLATE, which are
more sensible names given the very few exported variables in this
framework.  The only public variables relating to the templates are:

	INSTALL_SRC		INSTALL_TEMPLATE
	DEINSTALL_SRC		DEINSTALL_TEMPLATE
				HEADER_TEMPLATE

The packages in pkgsrc have been modified to reflect the changes in
the pkginstall framework.

Revision 1.20 / (download) - annotate - [select for diffs], Sun Feb 5 23:10:42 2006 UTC (17 years ago) by joerg
Branch: MAIN
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.19 / (download) - annotate - [select for diffs], Tue Jan 10 12:39:04 2006 UTC (17 years ago) by ghen
Branch: MAIN
Changes since 1.18: +2 -1 lines
Diff to previous 1.18 (colored)

Use mk/mysql.buildlink3.mk instead of databases/mysqlX-client/bl3.mk,
same for pgsql.bl3.mk.  Bump PKGREVISION.  Ok by wiz.

Revision 1.18 / (download) - annotate - [select for diffs], Tue Jan 3 03:50:45 2006 UTC (17 years, 1 month ago) by jlam
Branch: MAIN
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

Update security/courier-authlib to 0.58.  Changes from version 0.57 include:

	* Re-enable pam_acct_mgmt hook.
	* Add support for shadow password expiration.
	* Configurable daemon socket timeout,
	* Add a section for LDAP environment variable options.
	* Replace LDAP_SERVER and LDAP_PORT settings with LDAP_URI,
	  which obsoletes LDAP_TLS.
	* Fix LDAP error checking.

Revision 1.17 / (download) - annotate - [select for diffs], Sat Dec 17 05:20:23 2005 UTC (17 years, 1 month ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

Change my MAINTAINER email address to the one I've been using for
pkgsrc work.

Revision 1.16 / (download) - annotate - [select for diffs], Mon Dec 5 23:55:17 2005 UTC (17 years, 2 months ago) by rillig
Branch: MAIN
Changes since 1.15: +4 -4 lines
Diff to previous 1.15 (colored)

Ran "pkglint --autofix", which corrected some of the quoting issues in
CONFIGURE_ARGS.

Revision 1.15 / (download) - annotate - [select for diffs], Mon Dec 5 20:50:55 2005 UTC (17 years, 2 months ago) by rillig
Branch: MAIN
Changes since 1.14: +4 -4 lines
Diff to previous 1.14 (colored)

Fixed pkglint warnings. The warnings are mostly quoting issues, for
example MAKE_ENV+=FOO=${BAR} is changed to MAKE_ENV+=FOO=${BAR:Q}. Some
other changes are outlined in

    http://mail-index.netbsd.org/tech-pkg/2005/12/02/0034.html

Revision 1.14 / (download) - annotate - [select for diffs], Mon Nov 7 16:43:49 2005 UTC (17 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.13: +1 -2 lines
Diff to previous 1.13 (colored)

Only install the authldap.schema file if the "ldap" package option is
specified.

Revision 1.13 / (download) - annotate - [select for diffs], Thu Aug 11 00:03:16 2005 UTC (17 years, 5 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3
Changes since 1.12: +13 -9 lines
Diff to previous 1.12 (colored)

Update security/courier-authlib to 0.57.  Changes from version 0.55
include:

	* authlib: create the authtest and authpasswd manual pages.

	* authdaemon.c (auth_generic): Silly bug in auth_generic().
	* authldaplib.c (auth_ldap_do3): Fix call of authcryptpasswd().
	* authpgsqllib.c (auth_pgsql_setpass): Ditto.
	* authmysqllib.c (auth_mysql_setpass): Ditto.
	* authmysqllib.c (auth_mysql_setpass): Fix a memory leak.
	* authpipe: more fixes to the authpipe module.
	* authpipe: various fixes to the authpipe module.
	* authpipe.c (auth_pipe_pre): Fix zombies created by the authpipe
	  module.
	* New authpipe authentication module.
	* authldap.schema: Add mailhost to the recommended LDAP schema.

	* README_authlib.sgml: Document updated authpipe protocol.

	* cryptpassword.c (authcryptpasswd): Fix handling of encryption hints.
	* checkpassword.c (do_authcheckpassword): Ignore {CRYPT} prefix on
	  crypted passwords.
	* checkpasswordsha1.c (authcheckpasswordsha1): Fix {SHA256} passwords.

	* authdaemond.c: Strip full name/gecos field after the first comma.
	* authdaemond: Pass LOGGEROPTS option to authdaemond.

	* liblog/logger.c: Fix wrong args to setuidgid().
	* liblog/logger.c: Added -droproot option to courierlogger.

	* liblock/lockdaemon.c: Try to recover if upgraded daemon process runs
	  under a different uid.

	* Changed -uid and -gid options to -user and -group for consistency
	  with couriertcpd. Change them to affect courierlogger itself,
	  after it has spawned any child.

	* Optional default domain for authentication requests.

	* Fix the error code when an empty password is provided.

Revision 1.12 / (download) - annotate - [select for diffs], Sat Jul 16 01:19:19 2005 UTC (17 years, 6 months ago) by jlam
Branch: MAIN
Changes since 1.11: +2 -3 lines
Diff to previous 1.11 (colored)

Get rid of USE_PERL5.  The new way to express needing the Perl executable
around at either build-time or at run-time is:

	USE_TOOLS+=	perl		# build-time
	USE_TOOLS+=	perl:run	# run-time

Also remove some places where perl5/buildlink3.mk was being included
by a package Makefile, but all that the package wanted was the Perl
executable.

Revision 1.11 / (download) - annotate - [select for diffs], Fri Jun 24 17:31:28 2005 UTC (17 years, 7 months ago) by kristerw
Branch: MAIN
Changes since 1.10: +4 -2 lines
Diff to previous 1.10 (colored)

Prevent paths to the build directories from being included in the package.
Bump PKGREVISION.

Revision 1.10 / (download) - annotate - [select for diffs], Sun May 22 20:08:29 2005 UTC (17 years, 8 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Remove USE_GNU_TOOLS and replace with the correct USE_TOOLS definitions:

	USE_GNU_TOOLS	-> USE_TOOLS
	awk		-> gawk
	m4		-> gm4
	make		-> gmake
	sed		-> gsed
	yacc		-> bison

Revision 1.9 / (download) - annotate - [select for diffs], Fri May 13 03:26:44 2005 UTC (17 years, 8 months ago) by jlam
Branch: MAIN
Changes since 1.8: +4 -3 lines
Diff to previous 1.8 (colored)

Pass the install-time definition of variables that specify the locations
of the example config files through to sub-make processes.  Since
courier-authlib uses GNU automake, we need to set AM_MAKEFLAGS to the
correct value.  This fixes the installation of the *.dist files into
${PREFIX}/share/examples/courier-authlib.

Revision 1.8 / (download) - annotate - [select for diffs], Mon Apr 11 21:47:11 2005 UTC (17 years, 9 months ago) by tv
Branch: MAIN
Changes since 1.7: +1 -2 lines
Diff to previous 1.7 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.7 / (download) - annotate - [select for diffs], Tue Mar 22 03:53:33 2005 UTC (17 years, 10 months ago) by jlam
Branch: MAIN
Changes since 1.6: +2 -3 lines
Diff to previous 1.6 (colored)

Update security/courier-authlib to courier-authlib-0.55.  Changes from
version 0.54 include:

    * authsystem.passwd.in: Explicitly set LC_ALL to en_US
    * SASL: Added CRAM-SHA256 authentication method (experimental).
    * courierauthdebug.h: Macro dprintf conflicts with new glibc.

Revision 1.6 / (download) - annotate - [select for diffs], Fri Mar 18 20:20:48 2005 UTC (17 years, 10 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Avoid possibly linking everything against -lintl when PostgreSQL
support is built into courier-authlib -- -lintl is only needed by the
authpgsql authentication module.  This avoids problems when linking
clients with -lcourierauth and the linker thinks -lintl is needed when
it really doesn't.  Bump the PKGREVISION to 3.

Revision 1.5 / (download) - annotate - [select for diffs], Sat Feb 26 22:14:01 2005 UTC (17 years, 11 months ago) by jlam
Branch: MAIN
Changes since 1.4: +17 -3 lines
Diff to previous 1.4 (colored)

Install some documentation files for courier-authlib, but only install the
relevant ones depending on the options chosen.  This fixes PR pkg/29465.
Bump the PKGREVISION to 2.

Revision 1.4 / (download) - annotate - [select for diffs], Mon Feb 21 17:08:39 2005 UTC (17 years, 11 months ago) by jlam
Branch: MAIN
Changes since 1.3: +3 -1 lines
Diff to previous 1.3 (colored)

Fix the authdaemond rc.d script to invoke the correct script to start
the authentication daemon.  Fix provided by Inseo Park in private mail.
Also, honor VARBASE.  Bump the PKGREVISION to 1.

Revision 1.3 / (download) - annotate - [select for diffs], Fri Feb 18 22:12:43 2005 UTC (17 years, 11 months ago) by jlam
Branch: MAIN
Changes since 1.2: +7 -3 lines
Diff to previous 1.2 (colored)

Update security/courier-authlib to 0.54.  Changes from version 0.53
include:

	* userdb/makeuserdb.in: Report dangling symlinks.

Revision 1.2 / (download) - annotate - [select for diffs], Thu Feb 10 03:50:03 2005 UTC (17 years, 11 months ago) by jlam
Branch: MAIN
Changes since 1.1: +5 -2 lines
Diff to previous 1.1 (colored)

Rearrange so that the MAINTAINER and HOMEPAGE are stored with the
package Makefile instead of Makefile.common.  Also, fix the HOMEPAGE
for the courier-authlib component of the Courier package.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Thu Feb 10 03:21:30 2005 UTC (17 years, 11 months ago) by jlam
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Import courier-authlib-0.53 as security/courier-authlib.

The Courier authentication library provides authentication services for
other Courier applications.  In this context, the term "authentication"
refers to the following functions:

    1. Take a userid or a loginid, and a password. Determine whether the
       loginid and the password are valid.
    2. Given a userid, obtain the following information about the userid:

         A. The account's home directory.
         B. The numeric system userid and groupid that owns all files
            associated with this account.
         C. The location of the account's maildir.
         D. Any maildir quota defined for this account. See the Courier
            documentation for more information on maildir quotas.
         E. Other miscellaneous account-specific options.

    3. Change the password associated with a loginid.
    4. Obtain a complete list of all loginids.

Revision 1.1 / (download) - annotate - [select for diffs], Thu Feb 10 03:21:30 2005 UTC (17 years, 11 months ago) by jlam
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>