[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / print / xpdf-greek

File: [cvs.NetBSD.org] / pkgsrc / print / xpdf-greek / Makefile (download)

Revision 1.4, Tue Mar 25 14:06:54 2003 UTC (21 years ago) by salo
Branch: MAIN
Changes since 1.3: +9 -8 lines

Sync with updated xpdf-2.02 package.

- install into PREFIX, not X11PREFIX
- DEPENDS on xpdf>=2.02 due to USE_X11BASE->USE_X11 change
- fix DEINSTALL files to really remove chunks added to xpdfrc,
  correctly define PKG_SYSCONFDIR, don't use direct commands
  (sed->@SED@, mv->@MV@, rm->@RM@)
- define USE_PKGINSTALL to correctly replace variables in DEINSTALL files
- consistently use DIST_SUBDIR
- don't define completely bogus version numbers, use dates from the
  MASTER_SITE and xpdfrc chunks
- remove PREFIX/share/xpdf from PLISTs, this directory is now part of the xpdf
  package
- remove superfluous license/copyright note from DESCR files
- bump PKGREVISION where necessary

# $NetBSD: Makefile,v 1.4 2003/03/25 14:06:54 salo Exp $
#

DISTNAME=	xpdf-greek
PKGNAME=	${DISTNAME}-20020213
CATEGORIES=	print
MASTER_SITES=	ftp://ftp.foolabs.com/pub/xpdf/

MAINTAINER=	packages@netbsd.org
HOMEPAGE=	http://www.foolabs.com/xpdf/
COMMENT=	xpdf support files for Greek

DEPENDS+=	xpdf>=2.02:../../print/xpdf

USE_X11=	yes
USE_PKGINSTALL=	yes

DIST_SUBDIR=	${PKGNAME_NOREV}
WRKSRC=		${WRKDIR}/${DISTNAME}
NO_CONFIGURE=	yes
NO_BUILD=	yes

post-patch:
	${MV} ${WRKSRC}/add-to-xpdfrc ${WRKSRC}/add-to-xpdfrc.orig
	${SED} -e 's:/usr/local:'${PREFIX}':g' < ${WRKSRC}/add-to-xpdfrc.orig > ${WRKSRC}/add-to-xpdfrc

do-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/xpdf/greek
	${INSTALL_DATA} ${WRKSRC}/ISO-8859-7.unicodeMap \
		${PREFIX}/share/xpdf/greek

post-install:
	${CAT} ${WRKSRC}/add-to-xpdfrc >> ${PKG_SYSCONFDIR}/xpdfrc

.include "../../mk/bsd.pkg.mk"