File:  [cvs.NetBSD.org] / pkgsrc / print / ruby-pdf-reader / Makefile
Revision 1.25: download - view: text, annotated - select for diffs
Sun Nov 28 08:07:38 2021 UTC (3 years, 4 months ago) by taca
Branches: MAIN
CVS tags: HEAD
print/ruby-pdf-reader: update to 2.6.0

2.6.0 (2021-11-12)

* Text extraction improvements

  - Improved text layout on pages with a variety of font sizes
    (http://github.com/yob/pdf-reader/pull/355)
  - Fixed text positioning for some rotated pages
    (http://github.com/yob/pdf-reader/pull/356)
  - Improved character width calculation for PDFs using built-in
    (non-embedded) ZapfDingbats (http://github.com/yob/pdf-reader/pull/373)
  - Skip zero-width characters (http://github.com/yob/pdf-reader/pull/372)

* Performance improvements

  - Reduced memory pressure when decoding TIFF images
    (http://github.com/yob/pdf-reader/pull/360)
  - Optional dependency on ascii81_native gem for faster processing of files
    using the ascii85 filter (http://github.com/yob/pdf-reader/pull/359)

* Successfully parse more files

  - Gracefully handle some non-spec compliant CR/LF issues
    (http://github.com/yob/pdf-reader/pull/364)
  - Fix parsing of some escape sequences in content streams
    (http://github.com/yob/pdf-reader/pull/368)
  - Increase the amount of junk bytes we detect and skip at the end of a
    file (382)
  - Ignore "/Prev 0" in trailers (http://github.com/yob/pdf-reader/pull/383)
  - Fix parsing of some inline images (BI ID EI tokens)
    (http://github.com/yob/pdf-reader/pull/389)
  - Gracefully handle some xref tables that incorrectly start with 1
    (http://github.com/yob/pdf-reader/pull/384)

# $NetBSD: Makefile,v 1.25 2021/11/28 08:07:38 taca Exp $

DISTNAME=	pdf-reader-2.6.0
CATEGORIES=	print

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/yob/pdf-reader
COMMENT=	Library for accessing the content of PDF files
LICENSE=	mit

DEPENDS+=	${RUBY_PKGPREFIX}-Ascii85>=1.0.0:../../converters/ruby-Ascii85
DEPENDS+=	${RUBY_PKGPREFIX}-rc4>=0:../../security/ruby-rc4
DEPENDS+=	${RUBY_PKGPREFIX}-hashery>=2.0<3:../../devel/ruby-hashery
DEPENDS+=	${RUBY_PKGPREFIX}-afm>=0.2.1<0.3:../../fonts/ruby-afm
DEPENDS+=	${RUBY_PKGPREFIX}-ttfunk>=0:../../fonts/ruby-ttfunk

USE_LANGUAGES=	# none

RUBYGEM_OPTIONS+=	--format-executable

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>