[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / print / ruby-pdf-reader

File: [cvs.NetBSD.org] / pkgsrc / print / ruby-pdf-reader / Makefile (download)

Revision 1.20, Tue Mar 24 15:40:56 2020 UTC (4 years ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.19: +2 -2 lines

print/ruby-pdf-reader: update to 2.4.0

Update ruby-pdf-reader to 2.4.0.


2.4.0 (21st November 2019)

- Optimise overlapping characters code introduced in 2.3.0. Text extraction
  of pages with thousands of characters is still slower than it was in
  2.2.1, but it might tolerable for now.
  See https://github.com/yob/pdf-reader/pull/308 for details.

- Implement very basic font substitution for Type1 and TrueType fonts that
  aren't embedded

- Remove PDF::Hash class. It's been deprecated since 2010, and it's hard to
  believe anyone is still using it.

- Several small bug fixes

2.3.0 (7th November 2019)

- Text extraction now makes an effort to skip duplicate characters that
  overlap, a common approach used for a fake "bold" effect, This will make
  text extraction a bit slower - if that turns out to be an issue I'll look
  into further optimisations or provide a toggle to turn it off

- Several small bug fixes

# $NetBSD: Makefile,v 1.20 2020/03/24 15:40:56 taca Exp $

DISTNAME=	pdf-reader-2.4.0
CATEGORIES=	print

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/yob/pdf-reader
COMMENT=	Library for accessing the content of PDF files
LICENSE=	mit

DEPENDS+=	${RUBY_PKGPREFIX}-Ascii85>=1.0.0<1.1:../../converters/ruby-Ascii85
DEPENDS+=	${RUBY_PKGPREFIX}-rc4>=0:../../security/ruby-rc4
DEPENDS+=	${RUBY_PKGPREFIX}-hashery>=2.0<3:../../devel/ruby-hashery
DEPENDS+=	${RUBY_PKGPREFIX}-afm>=0.2.1<0.3:../../fonts/ruby-afm
DEPENDS+=	${RUBY_PKGPREFIX}-ttfunk>=0:../../fonts/ruby-ttfunk

USE_LANGUAGES=	# none

RUBYGEM_OPTIONS+=	--format-executable

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"