# $NetBSD: Makefile,v 1.100 2023/11/14 14:02:45 wiz Exp $
PKGREVISION= 3
.include "../../print/poppler/Makefile.common"
COMMENT= PDF rendering library
PKGCONFIG_OVERRIDE+= poppler.pc.cmake
INSTALLATION_DIRS+= include/poppler share/doc/poppler
# Don't compile GTK+ test program.
CMAKE_ARGS+= -DBUILD_GTK_TESTS=OFF
# Don't compile GLib wrapper which also needs gtk2
CMAKE_ARGS+= -DENABLE_GLIB=OFF
# Don't build and install the tools
CMAKE_ARGS+= -DENABLE_UTILS=OFF
# Don't compile poppler cpp wrapper.
CMAKE_ARGS+= -DENABLE_CPP=OFF
# Don't compile poppler qt5/6 wrapper.
CMAKE_ARGS+= -DENABLE_QT5=OFF
CMAKE_ARGS+= -DENABLE_QT6=OFF
# Don't build libcurl based HTTP support. ## might want to include
CMAKE_ARGS+= -DENABLE_LIBCURL=OFF
# Don't run gperf if it's present
CMAKE_ARGS+= -DRUN_GPERF_IF_PRESENT=OFF
.include "../../mk/bsd.prefs.mk"
.if ${USE_CROSS_COMPILE:tl} == "yes"
ALL_ENV+= PKG_CONFIG_SYSROOT_DIR=${CROSS_DESTDIR:Q}
CMAKE_ARGS+= -DCMAKE_SYSROOT:STRING=${CROSS_DESTDIR:Q}
.endif
# Passing "-ansi" turns "long long" support off on FreeBSD/amd64:
.if ${OPSYS} == "FreeBSD" && ${MACHINE_ARCH} == "x86_64"
CFLAGS+= -D__LONG_LONG_SUPPORTED=
.endif
post-install:
${INSTALL_MAN} ${WRKSRC}/README.md ${DESTDIR}${PREFIX}/share/doc/poppler/
${INSTALL_MAN} ${WRKSRC}/README-XPDF ${DESTDIR}${PREFIX}/share/doc/poppler/
${RMDIR} ${DESTDIR}${PREFIX}/include/poppler || ${TRUE}
.include "../../devel/nss/buildlink3.mk"
.include "../../fonts/fontconfig/buildlink3.mk"
.include "../../graphics/cairo/buildlink3.mk"
.include "../../graphics/lcms2/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>