[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / print / poppler-utils

File: [cvs.NetBSD.org] / pkgsrc / print / poppler-utils / Makefile (download)

Revision 1.28, Mon Jun 3 10:05:53 2013 UTC (10 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.27: +2 -2 lines

Bump freetype2 and fontconfig dependencies to current pkgsrc versions,
to address issues with NetBSD-6(and earlier)'s fontconfig not being
new enough for pango.

While doing that, also bump freetype2 dependency to current pkgsrc
version.

Suggested by tron in PR 47882

# $NetBSD: Makefile,v 1.28 2013/06/03 10:05:53 wiz Exp $

.include "../../print/poppler/Makefile.common"

PKGNAME=		poppler-utils-${POPPLER_VERS}
PKGREVISION=		1

COMMENT=		PDF utilities (from poppler)
MAINTAINER=		reed@reedmedia.net

CONFLICTS+=		poppler-0.5.1 poppler-0.5.1nb1 poppler-0.5.1nb2
CONFLICTS+=		xpdf<3.02pl4nb1

GNU_CONFIGURE=		yes
USE_TOOLS+=		gmake

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}
# Don't build the cairo graphics backend.
CONFIGURE_ARGS+=	--disable-cairo-output
# Don't build the splash graphics backend.
CONFIGURE_ARGS+=	--disable-splash-output
# Don't compile poppler qt wrapper.
CONFIGURE_ARGS+=	--disable-poppler-qt
# Don't compile GTK+ test program.
CONFIGURE_ARGS+=	--disable-gtk-test
# Don't compile GLib wrapper which also needs gtk2
CONFIGURE_ARGS+=	--disable-poppler-glib
# Enable build and install of the tools
CONFIGURE_ARGS+=	--enable-utils	# the default

BUILDLINK_API_DEPENDS.poppler+=     poppler>=${POPPLER_VERS}
.include "../../print/poppler/buildlink3.mk"

.if !empty(PKG_BUILD_OPTIONS.poppler:Mpoppler-cms)
CONFIGURE_ARGS+=	--enable-cms
.else
CONFIGURE_ARGS+=	--disable-cms
.endif

BUILD_DIRS=		utils # implies INSTALL_DIRS too

.include "../../mk/bsd.prefs.mk"

.if !empty(MACHINE_PLATFORM:MNetBSD-[12].*)
.include "../../devel/pthread-stublib/buildlink3.mk"
PTHREAD_STUBLIB=	"-L${LOCALBASE}/lib -Wl,-R${LOCALBASE}/lib -lpthstub"
.else
PTHREAD_STUBLIB=	# provided by libc
.endif
MAKE_ENV+=		PTHREAD_STUBLIB=${PTHREAD_STUBLIB}

.include "../../mk/jpeg.buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"