[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / print / gv

File: [cvs.NetBSD.org] / pkgsrc / print / gv / Makefile (download)

Revision 1.65, Tue Jul 3 20:01:43 2007 UTC (16 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.64: +2 -3 lines

Update to 3.6.3:

%%%%%%%%%%%%%%%%%%% GV 3.6.3  (June 2007) %%%%%%%%%%%%%%%%%%%%%%%%%%%%%

# gv is now able to work with latest ghostscript: gs 8.57

# The bug causing the version not to figure in the manual has been
  fixed.

# The SIGINT signal is now masked (ignored) by gv.

# gv no more segfaults when reading a configuration file as produced by
  State -> Setup Options -> Save

# gv should compile in non-GNU system that doesnt have glib2. The
  `getopt' gnulib module has been imported to fix this.

# gv now correctly adjust the page index window after PAGE-UP and
  PAGE-DOWN events.

# gv is now able to open files with minus character beginning
  filenames.

# X resources related bugs has been fixed. gv is now able to get
  resources from the display database, user file, gv system database
  and command line doing the Right Thing (TM).

# gv is now able to correctly understand DocumentMedia and other DSC
  directives that uses postscript strings. It was not possible with
  previous versions due to a bug in the postscript names scanning
  routine.

* Vulnerability CVE-2006-5864 has been fixed.

* gs is now invoked with `-dFIXEDMEDIA'

* The internal gettext implementation has been renamed to `ps_gettext'
  to avoid collisions with the builtin `gettext' function.

* --quiet and --noquiet now works as expected.

? There are troubles with 64 bits machines: the use of x-pointers to
  store data should be eliminated in subsequent versions.

# $NetBSD: Makefile,v 1.65 2007/07/03 20:01:43 wiz Exp $

DISTNAME=	gv-3.6.3
CATEGORIES=	print
MASTER_SITES=	${MASTER_SITE_GNU:=gv/}

MAINTAINER=	tron@NetBSD.org
HOMEPAGE=	http://www.gnu.org/software/gv/
COMMENT=	PostScript and PDF previewer

GNU_CONFIGURE=		yes
USE_TOOLS+=		gmake gs:run makeinfo

TEXINFO_REQD=		4.2
INFO_FILES=		yes
LIBS+=			${BUILDLINK_LDADD.getopt}

# this pkg does not work with std xaw, but xpm and xaw3d work
XAW_TYPE?=		3d
.include "../../mk/bsd.prefs.mk"
.if ${XAW_TYPE} == "standard"
XAW_TYPE=		3d
.endif

# Solaris-2.{8,9}/sparc are missing setenv() and unsetenv()
# it is probably true that 5.6, 5.7, 5.8, and 5.9 all have
# this problem.  It appears that 5.10 does not need this flag.
.if ${OPSYS} == "SunOS" && !empty(OS_VERSION:M5.[6789])
CONFIGURE_ARGS+=	--enable-setenv-code
.endif

.include "../../devel/libgetopt/buildlink3.mk"
.include "../../mk/xaw.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"