[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / print / gutenprint-lib

Annotation of pkgsrc/print/gutenprint-lib/Makefile, Revision 1.5

1.5     ! joerg       1: # $NetBSD: Makefile,v 1.4 2008/03/06 14:53:53 wiz Exp $
1.1       gdt         2:
                      3: VERSION=       5.0.2
                      4: DISTNAME=      gutenprint-${VERSION}
                      5: EXTRACT_SUFX=  .tar.bz2
                      6: PKGNAME=       gutenprint-lib-${VERSION}
1.5     ! joerg       7: PKGREVISION=   3
1.1       gdt         8: CATEGORIES=    print
                      9: MASTER_SITES=  ${MASTER_SITE_SOURCEFORGE:=gimp-print/}
                     10:
                     11: MAINTAINER=    gdt@NetBSD.org
                     12: COMMENT=       Drivers for Canon, Epson, Lexmark, and PCL printers
                     13: HOMEPAGE=      http://gutenprint.sourceforge.net/
                     14:
                     15: # Not sure if this works.
                     16: #PKG_DESTDIR_SUPPORT=  user-destdir
                     17:
1.5     ! joerg      18: USE_TOOLS+=            gmake lex pkg-config perl:run
1.1       gdt        19: USE_PKGLOCALEDIR=      YES
                     20: USE_LIBTOOL=           YES
                     21:
                     22: USE_LANGUAGES+=                c99 c++
1.2       gdt        23: # gcc 3.3.3 either can't compile this, or needs huge amounts of RAM (0.5G+).
                     24: # Observed on NetBSD/i386 3 and confirmed with upstream.  Apparently it's
                     25: # just 3.3.3 - there are no known issues with 2.95.
1.1       gdt        26:
                     27: # gutenprint has many options, and really should be split into
                     28: # multiple packages.  Splitting is difficult because of the structure
                     29: # of the upstream distribution.  For now, this package contains
                     30: # everything that gdt wants, because that seems more useful to users
                     31: # than not having gutenprint in pkgsrc.
                     32:
                     33: GNU_CONFIGURE=         YES
                     34:
                     35: # XXX Make command.types be a CONF_FILE
                     36:
                     37: # Adjust configure to disable components that we don't want.  For
                     38: # components that should eventually be in split packages, we mark them
                     39: # as such.  Related configure options are grouped together; for now we list
                     40: # many default options that probably will not be exercised.
                     41:
                     42: # GTK1 ui and gimp1 plugin.  These are obsolete and will not
                     43: # be supported.
                     44: CONFIGURE_ARGS+=       --disable-libgutenprintui
                     45: CONFIGURE_ARGS+=       --without-gimp
                     46:
                     47: # CUP support.  This should be in a split package
                     48: #CONFIGURE_ARGS+=      --without-cups
                     49: #CONFIGURE_ARGS+=      --enable-cups-1_2-enhancements
                     50: #CONFIGURE_ARGS+=      --disable-cups-ppds
                     51: #CONFIGURE_ARGS+=      --disable-translated-cups-ppds
                     52:
                     53: # Ghostscript support.  This should be in split packages, if at all.
                     54: CONFIGURE_ARGS+=       --without-ghost
                     55:
                     56: # GTK2 ui and gimp2 plugin
                     57: #CONFIGURE_ARGS+=      --disable-libgutenprintui2
                     58: #CONFIGURE_ARGS+=      --without-gimp2
                     59: # By default, the gimp2 plugin is named gutenprint
                     60: #CONFIGURE_ARGS+=      --with-gimp2-as-gutenprint
                     61:
                     62: # Foomatic support.  This should be in a split package, if at all.
                     63: CONFIGURE_ARGS+=       --without-foomatic              # split-pkg
                     64: #CONFIGURE_ARGS+=      --with-foomatic3                # IN ABOVE
                     65:
                     66: # Disable translated ppds.  Without this option, there are dozens of
                     67: # copies of each printer, differing in the CUPS UI only by a language
                     68: # code.  The awkwardness seems to outweigh the benefit.
                     69: CONFIGURE_ARGS+=       --without-translated-ppds
                     70:
                     71: # Sample images.  These are small so there seems to be no point in
                     72: # omitting them.
                     73: #CONFIGURE_ARGS+=      --disable-samples               # base
                     74:
                     75: # escputil.  This is a utility for epson printers.  It should arguably
                     76: # be in a split package, but it is tiny so there is little point other
                     77: # than cleanliness.
                     78: #CONFIGURE_ARGS+=      --disable-escputil
                     79: # XXX Something in gutenprint seems to use readline, but it's not clear why,
                     80: # so just disable it to reduce dependencies.
                     81: CONFIGURE_ARGS+=       --without-readline
                     82:
                     83: # test pattern generator.
                     84: #CONFIGURE_ARGS+=      --disable-test
                     85: #CONFIGURE_ARGS+=      --disable-testpattern
                     86:
                     87: # iconv?
                     88:
                     89: .include "../../devel/gettext-lib/buildlink3.mk"
                     90:
                     91: # gutenprint-gimp: gimp plugin
                     92: .include "../../graphics/gimp/buildlink3.mk"
                     93: .include "../../x11/gtk2/buildlink3.mk"
                     94:
                     95: # gutenprint-cups: cups support
                     96: .include "../../print/cups/buildlink3.mk"
                     97:
                     98: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>