[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / print / gutenprint-lib

Annotation of pkgsrc/print/gutenprint-lib/Makefile, Revision 1.107

1.107   ! adam        1: # $NetBSD: Makefile,v 1.106 2021/05/24 19:53:45 wiz Exp $
1.1       gdt         2:
1.91      gdt         3: INSTALLVERSION=        5.3
                      4: VERSION=       ${INSTALLVERSION}.3
1.1       gdt         5: DISTNAME=      gutenprint-${VERSION}
                      6: PKGNAME=       gutenprint-lib-${VERSION}
1.107   ! adam        7: PKGREVISION=   13
1.1       gdt         8: CATEGORIES=    print
                      9: MASTER_SITES=  ${MASTER_SITE_SOURCEFORGE:=gimp-print/}
1.91      gdt        10: EXTRACT_SUFX=  .tar.xz
1.1       gdt        11:
                     12: MAINTAINER=    gdt@NetBSD.org
                     13: COMMENT=       Drivers for Canon, Epson, Lexmark, and PCL printers
1.96      nia        14: HOMEPAGE=      http://gutenprint.sourceforge.net/
1.1       gdt        15:
1.59      gdt        16: LICENSE=       gnu-gpl-v2
                     17:
1.12      reed       18: PREV_PKGPATH=  print/gutenprint51-lib
                     19:
1.92      rillig     20: PLIST_SUBST+=          INSTALLVERSION=${INSTALLVERSION}
1.21      gdt        21: PRINT_PLIST_AWK+=      { gsub("gutenprint/${INSTALLVERSION}", \
                     22:                                "gutenprint/$${INSTALLVERSION}") }
                     23: PRINT_PLIST_AWK+=      { gsub(".${INSTALLVERSION}$$", \
                     24:                                ".$${INSTALLVERSION}") }
1.7       gdt        25:
1.5       joerg      26: USE_TOOLS+=            gmake lex pkg-config perl:run
1.1       gdt        27: USE_PKGLOCALEDIR=      YES
                     28: USE_LIBTOOL=           YES
                     29:
1.26      gdt        30: USE_LANGUAGES+=                c99
                     31:
                     32: GNU_CONFIGURE=         YES
1.1       gdt        33:
1.101     triaxx     34: .include "../../print/gutenprint-lib/options.mk"
                     35:
1.1       gdt        36: # gutenprint has many options, and really should be split into
                     37: # multiple packages.  Splitting is difficult because of the structure
                     38: # of the upstream distribution.  For now, this package contains
                     39: # everything that gdt wants, because that seems more useful to users
                     40: # than not having gutenprint in pkgsrc.
                     41:
1.26      gdt        42: # Adjust configure to disable components that we don't want.  Note
                     43: # components that should eventually be in split packages.  Options
                     44: # that are on by default are commented out.  Options that default to
                     45: # on or off and are not particularly interesting are not mentioned.
                     46:
                     47: # gdt doesn't understand what this means.
                     48: # --enable-nls-macosx     build CUPS PPD files [(automatic)]
                     49:
                     50: # cups ppds (separate from cups support, probably)
                     51: # Note that the default is to install a program which generates ppds,
                     52: # rather than large numbers of ppds.
                     53: #CONFIGURE_ARGS+=      --enable-cups-ppds
                     54: #CONFIGURE_ARGS+=      --enable-cups-1_2-enhancements
                     55: # Disable translated ppds.  Without this option, there are dozens of
                     56: # copies of each printer, differing in the CUPS UI only by a language
                     57: # code.  The awkwardness seems to outweigh the benefit.
                     58: CONFIGURE_ARGS+=       --disable-translated-cups-ppds
                     59: # --enable-globalized-cups-ppds (auto)
                     60:
                     61: # Respect upstream's judgement about this issue, without understanding.
                     62: # --enable-static-genppd
1.1       gdt        63:
1.26      gdt        64: # GTK2 ui (on by default)
                     65: #CONFIGURE_ARGS+=      --enable-libgutenprintui2
1.1       gdt        66:
1.26      gdt        67: # Sample images are small, so let them be included.
                     68: #CONFIGURE_ARGS+=      --enable-samples
1.1       gdt        69:
1.26      gdt        70: # escputil is a utility for Epson printers.  It should arguably be in
                     71: # a split package, but it's small and useful so splitting isn't worth
                     72: # the effort.
1.92      rillig     73: CONFIGURE_ARGS+=       --enable-escputil
1.26      gdt        74:
1.66      gdt        75: # test pattern generator.  Small, so let it be built.
1.26      gdt        76: #CONFIGURE_ARGS+=      --enable-test
                     77: #CONFIGURE_ARGS+=      --enable-testpattern
1.1       gdt        78:
1.21      gdt        79: # CUPS support, on by default.  This should be in a split package.
                     80: #CONFIGURE_ARGS+=      --with-cups
1.1       gdt        81:
1.21      gdt        82: # Something in gutenprint seems to use readline, but it's not clear
                     83: # why, so just disable it to reduce dependencies.
1.1       gdt        84: CONFIGURE_ARGS+=       --without-readline
                     85:
1.26      gdt        86: # XXX Make command.types be a CONF_FILE
1.1       gdt        87:
1.81      gdt        88: # XXX Replace patch-aa with SUBST_SED to use PREFIX rather than hard-coded /usr/pkg.
                     89:
1.18      gdt        90: TEST_TARGET=           check
                     91:
1.7       gdt        92: # A libintl is optional in gutenprint.
1.1       gdt        93: .include "../../devel/gettext-lib/buildlink3.mk"
                     94:
                     95: # gutenprint-cups: cups support
1.72      khorben    96: .include "../../print/cups-base/buildlink3.mk"
1.1       gdt        97:
                     98: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>