File:  [cvs.NetBSD.org] / pkgsrc / print / foomatic-ppds / Makefile
Revision 1.3: download - view: text, annotated - select for diffs
Sun Feb 5 23:10:36 2006 UTC (18 years, 10 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1, HEAD
Recursive revision bump / recommended bump for gettext ABI change.

# $NetBSD: Makefile,v 1.3 2006/02/05 23:10:36 joerg Exp $

.include "Makefile.common"

DISTNAME=	foomatic-filters-ppds-${FOOMATIC_PPDS_VERSION}
PKGNAME=	${DISTNAME:S/-filters-/-/}
PKGREVISION=	1

# The definitive location of the distfile is at www.linuxprinting.org,
# but this tarball is regenerated daily from the Foomatic database.
# Rather than track this file very aggressively, we'll place a new
# copy at MASTER_SITE_LOCAL periodically and update this package
# accordingly.
#
MASTER_SITES=	${MASTER_SITE_LOCAL} \
		http://www.linuxprinting.org/download/foomatic/

MAINTAINER=	jlam@pkgsrc.org
COMMENT=	Foomatic PPDs collection

DEPENDS=	foomatic-filters>=3.0.2:../../print/foomatic-filters

REQD_DIRS=	share/foomatic
PLIST_SRC=	${WRKDIR}/PLIST_SRC

do-build:
	${CAT} ${PKGDIR}/PLIST > ${PLIST_SRC}
	cd ${WRKSRC}/share;						\
	${FIND} ppd -type f -print | ${SORT} -u |			\
	${SED} -e "s|^|share/foomatic/|" >> ${PLIST_SRC}
	cd ${WRKSRC}/share;						\
	${FIND} ppd -type d -print | ${SORT} -ur |			\
	${SED} -e "s|^|@dirrm share/foomatic/|" >> ${PLIST_SRC}
	${ECHO} "@dirrm share/foomatic" >> ${PLIST_SRC}

do-install:
	${CP} -R ${WRKSRC}/share/ppd ${PREFIX}/share/foomatic/ppd

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>