[BACK]Return to Makefile.in CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / pkgtools / pkg_install / files / create

File: [cvs.NetBSD.org] / pkgsrc / pkgtools / pkg_install / files / create / Makefile.in (download)

Revision 1.10, Tue Sep 23 07:44:51 2003 UTC (20 years, 6 months ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2004Q2-base, pkgsrc-2004Q2, pkgsrc-2004Q1-base, pkgsrc-2004Q1, pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.9: +4 -2 lines

add --with-{ftp,mtree,pax,tar} to allow overriding the commands that
pkg_install calls, and pass the full path for each from the pkg Makefile.

fixes issue with pkg_add and pkg_create calling non-existent or
less-than-functional tools since it relied on $PATH.

# $NetBSD: Makefile.in,v 1.10 2003/09/23 07:44:51 grant Exp $

srcdir=		@srcdir@

prefix=		@prefix@
exec_prefix=	@exec_prefix@
sbindir=	@sbindir@
mandir=		@mandir@

man1dir=	$(mandir)/man1
cat1dir=	$(mandir)/cat1

tar=		@tar@

CC=		@CC@
CCLD=		$(CC)
LIBS=		-linstall @LIBS@
CPPFLAGS=	@CPPFLAGS@ -I. -I$(srcdir) -I../lib
DEFS=		@DEFS@ -DTAR_CMD=\"$(tar)\"
CFLAGS=		@CFLAGS@
LDFLAGS=	@LDFLAGS@ -L../lib

INSTALL=	@INSTALL@

PROG=		pkg_create

SRCS=	main.c perform.c pl.c
OBJS=	$(SRCS:.c=.o)

.PHONY: all clean install

.c.o:
	$(CC) $(DEFS) $(CPPFLAGS) $(CFLAGS) -c $<

all: $(PROG)

$(PROG): $(OBJS)
	$(CCLD) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)

clean:
	rm -f $(OBJS) $(PROG)

install:
	$(INSTALL) -m 755 -d $(sbindir)
	$(INSTALL) -m 755 -d $(man1dir)
	$(INSTALL) -m 755 -d $(cat1dir)
	$(INSTALL) $(PROG) $(sbindir)
	$(INSTALL) -m 444 $(PROG).1 $(man1dir)/$(PROG).1
	$(INSTALL) -m 444 $(PROG).cat1 $(cat1dir)/$(PROG).0