The NetBSD Project

CVS log for pkgsrc/pkgtools/pkg_install/files/configure.ac

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / pkgtools / pkg_install / files

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.44 / (download) - annotate - [select for diffs], Wed Dec 2 10:22:39 2020 UTC (12 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, HEAD
Changes since 1.43: +3 -3 lines
Diff to previous 1.43 (colored)

*: move default database directory from /var/db/pkg to ${PREFIX}/pkgdb

As discussed in August 2020 and previously on pkgsrcCon 2019.

Ok pkgsrc-pmc@

Revision 1.43 / (download) - annotate - [select for diffs], Wed Jul 1 10:15:20 2020 UTC (17 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.42: +2 -2 lines
Diff to previous 1.42 (colored)

pkg_install: Update version to 20200701.

Includes fixes to +REQUIRED_BY generation, performance improvements,
build fixes against newer libnetpgpverify, and better error messages.

When combined with newer pkgin releases, this should now eliminate the
various "pkg_add: Can't open +CONTENTS of depending package ..." errors
that users had frequently observed during upgrades (joyent/pkgsrc#158,
joyent/pkgsrc#190, joyent/pkgsrc#256, and many IRC logs).

Revision 1.42 / (download) - annotate - [select for diffs], Thu Jun 30 17:42:04 2016 UTC (5 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.41: +2 -2 lines
Diff to previous 1.41 (colored)

Remove last traces of bmp here too.

Was not installed for a long time and recently removed from NetBSD base.

Revision 1.41 / (download) - annotate - [select for diffs], Sun Feb 14 08:06:54 2016 UTC (5 years, 9 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.40: +2 -2 lines
Diff to previous 1.40 (colored)

Fix a small typo to ensure the name of the header file is correct.

Revision 1.40 / (download) - annotate - [select for diffs], Thu Oct 15 13:31:27 2015 UTC (6 years, 1 month ago) by sevan
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.39: +3 -4 lines
Diff to previous 1.39 (colored)


Do not check for or include sys/param.h
This resolves issues on platforms which MACHINE & MACHINE_ARCH is explicitly
defined, such as OpenBSD/amd64 & Bitrig/amd64 where we would like to build with
MACHINE_ARCH=x86_64 but can't as a platform check fails when installing
packages after bootstrap
pkg_add: Warning: package `digest-20121220' was built for a platform:
pkg_add: OpenBSD/x86_64 5.8 (pkg) vs. OpenBSD/amd64 5.8 (this host)

Tested on
Mac OS X Tiger/PowerPC
OpenBSD
Bitrig
Solaris 10/SPARC
FreeBSD 10.2-RELEASE & 11-CURRENT
DragonFlyBSD
Debian 8
OmniOS

Reviewed by joerg@

Revision 1.39 / (download) - annotate - [select for diffs], Thu Jan 22 18:15:39 2015 UTC (6 years, 10 months ago) by pho
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.38: +4 -1 lines
Diff to previous 1.38 (colored)

Add AC_SYS_LARGEFILE to files/configure.ac

Given that libarchive is built with large file support, pkg_install
needs it too. Otherwise libarchive and pkg_install may see different
definitions of types such as struct stat, resulting in a runtime
failure on some platforms (especially Darwin 9):

  % bmake package
  => Creating binary package /usr/pkgsrc/pkgtools/pkg_install/work/.packages/pkg_install-20141227.tgz
  pkg_create: cannot write to archive: tar format cannot archive this (type=00)

The reason why this was unnoticed until now is that libarchive's
"configure" has just been regenerated with Autoconf 2.69. Prior to
2.69, AC_SYS_LARGEFILE did nothing significant on Darwin so there was
no actual inconsistency between libarchive and pkg_install, which was
just coincidental.

Revision 1.38 / (download) - annotate - [select for diffs], Sat Aug 3 11:45:14 2013 UTC (8 years, 4 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.37: +2 -2 lines
Diff to previous 1.37 (colored)

* BSD/OS and OSF/1 are also missing `z' modifier support for printf(3) format.
* bare `zu' modifier is used, it should be replaced with `PRIzu` instead.

Fixes crash with `pkg_admin rebuild' on platforms missing %z support,
PR pkg/48070.

Revision 1.37 / (download) - annotate - [select for diffs], Sun Feb 10 12:46:56 2013 UTC (8 years, 9 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

Also set NUMERIC_VERSION_ONLY for Cygwin,
eliminate (api_major.api_minor/shared_data/mount_registory) part.

Revision 1.36 / (download) - annotate - [select for diffs], Wed Apr 20 09:57:25 2011 UTC (10 years, 7 months ago) by morr
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.35: +2 -2 lines
Diff to previous 1.35 (colored)

Add linux to list for retaining the numeric OS version.
Fixes PR pkg/43622.

Revision 1.35 / (download) - annotate - [select for diffs], Tue Apr 20 00:39:12 2010 UTC (11 years, 7 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.34: +23 -1 lines
Diff to previous 1.34 (colored)

pkg_install-20100420:
Extract dependencies of libarchive from the pkgconfig file and thereby
drop knowledge of the needed libraries.

At least some versions of HP-UX are known to not support %zu, add a
workaround. This is using the black list approach for now.

Recognize xz as compression type for pkg_create.

The first time an error is hit while fetching packages, try to reget
from the same position. This works around the server closing the
connection while fetching dependencies.

Revision 1.34 / (download) - annotate - [select for diffs], Sat Jan 23 22:41:43 2010 UTC (11 years, 10 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.33: +2 -2 lines
Diff to previous 1.33 (colored)

Check -lnetwork for gethostbyname on Haiku. From PR 42665.

Revision 1.33 / (download) - annotate - [select for diffs], Fri Jan 22 13:30:41 2010 UTC (11 years, 10 months ago) by joerg
Branch: MAIN
Changes since 1.32: +6 -9 lines
Diff to previous 1.32 (colored)

pkg_install-20100122:
- Refactor man pages:
  - Move description of environmental variables into pkg_install.conf(5)
  - Remove a bunch of dead references
  - Avoid using hard-coded path names that can easily be overridden by
    the user.
- Refactor pkgdb related logic, so that -K behaves consistently.
- Add some helper functions to isolate more places from the pkgdb
  layout.
- Sync license list.
- Handle PKG_REFCOUNT_DBDIR consistently as option too.
- Utilize connection cache from libfetch.
- Add helper target for cat pages updates.

Revision 1.32 / (download) - annotate - [select for diffs], Thu Jan 21 21:58:05 2010 UTC (11 years, 10 months ago) by jmmv
Branch: MAIN
Changes since 1.31: +9 -3 lines
Diff to previous 1.31 (colored)

Stick the correct value of PKG_DBDIR into the manpages instead of
pointing the user to /var/db/pkg, which may not be the right value if
it was customized.  Bump version to 20100121.

Revision 1.31 / (download) - annotate - [select for diffs], Fri Sep 11 18:00:12 2009 UTC (12 years, 2 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3
Changes since 1.30: +5 -8 lines
Diff to previous 1.30 (colored)

pkg_install-20090911:
- Cleanup configure.ac to not check for headers and functions not used
- Always use nbcompat/db.h on !NetBSD (PR 41865)
- Don't bother setting termwidth in pkg_info, it is never used.

Revision 1.30 / (download) - annotate - [select for diffs], Thu Feb 19 20:27:36 2009 UTC (12 years, 9 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1
Changes since 1.29: +4 -1 lines
Diff to previous 1.29 (colored)

Make sure that SYSCONFDIR is expanded in pkg_install.conf(5).

Revision 1.29 / (download) - annotate - [select for diffs], Thu Feb 12 00:14:48 2009 UTC (12 years, 9 months ago) by joerg
Branch: MAIN
Changes since 1.28: +1 -2 lines
Diff to previous 1.28 (colored)

Don't check for tgetent or curses, it is never used.

Revision 1.28 / (download) - annotate - [select for diffs], Mon Feb 2 12:35:00 2009 UTC (12 years, 10 months ago) by joerg
Branch: MAIN
Changes since 1.27: +9 -29 lines
Diff to previous 1.27 (colored)

Merge pkg_install-20090201 from pkg_install-renovation branch.

- DB support is always included from libnbcompat if needed
- pkg_view and linkfarm are not installed any more; they are not moved
into the attic yet, so they can easily be installed as separte package
- common configuration file to customise the behavior of various
components; this supersedes the old audit-packages.conf
- support for PKSC7 signatures (using X509 certs) and GPG signatures for
packages in a secure way. See pkg_admin(8) for how to create them and
pkg_install.conf(5) for the options to use them
- audit-packages and download-vulnerability-list are wrapper scripts
  around pkg_admin. They try to mimic the classic options if used sanely.
  "pkg_admin audit" is now an order of magnitude faster than before
- pkg_add uses libarchive and libfetch instead of external ftp and tar:
  - progress bar is currently missing for downloads
  - "pkg_add -" is no longer supported
  - no adhoc check for conficts between dependencies and already
    installed packages
  - "pkg_add -s" has been replaced with an option in pkg_install.conf,
    verification of plain detached GPG signatures is no longer supported
  - optional check for vulnerabilities before adding a package
  - if /var and /usr/pkg are on different fileystems it is twice as fast
    now
  - conflicts due to overlapping plists are checked before installation
  - pkg_add no longer plays with the process limits
- pkg_add and pkg_delete have a new destdir option; scripts have to
  either be modified to use PKG_DESTDIR or should be disabled
- pkg_add -u for now can't be used to update to the exact same version
- internal "rm -rf" and "mkdir_p" code
- all memory allocation failures are not explicitly fatal
- if a file is not removed due to a failed checksum, still remove the
  entry from pkgdb

Revision 1.26.2.6 / (download) - annotate - [select for diffs], Mon Feb 2 11:55:15 2009 UTC (12 years, 10 months ago) by joerg
Branch: pkg_install-renovation
Changes since 1.26.2.5: +1 -1 lines
Diff to previous 1.26.2.5 (colored) to branchpoint 1.26 (colored) next main 1.27 (colored)

pkg_install-20090201:
- sync DESCR and MESSAGE with HEAD and the branch state
- sync Makefile
- regen configure
- cleanup __RCSID
- merge audit logic in pkg_add and pkg_admin into new audit_packages
function. As side effect, pkg_add will list all vulnerabilities before
asking the user whether it should continue
- sort config_variable array

Revision 1.26.2.5 / (download) - annotate - [select for diffs], Sun Sep 21 13:02:58 2008 UTC (13 years, 2 months ago) by joerg
Branch: pkg_install-renovation
Changes since 1.26.2.4: +3 -10 lines
Diff to previous 1.26.2.4 (colored) to branchpoint 1.26 (colored)

Clean up autoconf output list and add bmp.sh to the distclean target.

Revision 1.27 / (download) - annotate - [select for diffs], Tue Sep 16 13:32:58 2008 UTC (13 years, 2 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3
Changes since 1.26: +1 -1 lines
Diff to previous 1.26 (colored)

20080915:
Merge a number of bugfixes from the pkg_install-renovation branch:
- explicit include of nbcompat/md5.h
- use errx when dealing with libfetch as it doesn't set errno
- avoid optind = 0 as GNUish getopt will reset itself otherwise

Revision 1.26.2.4 / (download) - annotate - [select for diffs], Thu Jun 12 15:16:41 2008 UTC (13 years, 5 months ago) by joerg
Branch: pkg_install-renovation
Changes since 1.26.2.3: +0 -1 lines
Diff to previous 1.26.2.3 (colored) to branchpoint 1.26 (colored)

Stop doing the rlimit dance. Last time I checked, the dependency graph
had a depth around 17. Given that ISO C allows at least 20 open streams,
that should be good enough on all systems.

Revision 1.26.2.3 / (download) - annotate - [select for diffs], Sat May 24 21:54:22 2008 UTC (13 years, 6 months ago) by joerg
Branch: pkg_install-renovation
Changes since 1.26.2.2: +1 -7 lines
Diff to previous 1.26.2.2 (colored) to branchpoint 1.26 (colored)

pkg_install-20080524:
Stop installation the pkg_view and linkform script as part of
pkg_install. They are the only remaining user of the pax dependency.
This was discussed was agc@ and the consensus is that if someone really
wants them, they should be pulled into a separate less essential
package.

Revision 1.26.2.2 / (download) - annotate - [select for diffs], Fri May 23 15:51:22 2008 UTC (13 years, 6 months ago) by joerg
Branch: pkg_install-renovation
Changes since 1.26.2.1: +1 -1 lines
Diff to previous 1.26.2.1 (colored) to branchpoint 1.26 (colored)

Consistently use the libnbcompat header for md5 if this is not a native
NetBSD build.

Revision 1.26.2.1 / (download) - annotate - [select for diffs], Sun May 11 20:20:37 2008 UTC (13 years, 6 months ago) by joerg
Branch: pkg_install-renovation
Changes since 1.26: +6 -12 lines
Diff to previous 1.26 (colored)

Add support PKCS7 signatures in packages and pkg-vulnerabilities.
The support for non-native OpenSSL still needs to be done, e.g.
ensure static linkage for that. Documentation is essentially missing.

Revision 1.26 / (download) - annotate - [select for diffs], Sun Apr 20 13:59:09 2008 UTC (13 years, 7 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkg_install-renovation-base, cwrapper-base, cwrapper, cube-native-xorg-base, cube-native-xorg
Branch point for: pkg_install-renovation
Changes since 1.25: +10 -0 lines
Diff to previous 1.25 (colored)

Detect socket and gethostbyname requirements for Solaris.

Revision 1.25 / (download) - annotate - [select for diffs], Mon Feb 4 14:28:27 2008 UTC (13 years, 10 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1
Changes since 1.24: +1 -1 lines
Diff to previous 1.24 (colored)

pen.c only uses statvfs.h and the necessary headers are included by
libnbcompat.h already. So don't include sys/param.h and sys/mount.h in
it and remove the configure test for sys/mount.h.
While here, remove some #if 0'd code from pen.c.

Revision 1.24 / (download) - annotate - [select for diffs], Fri Aug 24 15:25:09 2007 UTC (14 years, 3 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.23: +1 -1 lines
Diff to previous 1.23 (colored)

Drop -RELEASE and similiar components of the OS version on FreeBSD as
well.

Revision 1.23 / (download) - annotate - [select for diffs], Sun Aug 5 01:27:55 2007 UTC (14 years, 4 months ago) by joerg
Branch: MAIN
Changes since 1.22: +5 -4 lines
Diff to previous 1.22 (colored)

Detect grp.h. Regen.

Revision 1.22 / (download) - annotate - [select for diffs], Fri Aug 3 13:15:59 2007 UTC (14 years, 4 months ago) by joerg
Branch: MAIN
Changes since 1.21: +6 -0 lines
Diff to previous 1.21 (colored)

- only build pkg_admin, pkg_create and pkg_info for --enable-bootstrap
- for pkg_create, split-off the package creation from the plist
  processing. package creation is disabled for --enable-bootstrap
- change package creation to use libarchive
- add two options (-u and -g) to override file system ownership
- pkg_create now creates files in the tarball with correct owner/group
  based on -u/-g or @owner/@group
- add a function to compute the +CONTENTS file in memory

Bump version to 20070802.
Review of a slightly older version by jlam@

Revision 1.21 / (download) - annotate - [select for diffs], Wed Jul 25 15:01:46 2007 UTC (14 years, 4 months ago) by joerg
Branch: MAIN
Changes since 1.20: +1 -7 lines
Diff to previous 1.20 (colored)

Mostly deorbit mtree support:
- pkg_create bails out with -m
- pkg_add ignores mtree specs in packages and prints a warning.
  It does not remove the file like before.
- remove now obsolete documentation.

pkg_info still prints the information and pkg_admin ignores the files.
Make the dependency on the tools a runtime dependency.
Take maintainership of pkg_install and bump version to 20070725.

Revision 1.20 / (download) - annotate - [select for diffs], Sat Jul 21 10:21:04 2007 UTC (14 years, 4 months ago) by adrianp
Branch: MAIN
Changes since 1.19: +6 -0 lines
Diff to previous 1.19 (colored)

Misc man page fixes
Update to autoconf 2.61
Add checks for AC_TYPE_UINT{8,16,32,64}_T
Add checks for stdint.h
Change how config file notification works
If no IGNORE_URLS directive is found then just say that
Check that pkg-vulnerabilities exists before we try any operations on it
Use st_ctime as opposed to st_ctimespec.tv_sec as the former is SUSv3
This update should fix PR #36655 and go part way to fixing PR #36662

Thanks to tnn@ and joerg@ for suggested fixes and Yakovetsky Vladimir and
 Stuart Shelton for testing and patches.

Revision 1.19 / (download) - annotate - [select for diffs], Sat Jul 14 20:17:07 2007 UTC (14 years, 4 months ago) by adrianp
Branch: MAIN
Changes since 1.18: +8 -1 lines
Diff to previous 1.18 (colored)

Update to pkg_install-20070714
Merge of audit-packages with various improvements:
* Version 20070714
	Initial release of re-write in C
	Add support for notfication of eol packages (-e)
	Multiple levels of verbosity (e.g. -v -v)
	Specify a custom config file to use (-c)
	Query running config values (-Q)
	Default to download .gz compress pkg-vulnerabilities file
	Support for .bz2 compress pkg-vulnerabilities file
	Verify signature on downloaded files (-s)

Thanks to tron@, jschauma@, agc@, joerg@ and pkgsrc-security@ for feedback
and testing.

Revision 1.18 / (download) - annotate - [select for diffs], Mon Apr 16 12:55:35 2007 UTC (14 years, 7 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2
Changes since 1.17: +1 -1 lines
Diff to previous 1.17 (colored)

Sync with NetBSD base:
Some FTP server don't expand [] in NLIST, most noticable is vsftpd.
Avoid this by splitting the wildcard search pattern into two commands.
Sync some other minor changes.

Bump to 20070416.

Revision 1.17 / (download) - annotate - [select for diffs], Wed Jan 25 00:20:09 2006 UTC (15 years, 10 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.16: +6 -0 lines
Diff to previous 1.16 (colored)

Add conditional code to ignore the non-numeric part of an OS version
for the sake of compatibility tests in pkg_add.
E.g. DragonFly versions like
        1.4.0-RELEASE
are reduced to
        1.4.0

This code is currently enabled for DragonFly only.

Revision 1.16 / (download) - annotate - [select for diffs], Wed Jan 4 23:33:23 2006 UTC (15 years, 11 months ago) by christos
Branch: MAIN
Changes since 1.15: +3 -3 lines
Diff to previous 1.15 (colored)

Handle newer versions of Berkeley DB. Our algorithm is:

- if you have > db1 the probably you have db_185.h which means
  that dbopen is really __db185_open, and we'll prefer that.
- else if you have db1, then you have db1/db.h and dbopen
- else if you have db.h, then this is either the one from db1 and it will
  work with -ldb having dbopen, or it will not.

Note that the compatibility option on __db185_open() will actually not create
or update db1.85/1.86 files, but it will use the current format of the db
library. This compatibility layer is source code only.

Revision 1.15 / (download) - annotate - [select for diffs], Fri Jun 10 01:37:21 2005 UTC (16 years, 6 months ago) by dmcmahill
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.14: +45 -1 lines
Diff to previous 1.14 (colored)

add autoconf test for missing (like in openbsd-3.6) or broken (like
in AIX-4.3.2) PRIu64.  If it is missing or broken, provide one.  Should
address PR30375.  Welcome to pkg_install-20050607

Revision 1.14 / (download) - annotate - [select for diffs], Sat May 28 02:50:46 2005 UTC (16 years, 6 months ago) by dmcmahill
Branch: MAIN
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

- pull in the changes from usr.sbin which prevent an over flow
  of a 32 bit signed number when pkg_add-ing a binary package
  file larger than 512 Mb.

- Bump PKGTOOLS_VERSION (NOT!!! PKGTOOLS_REQD) to 20050527

Revision 1.13 / (download) - annotate - [select for diffs], Sat Aug 21 06:33:40 2004 UTC (17 years, 3 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1, pkgsrc-2004Q4-base, pkgsrc-2004Q4, pkgsrc-2004Q3-base, pkgsrc-2004Q3
Changes since 1.12: +1 -1 lines
Diff to previous 1.12 (colored)

Fix the version number of the package in the configure script, and modify
the Makefiles so that they can be built by really basic make programs.

Revision 1.12 / (download) - annotate - [select for diffs], Sat Aug 21 05:12:10 2004 UTC (17 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.11: +4 -3 lines
Diff to previous 1.11 (colored)

Alphabetize list of headers.

Revision 1.11 / (download) - annotate - [select for diffs], Fri Aug 13 14:49:59 2004 UTC (17 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.10: +1 -1 lines
Diff to previous 1.10 (colored)

Typo: it's <regex.h>, not <regext.h>.

Revision 1.10 / (download) - annotate - [select for diffs], Fri Aug 13 14:35:24 2004 UTC (17 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.9: +6 -2 lines
Diff to previous 1.9 (colored)

Add checks for all of the system headers used in the sources.  Also include
missing <netdb.h> in lib/ftpio.c for MAXHOSTNAMELEN definition on Solaris.

Revision 1.9 / (download) - annotate - [select for diffs], Fri Aug 6 16:57:03 2004 UTC (17 years, 4 months ago) by jlam
Branch: MAIN
Changes since 1.8: +3 -3 lines
Diff to previous 1.8 (colored)

Sync with version 20040730 from src/usr.sbin/pkg_install on the HEAD:

> Re-work the code which checks the recorded build versions of a binary
> package to make pkg_add work properly when no +BUILD_INFO file exists.
>
> Modify the return value from read_buildinfo() to return 1 for success
> and 0 for failure.
>
> Use symbolic constants, rather than integers.
>
> If we can't read the build information, always tell of this fact.
>
> Bump version to 20040730
>
> Addresses PR 26429; a different version of these mods were verified to
> allow a +BUILD_INFO-less binary package to be added by Martin Husemann.

Revision 1.8 / (download) - annotate - [select for diffs], Tue Jun 1 17:32:21 2004 UTC (17 years, 6 months ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.7: +1 -1 lines
Diff to previous 1.7 (colored)

Import 20040601.
  - Handle symlinks in a view correctly.
  - Remove superfluous escapes in BRE.

This closes PR pkg/24190.

Revision 1.7 / (download) - annotate - [select for diffs], Mon Jan 12 22:20:36 2004 UTC (17 years, 10 months ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.6: +1 -1 lines
Diff to previous 1.6 (colored)

don't bother checking for md5.h, as the result overrides libnbcompat's
more appropriate test.

fixes build problem noted on RedHat.

Revision 1.6 / (download) - annotate - [select for diffs], Sat Dec 20 04:23:05 2003 UTC (17 years, 11 months ago) by grant
Branch: MAIN
Changes since 1.5: +1 -1 lines
Diff to previous 1.5 (colored)

Sync pkgtools/pkg_install with src/usr.sbin/pkg_install from 20031220.
New features include OS/arch/version checking and a large speed
improvement to pkg_info.

Revision 1.5 / (download) - annotate - [select for diffs], Tue Sep 23 07:46:07 2003 UTC (18 years, 2 months ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.4: +1 -1 lines
Diff to previous 1.4 (colored)

bump date

Revision 1.4 / (download) - annotate - [select for diffs], Tue Sep 23 07:44:50 2003 UTC (18 years, 2 months ago) by grant
Branch: MAIN
Changes since 1.3: +25 -2 lines
Diff to previous 1.3 (colored)

add --with-{ftp,mtree,pax,tar} to allow overriding the commands that
pkg_install calls, and pass the full path for each from the pkg Makefile.

fixes issue with pkg_add and pkg_create calling non-existent or
less-than-functional tools since it relied on $PATH.

Revision 1.3 / (download) - annotate - [select for diffs], Mon Sep 8 04:49:06 2003 UTC (18 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.2: +18 -1 lines
Diff to previous 1.2 (colored)

Substitute for various program paths used by the linkfarm(1) and
pkg_view(1) shell scripts.

Revision 1.2 / (download) - annotate - [select for diffs], Thu Sep 4 20:34:04 2003 UTC (18 years, 3 months ago) by jlam
Branch: MAIN
Changes since 1.1: +7 -1 lines
Diff to previous 1.1 (colored)

Allow this to compile on systems without vfork by #define'ing it to fork.
This is okay since we just do vfork()/exec() in lib/ftpio.c and don't rely
on any vfork vs. fork semantics.

Revision 1.1 / (download) - annotate - [select for diffs], Mon Sep 1 16:27:10 2003 UTC (18 years, 3 months ago) by jlam
Branch: MAIN

Update pkg_install to 20030823, which has the changes to support
package views.  Pkgsrc changes include:

* Convert to use pkgtools/libnbcompat so that it's easier to keep
  this in sync with src/usr.sbin/pkg_install.

* Add a src2nbcompat script that converts src/usr.sbin/pkg_install
  into an appropriate start for pkgtools/pkg_install.  The script
  removes the Makefiles, adds CPP inclusion guards around each
  #include <...> line, and includes <nbcompat.h> at the top of each
  *.c file.  This should make it even easier to keep sources in
  sync with the HEAD.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>