[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / pkgtools / pkg_install

Annotation of pkgsrc/pkgtools/pkg_install/Makefile, Revision 1.97

1.97    ! jlam        1: # $NetBSD: Makefile,v 1.96 2004/03/13 19:12:26 jlam Exp $
1.4       hubertf     2:
1.58      schmonz     3: # Notes to package maintainers:
1.57      hubertf     4: #
1.58      schmonz     5: # To update this package, import from src/usr.sbin/pkg_install.
1.57      hubertf     6: #
1.58      schmonz     7: # Updating this package does not automatically necessitate bumping
                      8: # PKGTOOLS_REQD in bsd.pkg.mk. Do so if and only if there is a critical
                      9: # change in the pkg_* tools that pkgsrc relies on for proper operation.
1.57      hubertf    10:
1.58      schmonz    11: DISTNAME=              pkg_install-${VERSION}
1.1       agc        12: CATEGORIES=            pkgtools
1.58      schmonz    13: MASTER_SITES=          # empty
                     14: DISTFILES=             # empty
1.1       agc        15:
1.73      grant      16: MAINTAINER=            tech-pkg@NetBSD.org
1.82      reed       17: HOMEPAGE=              http://www.pkgsrc.org/
1.90      grant      18: COMMENT=               Package management and administration tools for pkgsrc
1.60      schmonz    19:
1.58      schmonz    20: GNU_CONFIGURE=         # defined
                     21: CONFIGURE_ARGS+=       --with-pkgdbdir=${PKG_DBDIR}
1.87      grant      22: CONFIGURE_ARGS+=       --with-ftp=${FETCH_CMD}
                     23: CONFIGURE_ARGS+=       --with-mtree=${MTREE}
                     24: CONFIGURE_ARGS+=       --with-pax=${PAX}
                     25: CONFIGURE_ARGS+=       --with-tar=${TAR}
1.58      schmonz    26:
1.65      schmonz    27: NO_PKGTOOLS_REQD_CHECK=        # defined
1.83      jlam       28: NO_BUILDLINK=          # defined
1.58      schmonz    29: NO_CHECKSUM=           # defined
                     30: NO_MTREE=              # defined
                     31: NO_PKG_REGISTER=       # defined
                     32: NO_PACKAGE=            Deinstallation is not permitted
1.88      grant      33: NO_TOOLS=              # defined
1.66      agc        34: PKG_PRESERVE=          # defined
1.1       agc        35:
1.97    ! jlam       36: # These are needed to solve a chicken-and-egg problem where pkgsrc uses
1.96      jlam       37: # newer features of pkg_install, but older NetBSD installations won't
                     38: # support them.  In this case, we explicitly use the native GCC
                     39: # compiler to avoid problems with depending on pkgsrc GCC for building
1.97    ! jlam       40: # pkg_install.  We also avoid building digest as that would involve
        !            41: # using the newer pkg_install tools.
1.96      jlam       42: #
                     43: USE_NATIVE_GCC=                yes
1.97    ! jlam       44: USE_DIGEST=            no
1.96      jlam       45:
1.89      grant      46: PLIST_SUBST+=          MANDIR=${MANDIR}
                     47: PLIST_SUBST+=          PKG_TOOLS_BIN=${PKG_TOOLS_BIN}
                     48:
1.83      jlam       49: LIBNBCOMPAT_FILESDIR=  ${.CURDIR}/../../pkgtools/libnbcompat/files
                     50: LIBNBCOMPAT_SRCDIR=    ${WRKDIR}/libnbcompat
                     51:
                     52: CFLAGS+=               -I${LIBNBCOMPAT_SRCDIR}
                     53: LDFLAGS+=              -L${LIBNBCOMPAT_SRCDIR}
                     54: LIBS+=                 -lnbcompat
1.1       agc        55:
1.95      grant      56: MAKE_ENV+=             MACHINE_ARCH="${MACHINE_ARCH}"
                     57: MAKE_ENV+=             OPSYS="${OPSYS}"
1.91      grant      58:
1.92      jlam       59: PKG_DBDIR?=            /var/db/pkg
                     60: PKG_INFO=              PKG_DBDIR=${PKG_DBDIR} ${PKG_INFO_CMD}
1.94      jlam       61: PKG_ADMIN=             PKG_DBDIR=${PKG_DBDIR} ${PKG_ADMIN_CMD}
1.92      jlam       62:
                     63: .include "../../mk/bsd.prefs.mk"
                     64:
1.58      schmonz    65: VERSION!=              ${AWK} -F '"' '/PKGTOOLS_VERSION/ {print $$2}' \
                     66:                        ${FILESDIR}/lib/version.h
1.78      jlam       67:
1.58      schmonz    68: do-extract:
1.83      jlam       69:        @${CP} -Rp ${LIBNBCOMPAT_FILESDIR} ${LIBNBCOMPAT_SRCDIR}
1.58      schmonz    70:        @${CP} -Rp ${FILESDIR} ${WRKSRC}
1.12      hubertf    71:
1.83      jlam       72: pre-configure:
1.85      grant      73:        cd ${LIBNBCOMPAT_SRCDIR} && ${SETENV} CC="${CC}" ./configure && \
                     74:                ${MAKE_PROGRAM}
1.83      jlam       75:
1.12      hubertf    76: post-install:
1.75      jlam       77:        if [ ! -f ${PKG_DBDIR}/pkgdb.byfile.db ]; then                  \
                     78:                if [ ! -d ${PKG_DBDIR} ]; then                          \
                     79:                        ${INSTALL_DATA_DIR} ${PKG_DBDIR};               \
                     80:                fi;                                                     \
1.77      jlam       81:                ${PKG_ADMIN} rebuild;                                   \
1.15      hubertf    82:        fi
1.1       agc        83:
                     84: .include "../../mk/bsd.pkg.mk"
1.65      schmonz    85:
1.69      wiz        86: PREFIX:=               ${PKG_TOOLS_BIN:C|/[^/]?bin$||}
1.68      schmonz    87: .if ${PREFIX} == "/usr"
1.67      schmonz    88: CONFIGURE_ARGS+=       --mandir=${PREFIX}/share/man
1.89      grant      89: MANDIR=                        share/
1.67      schmonz    90: .else
                     91: CONFIGURE_ARGS+=       --mandir=${PREFIX}/man
1.89      grant      92: MANDIR=                        # empty
1.68      schmonz    93: .endif

CVSweb <webmaster@jp.NetBSD.org>