[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / pkgtools / pkg_install

Annotation of pkgsrc/pkgtools/pkg_install/Makefile, Revision 1.63

1.63    ! salo        1: # $NetBSD: Makefile,v 1.62 2002/12/22 08:58:05 salo Exp $
1.4       hubertf     2:
1.58      schmonz     3: # Notes to package maintainers:
1.57      hubertf     4: #
1.58      schmonz     5: # To update this package, import from src/usr.sbin/pkg_install.
1.57      hubertf     6: #
1.58      schmonz     7: # Updating this package does not automatically necessitate bumping
                      8: # PKGTOOLS_REQD in bsd.pkg.mk. Do so if and only if there is a critical
                      9: # change in the pkg_* tools that pkgsrc relies on for proper operation.
1.57      hubertf    10:
1.58      schmonz    11: DISTNAME=              pkg_install-${VERSION}
1.1       agc        12: CATEGORIES=            pkgtools
1.58      schmonz    13: MASTER_SITES=          # empty
                     14: DISTFILES=             # empty
1.1       agc        15:
                     16: MAINTAINER=            packages@netbsd.org
                     17: HOMEPAGE=              http://www.netbsd.org/
1.36      wiz        18: COMMENT=               NetBSD-current's pkg_* tools
1.60      schmonz    19:
                     20: USE_BUILDLINK2=                no
1.58      schmonz    21:
                     22: GNU_CONFIGURE=         # defined
                     23: CONFIGURE_ARGS+=       --with-pkgdbdir=${PKG_DBDIR}
                     24:
                     25: NO_CHECKSUM=           # defined
                     26: NO_PATCH=              # defined
                     27: NO_MTREE=              # defined
                     28: NO_PKG_REGISTER=       # defined
                     29: NO_PACKAGE=            Deinstallation is not permitted
1.1       agc        30:
                     31: .include "../../mk/bsd.prefs.mk"
                     32:
1.58      schmonz    33: VERSION!=              ${AWK} -F '"' '/PKGTOOLS_VERSION/ {print $$2}' \
                     34:                        ${FILESDIR}/lib/version.h
1.46      seb        35:
1.58      schmonz    36: LOCALBASE:=            ${PKG_TOOLS_BIN:C|/[^/]?bin$||}
1.38      hubertf    37: PKG_DBDIR?=            /var/db/pkg
1.42      hubertf    38:
1.43      hubertf    39: .if ${OPSYS} == "NetBSD" && !exists(/usr/share/tmac/tmac.andoc)
1.56      schmonz    40: PKG_FAIL_REASON+= "You need to have the 'text' set installed to build this package!"
1.46      seb        41: .endif
                     42:
1.58      schmonz    43: do-extract:
                     44:        @${CP} -Rp ${FILESDIR} ${WRKSRC}
1.12      hubertf    45:
                     46: post-install:
1.38      hubertf    47:        if [ ! -f ${PKG_DBDIR}/pkgdb.byfile.db ]; then \
                     48:                if [ ! -d ${PKG_DBDIR} ]; then \
                     49:                        ${INSTALL_DATA_DIR} ${PKG_DBDIR}; \
1.14      garbled    50:                fi; \
1.38      hubertf    51:                ${PKG_ADMIN} rebuild ; \
1.15      hubertf    52:        fi
1.1       agc        53:
                     54: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>