[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / pkgtools / bootstrap-mk-files

File: [cvs.NetBSD.org] / pkgsrc / pkgtools / bootstrap-mk-files / Makefile (download)

Revision 1.39, Tue Dec 31 19:10:20 2013 UTC (10 years, 3 months ago) by dholland
Branch: MAIN
Changes since 1.38: +2 -2 lines

Add support for PROGS (not just PROG) more or less like in the current
NetBSD make library. Bump version (to 20131207, which was when I wrote
this.) Fixes the build of multimedia/bsdav.

Note: this is not a merge from NetBSD HEAD, but a minimal
reimplementation of the feature to get the job done.

These make templates really need to be merged with or replaced by the
latest versions from NetBSD HEAD. Anyone embarking on such a merge
should probably revert this change (which is only to bsd.prog.mk)
before doing so.

No objection after 3+ weeks on tech-pkg.

# $NetBSD: Makefile,v 1.39 2013/12/31 19:10:20 dholland Exp $

DISTNAME=	bootstrap-mk-files-20131207
CATEGORIES=	pkgtools
MASTER_SITES=	# empty
DISTFILES=	# empty

CONFLICTS+=	mk-files-[0-9]*

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.pkgsrc.org/
COMMENT=	*.mk files for the bootstrap bmake utility

NO_PKGTOOLS_REQD_CHECK=	# defined
BOOTSTRAP_PKG=	yes

NO_BUILD=	yes

USE_TOOLS+=	sed

INSTALLATION_DIRS=	share/mk

do-extract:
	@${CP} -R ${FILESDIR} ${WRKSRC}

do-configure:
	cd ${WRKSRC}; for file in bsd.* sys.mk; do			\
		${TEST} ! -f mods/${OPSYS}.$$file ||			\
		${CP} -f mods/${OPSYS}.$$file ${WRKSRC}/$$file;		\
	done
	cd ${WRKSRC};							\
	if ${TEST} -f mods/${OPSYS}.bsd.own.mk.in; then			\
		own_mk=mods/${OPSYS}.bsd.own.mk.in;			\
	else								\
		own_mk=mods/bsd.own.mk.in;				\
	fi;								\
	${SED}	-e 's|@ROOT_GROUP@|'${REAL_ROOT_GROUP}'|g'			\
		-e 's|@ROOT_USER@|'${REAL_ROOT_USER}'|g'			\
		-e 's|@SYSCONFDIR@|'${PKG_SYSCONFDIR}'|g'		\
		$$own_mk > bsd.own.mk

do-install:
	cd ${WRKSRC} && for file in bsd.* sys.mk; do			\
		${INSTALL_DATA} $$file ${DESTDIR}${PREFIX}/share/mk/$$file;	\
	done

.include "../../mk/bsd.pkg.mk"