[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / parallel / sge

Annotation of pkgsrc/parallel/sge/Makefile, Revision 1.11

1.11    ! jlam        1: # $NetBSD: Makefile,v 1.10 2005/06/17 03:50:29 jlam Exp $
1.1       dmcmahil    2: #
                      3:
                      4: DISTNAME=              sge-5.3p6
1.5       reed        5: PKGREVISION=   2
1.1       dmcmahil    6: CATEGORIES=            parallel sysutils
                      7: MASTER_SITES=          ${MASTER_SITE_LOCAL}
                      8:
                      9: MAINTAINER=            tech-pkg@NetBSD.org
                     10: HOMEPAGE=              http://gridengine.sunsource.net/
                     11: COMMENT=               Sun Grid Engine distributed resource management system
                     12:
                     13: BUILD_DEPENDS+=                {standalone-tcsh,tcsh}-[0-9]*:../../shells/tcsh
                     14:
                     15: GNU_CONFIGURE=         YES
1.11    ! jlam       16: USE_TOOLS+=            gmake perl:run
1.1       dmcmahil   17:
                     18: CFLAGS+=               -D${UPPER_OPSYS}
                     19: CONFIGURE_ENV+=                REMOTE=sge
                     20: CONFIGURE_ENV+=                CFLAGS="${CFLAGS}"
                     21: CONFIGURE_ARGS+=       --with-grd=${SGE_BUILDARCH}
                     22: PLIST_SUBST+=          SGE_ARCH=${SGE_ARCH}
                     23: MESSAGE_SUBST+=                SGE_ROOT=${SGE_ROOT}
                     24: MAKE_ENV+=             PERL5=${PERL5}
                     25:
                     26: USE_PKGINSTALL=                YES
                     27: SGE_USER?=             sgeadmin
                     28: SGE_GROUP?=            sgeadmin
                     29: PKG_GROUPS=            ${SGE_GROUP}
                     30: PKG_USERS=             ${SGE_USER}:${SGE_GROUP}::Sun\\ Grid\\ Engine\\ Administrator
                     31:
                     32: EVAL_PREFIX+=  PKGSRC_SSL_PREFIX=openssl
                     33:
                     34: AIMK=  ${SETENV} ${MAKE_ENV} tcsh -fb ${WRKSRC}/source/aimk
                     35:
1.3       kristerw   36: CONFIG_GUESS_OVERRIDE= source/3rdparty/qmake/config.guess \
                     37:                source/3rdparty/qtcsh/config.guess
                     38: CONFIG_SUB_OVERRIDE=   source/3rdparty/qmake/config.sub \
                     39:                source/3rdparty/qtcsh/config.sub
                     40:
1.1       dmcmahil   41: .include "../../mk/bsd.prefs.mk"
                     42:
                     43: # SGE_ARCH should match the putput of ${WRKSRC}/source/dist/util/arch
                     44: # SGE_BUILDARCH should match whats in ${WRKSRC}/source/aimk
1.7       jlam       45: UPPER_OPSYS_cmd=       ${ECHO} "${OPSYS}" | ${TR} a-z A-Z
                     46: UPPER_OPSYS=           ${UPPER_OPSYS_cmd:sh}
1.1       dmcmahil   47:
                     48: .if ${OPSYS} == "NetBSD"
                     49: SGE_ARCH=              nbsd-${MACHINE_ARCH}
1.7       jlam       50: SGE_BUILDARCH_cmd=     ${ECHO} "${OPSYS}_${MACHINE_ARCH}" | ${TR} a-z A-Z
1.1       dmcmahil   51: .elif ${OPSYS} == "FreeBSD"
                     52: SGE_ARCH=              fbsd-${MACHINE_ARCH}
1.7       jlam       53: SGE_BUILDARCH_cmd=     ${ECHO} "${OPSYS}_${MACHINE_ARCH}" | ${TR} a-z A-Z
1.1       dmcmahil   54: .elif ${OPSYS} == "SunOS"
                     55: .  if ${MACHINE_ARCH} == "i386"
                     56: SGE_ARCH=              solaris86
                     57: .  else
1.2       grant      58: _ISAINFO!=             isainfo
                     59: .    if !empty(_ISAINFO:Msparcv9)
                     60: SGE_ARCH=              solaris64
                     61: .    else
1.1       dmcmahil   62: SGE_ARCH=              solaris
1.2       grant      63: .    endif
1.1       dmcmahil   64: .  endif
1.7       jlam       65: SGE_BUILDARCH_cmd=     ${ECHO} "${SGE_ARCH}" | ${TR} a-z A-Z
1.1       dmcmahil   66: .elif ${OPSYS} == "Darwin"
                     67: SGE_ARCH=              darwin
                     68: SGE_BUILDARCH=         DARWIN
                     69: .else
                     70: PKG_FAIL_REASON=       "SGE_ARCH and SGE_BUILDARCH need to be confgured for your OS"
                     71: .endif
1.7       jlam       72: SGE_BUILDARCH?=                ${SGE_BUILDARCH_cmd:sh}
1.1       dmcmahil   73:
                     74: LDFLAGS+=      -R${SGE_ROOT}/lib/${SGE_ARCH}
                     75: BUILDLINK_PASSTHRU_RPATHDIRS+= ${SGE_ROOT}/lib/${SGE_ARCH}
                     76:
                     77: SGE_ROOT=      ${PREFIX}/sge
                     78:
1.10      jlam       79: INSTALLATION_DIRS=     bin
                     80:
1.1       dmcmahil   81: post-patch:
                     82:        @if [ "`${WRKSRC}/source/dist/util/arch`" != "${SGE_ARCH}" ]; then \
                     83:                ${ECHO} "ERROR:  SGE_ARCH as set in the pkgsrc Makefile," ;\
                     84:                ${ECHO} "        ${SGE_ARCH}, does not agree with that returned by" ; \
                     85:                ${ECHO} "        ${WRKSRC}/source/dist/util/arch," ; \
                     86:                ${ECHO} "        `${WRKSRC}/source/dist/util/arch`" ; \
                     87:                ${FALSE} ; \
                     88:        fi
                     89:
                     90: pre-configure:
                     91: .for __tmp__ in source/dist/util/arch_variables source/scripts/distinst.site source/aimk.site
                     92:        ${MV} ${WRKSRC}/${__tmp__} ${WRKSRC}/${__tmp__}.bak
                     93:        ${SED} -e 's;@rcd_dir@;${RCD_SCRIPTS_DIR};g' -e 's;@ssl_prefix@;${SSL_PREFIX};g' \
                     94:                -e 's;@perl5@;${PERL5};g' ${WRKSRC}/${__tmp__}.bak > \
                     95:                ${WRKSRC}/${__tmp__}
                     96:        ${RM} ${WRKSRC}/${__tmp__}.bak
                     97: .endfor
                     98:
                     99: do-configure:
                    100: .for __prog__ in qmake qtcsh
                    101:        ${MKDIR} ${WRKSRC}/source/3rdparty/${__prog__}/${SGE_BUILDARCH}
                    102:        cd ${WRKSRC}/source/3rdparty/${__prog__}/${SGE_BUILDARCH} && \
                    103:                ${SETENV} ${CONFIGURE_ENV} \
                    104:                SGE_ARCH=`${WRKSRC}/source/dist/util/arch` \
                    105:                ../configure ${CONFIGURE_ARGS} --srcdir=..
                    106: .endfor
                    107:
                    108: do-build:
                    109:        cd ${WRKSRC}/source && ${AIMK} -only-depend
                    110:        cd ${WRKSRC}/source && ${SETENV} ${MAKE_ENV} ./scripts/zerodepend
                    111:        cd ${WRKSRC}/source && ${AIMK} -no-qmake -no-qtcsh depend
                    112:        cd ${WRKSRC}/source && ${AIMK} -secure
                    113:        cd ${WRKSRC}/source && ${AIMK} -man
                    114:
                    115: do-install:
                    116:        ${LN} -fs ${WRKSRC}/source/scripts/distinst ${WRKSRC}/source/scripts/myinst
                    117:        ${MKDIR} ${SGE_ROOT}
                    118:        ${CHOWN} ${SGE_USER} ${SGE_ROOT}
                    119:        ${CHGRP} ${SGE_GROUP} ${SGE_ROOT}
                    120:        cd ${WRKSRC}/source && \
                    121:                ${ECHO} "Y" | ${SETENV} LOCALBASE=${LOCALBASE} SGE_ROOT=${SGE_ROOT} ./scripts/myinst -allall ${SGE_ARCH}
                    122:        cd ${SGE_ROOT} && ${SETENV} SGE_ROOT=${SGE_ROOT} ./util/setfileperm.sh -auto -noresport \
                    123:                ${SGE_USER} ${SGE_GROUP} ${SGE_ROOT}
                    124:        for f in ${SGE_ROOT}/bin/${SGE_ARCH}/q* ; do \
                    125:                cd ${PREFIX}/bin && ${LN} -fs $$f ; done
                    126:
                    127: .include "../../graphics/xpm/buildlink3.mk"
                    128: .include "../../security/openssl/buildlink3.mk"
                    129: .include "../../mk/motif.buildlink3.mk"
                    130: .include "../../mk/bsd.pkg.mk"
                    131: .if ${USE_BUILTIN.openssl} == "yes"
                    132: SSL_PREFIX=    /usr
                    133: .else
                    134: SSL_PREFIX=    ${PKGSRC_SSL_PREFIX}
                    135: .endif

CVSweb <webmaster@jp.NetBSD.org>