[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / parallel / openpbs

File: [cvs.NetBSD.org] / pkgsrc / parallel / openpbs / Attic / Makefile (download)

Revision 1.10, Sat Mar 4 21:30:27 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.9: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.10 2006/03/04 21:30:27 jlam Exp $
#

DISTNAME=		OpenPBS_2_3_16
PKGNAME=		openpbs-2.3.16
PKGREVISION=		1
CATEGORIES=		parallel sysutils
MASTER_SITES=		http://www.openpbs.org/UserArea/Download/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.openpbs.org/
COMMENT=		Generic network queueing system

INTERACTIVE_STAGE=	fetch

HAS_CONFIGURE=		yes
CONFIGURE_ARGS+=	--prefix=${PREFIX:Q}

REPLACE_INTERPRETER+=	tcl
_REPLACE.tcl.old=	.*/bin/pbs_tclsh
_REPLACE.tcl.new=	${PREFIX}/bin/tclsh
_REPLACE_FILES.tcl+=	src/gui/buildindex.src
_REPLACE_FILES.tcl+=	src/tools/xpbsmon/buildindex.src

REPLACE_INTERPRETER+=	tk
_REPLACE.tk.old=	.*/bin/wish
_REPLACE.tk.new=	${PREFIX}/bin/wish
_REPLACE_FILES.tk+=	src/gui/xpbs.src

REPLACE_INTERPRETER+=	tk2
_REPLACE.tk2.old=	.*/bin/pbs_wish
_REPLACE.tk2.new=	${PREFIX}/bin/pbs_wish
_REPLACE_FILES.tk2+=	src/tools/xpbsmon/xpbsmon.src

_CONFIGURE_POSTREQ+=     replace-interpreter

.include "../../x11/tk83/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"