[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / parallel / dqs

File: [cvs.NetBSD.org] / pkgsrc / parallel / dqs / Makefile (download)

Revision 1.7, Sat Mar 4 21:30:26 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.6: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.7 2006/03/04 21:30:26 jlam Exp $
#

DISTNAME=	DQS-3.3.2
PKGNAME=	dqs-3.3.2
PKGREVISION=	2
CATEGORIES=	parallel
MASTER_SITES=	http://www.go.dlr.de/fresh/unix/src/misc/
EXTRACT_SUFX=	.tgz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.scri.fsu.edu/~pasko/dqs.html
COMMENT=	Distributed queueing system

WRKSRC=		${WRKDIR}/DQS3
DOCDIR=		${PREFIX}/share/doc/dqs
DOCS=		Image16.gif Image17.gif Image18.gif Image19.gif Image20.gif \
		Image21.gif Image22.gif Image23.gif InstMaint.html \
		Refernce.html UserGuide.html error_msg.htm

EGDIR=		${PREFIX}/share/examples/dqs

# PKG_SYSCONFSUBDIR?=dqs
# CONF_FILES+=	${EGDIR}/conf_file ${PKG_SYSCONFDIR}/conf_file
# CONF_FILES+=	${EGDIR}/key_file ${PKG_SYSCONFDIR}/key_file
# CONF_FILES+=	${EGDIR}/resolve_file ${PKG_SYSCONFDIR}/resolve_file

post-patch:
	${ECHO} '#undef DEFAULT_HOST' >> ${WRKSRC}/SRC/dqs.h

post-install:
	${INSTALL_DATA_DIR} ${DOCDIR}
.for doc in ${DOCS}
	${INSTALL_DATA} ${WRKSRC}/DOC/user_guide/${doc} ${DOCDIR}
.endfor

.include "../../mk/bsd.pkg.mk"