Up to [cvs.NetBSD.org] / pkgsrc / parallel / R-promises
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.4 / (download) - annotate - [select for diffs], Tue Oct 26 11:10:35 2021 UTC (16 months, 3 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4,
HEAD
Changes since 1.3: +2 -2
lines
Diff to previous 1.3 (colored)
parallel: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes
Revision 1.3 / (download) - annotate - [select for diffs], Thu Oct 7 14:46:45 2021 UTC (17 months, 1 week ago) by nia
Branch: MAIN
Changes since 1.2: +1 -2
lines
Diff to previous 1.2 (colored)
parallel: Remove SHA1 hashes for distfiles
Revision 1.2 / (download) - annotate - [select for diffs], Sat Jun 5 08:43:54 2021 UTC (21 months, 2 weeks ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2
Changes since 1.1: +5 -5
lines
Diff to previous 1.1 (colored)
(parallel/promises) Updated 1.0.1 to 1.2.0.1 promises 1.2.0.1 ============== * Added `future_promise()` which returns a `promise` that executes the expression using `future::future()`. `future_promise()` should (typically) be a drop-in replacement for any `future::future()` function call. `future_promise()` will not execute `future` work faster than `future::future()`, but `future_promise()` will only submit `future` jobs if a worker is available. If no workers are available, `future_promise()` will hold the expression information in a `promise` until a worker does become available to better take advantage of computing resources available to the main R session. For more information, please see the [`future_promise()` article](https://rstudio.github.io/promises/articles/future_promise.html). (#62) * Added visibility support for `Promise$then(onFulfilled)`. (#59) promises 1.1.1 ============== * Fix handling of FutureErrors during `future::resolved()` and `future::value()` by discarding the corrupt future. (#37) promises 1.1.0 ============== * Fixed #49: `promise_all()` previously did not handle `NULL` values correctly. (#50)) * `new_promise_domain` now takes a `wrapOnFinally` argument, which can be used to intercept registration of `finally()`. Previous versions treated `finally` as passing the same callback to `then(onFulfilled=..., onRejected=...)`, and ignoring the result; for backward compatibility, promise domains will still treat `finally` that way by default (i.e. if `wrapOnFinally` is `NULL`, then `finally` will result in `wrapOnFulfilled` and `wrapOnRejected` being called, but if `wrapOnFinally` is provided then only `wrapOnFinally` will be called). (#43)
Revision 1.1 / (download) - annotate - [select for diffs], Fri Aug 9 20:25:29 2019 UTC (3 years, 7 months ago) by brook
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3
R-promises: initial commit Provides fundamental abstractions for doing asynchronous programming in R using promises. Asynchronous programming is useful for allowing a single R process to orchestrate multiple tasks in the background while also attending to something else. Semantics are similar to 'JavaScript' promises, but with a syntax that is idiomatic R.