[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / news / nntpclnt

File: [cvs.NetBSD.org] / pkgsrc / news / nntpclnt / Makefile (download)

Revision 1.21, Wed Apr 7 13:56:43 2004 UTC (20 years ago) by cube
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.20: +9 -4 lines

Use more safely the various buffers in postauth.c so that at least it
doesn't crash on common configuration.  Fixes PR 24982 by Gary Duzan.

Also, silently try to delete the configuration directory not to wipe the
user's configuration when updating the package.

Finally, mark this package as NetBSD and SunOS only, since it will fail
on other platforms by lack of default configuration.

Bump PKGREVISION.

# $NetBSD: Makefile,v 1.21 2004/04/07 13:56:43 cube Exp $

DISTNAME=	nntpclnt-1.6.1
PKGREVISION=	4
CATEGORIES=	news
MASTER_SITES=	ftp://ftp.uu.net/networking/news/nntp/

MAINTAINER=	tech-pkg@NetBSD.org
COMMENT=	NNTP client library and inews client posting program

CONFLICTS+=	inn-[0-9]*

LICENSE=	nntpclnt-license
RESTRICTED=	"Do not sell, rent, trade, market, or use for monetary profit"
NO_SRC_ON_CDROM=${RESTRICTED}
NO_BIN_ON_CDROM=${RESTRICTED}

ALL_TARGET=	inews
PKG_GROUPS=	news
USE_PKGINSTALL=	yes
PKG_SYSCONFSUBDIR=	nntp

PLIST_SUBST+=	PKG_SYSCONFDIR=${PKG_SYSCONFDIR}

.include "../../mk/bsd.prefs.mk"

CONFIG_SH=	${FILESDIR}/config.${OPSYS}.sh
ONLY_FOR_PLATFORM=	NetBSD-*-* SunOS-*-*

do-configure:
	${SED} -e s,@PREFIX@,${PREFIX}, -e s,@PKGSYSCONFDIR@,${PKG_SYSCONFDIR}, \
		${CONFIG_SH} >${WRKSRC}/config.sh
	@cd ${WRKSRC} && ${SH} Makefile.SH && ${SH} config.h.SH

post-build:
	cd ${WRKSRC} && \
		${AR} clq libnntpclnt.a nntpclnt.o && ${RANLIB} libnntpclnt.a

do-install:
	${INSTALL_PROGRAM} -g ${PKG_GROUPS} -m 2555 ${WRKSRC}/inews \
	  ${PREFIX}/bin
	${INSTALL_DATA} ${WRKSRC}/nntp.h ${PREFIX}/include/
	${INSTALL_DATA} ${WRKSRC}/libnntpclnt.a ${PREFIX}/lib/
	${INSTALL_DATA} ${WRKSRC}/nntpclnt.3 ${PREFIX}/man/man3/
	${INSTALL_DATA_DIR} ${PKG_SYSCONFDIR}

.include "../../mk/bsd.pkg.mk"