[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / yaydl

File: [cvs.NetBSD.org] / pkgsrc / net / yaydl / Makefile (download)

Revision 1.1, Sat Jan 9 21:33:04 2021 UTC (3 years, 3 months ago) by pin
Branch: MAIN

net/yaydl: import package

yaydl-yet another youtube (and more) downloader
Features:
-Can download videos.
-Can optionally keep only the audio part of them.
-Could convert the resulting file to something else (requires `ffmpeg`).
-Comes as a single binary (once compiled) - take it everywhere on your
thumbdrive, no Python cruft required.

# $NetBSD: Makefile,v 1.1 2021/01/09 21:33:04 pin Exp $

DISTNAME=	yaydl-0.3.0
CATEGORIES=	net
MASTER_SITES=	${MASTER_SITE_GITHUB:=dertuxmalwieder/}
GITHUB_TAG=	release-${PKGVERSION_NOREV}

MAINTAINER=	pin@NetBSD.org
HOMEPAGE=	https://code.rosaelefanten.org/yaydl/index
COMMENT=	Yet another youtube down loader
LICENSE=	cddl-1.0

.include "cargo-depends.mk"

USE_LANGUAGES+=			c	# rust, but needs a toolchain to link
USE_TOOLS+=			pkg-config

INSTALLATION_DIRS=	bin

MAKE_ENV+=	OPENSSL_DIR=${BUILDLINK_PREFIX.openssl:Q}
RUSTFLAGS+=	-C link-arg=${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.openssl}/lib
MAKE_ENV+=	RUSTFLAGS=${RUSTFLAGS:Q}

CARGO_NO_DEFAULT_FEATURES=	YES

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/target/release/yaydl ${DESTDIR}${PREFIX}/bin

.include "../../lang/rust/cargo.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"