[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / xymonclient

File: [cvs.NetBSD.org] / pkgsrc / net / xymonclient / Makefile (download)

Revision 1.15, Thu Oct 11 18:42:19 2012 UTC (11 years, 6 months ago) by spz
Branch: MAIN
Changes since 1.14: +3 -4 lines

- fix FreeBSD/Dragonfly properly
- update to newest version

Upstream changelog:

Xymon release 4.3.10 - released on Aug 6 2012
=============================================

Main features in this release is the addition of inode-checks
on all major platforms, and a series of enhancements to the
build procedure.

Also, building Xymon on most common platforms is now explicitly
described in the "install" document.

* Fix build problems with "errno"
* Fix build problems with OpenSSL in non-default locations
* Fix build problems with certain LDAP configurations
* Fix build problems with RRDtool on FreeBSD / OpenBSD
* Fix problem with ifstat data from Fedora in graphs
* "inode" check on FreeBSD, OpenBSD, OSX, Solaris, HP/UX, AIX
  in addition to existing support for Linux
* Document building and installing Xymon on common platforms
  (Linux, FreeBSD, OpenBSD, Solaris)
* Enhance xymoncfg so it can be used to import Xymon configuration
  settings into shell-scripts.


Xymon release 4.3.9 - released on Jul 24 2012
=============================================

This release is mainly a bug-fix release.

* Fix crash when XYMSRV is undefined but XYMSERVERS is
* Fix error in calculating combo-status messages with
  forward references
* Fix error in disable-until-TIME or disable-until-OK code
* Fix documentation of DURATION in alerts.cfg / xymond_alert so
  it is consistenly listed as being in "minutes".
* Permit explicit use of ">" and ">=" in alerts.cfg
* Permit building without the RRDtool libraries, e.g. for
  a network-tester build, but with trend-graphing disabled.
* Full compiler-warning cleanup
* Various configuration/build-script issues fixed.


Xymon release 4.3.8 - released on Jul 15 2012
=============================================

This release is mainly a bug-fix release.

Bugfixes
* Workaround for DNS timeout handling, now fixed at approximately 25
  seconds.
* "hostinfo" command for xymond documented
* confreport only shows processes that are monitored
* analysis.cfg parsing of COLOR for UP rules was broken
* RRD handlers no longer crash after receiving 1 billion updates
* Using .netrc for authentication could crash xymonnet
* "directory" includes would report the wrong filename for missing
  directories.
* useradm CGI would invoke htpassword twice
* "include" and "directory" now ignores trailing whitespace
* SSLv2 support disabled if SSL-library does not support it
* Minor bugfixes and cleanups of compiler warnings.

Enhancements
* Service status on info page now links to the detailed status page.
* Add RRDGRAPHOPTS setting to permit global user-specified RRD options,
  e.g. for font to showgraph CGI
* Add check for the size of public keys used in SSL certificates
  (enabled via --sslkeysize=N option for xymonnet)
* Optionally disable the display of SSL ciphers in the sslcert status
  (the --no-cipherlist option for xymonnet)
* Improved build-scripts works on newer systems with libraries in
  new and surprising places
* Reduce xymonnet memory usage and runtime for ping tests when there
  are multiple hosts.cfg entries with the same IP-address.
* Add code for inode-monitoring on Linux. Does not currently work on
  any other client platform.
* Added the ability to disable tests until a specific time, instead of
  for some interval. Disabling a test also now computes the expire time
  for the disable to happen at the next closest minute.

# $NetBSD: Makefile,v 1.15 2012/10/11 18:42:19 spz Exp $
#

DISTNAME=		xymon-4.3.10
PKGNAME=		xymonclient-4.3.10
CATEGORIES=		net
MASTER_SITES=		${MASTER_SITE_SOURCEFORGE:=xymon/}

MAINTAINER=		spz@NetBSD.org
HOMEPAGE=		http://xymon.sourceforge.net/
COMMENT=		Network services monitor a la Big Brother

LICENSE=		gnu-gpl-v2

PKG_DESTDIR_SUPPORT=	user-destdir
MAKE_JOBS_SAFE=		NO

CONFLICTS+=		hobbitmon-[0-9]*
CONFLICTS+=		hobbitclient-[0-9]*

HAS_CONFIGURE=		YES
USE_TOOLS+=		gmake

.include "../../mk/bsd.prefs.mk"

# xymons user/group

XYMONUSER?=		xymon
XYMONGROUP?=		xymon

PKG_GROUPS=		${XYMONGROUP}
PKG_USERS=		${XYMONUSER:Q}:${XYMONGROUP:Q}

PKG_GECOS.${XYMONUSER}=	Xymon monitor
PKG_HOME.${XYMONUSER}=	${XYMONHOME}

PKG_GROUPS_VARS+=	XYMONGROUP
PKG_USERS_VARS+=	XYMONUSER

# startup and config

RCD_SCRIPTS+=		xymonclient
PKG_SYSCONFDIR.xymon=	${PREFIX}/etc/xymon
EXAMPLEDIR=		${PREFIX}/share/examples/xymon

XYMONHOME?=		${PREFIX}/share/xymon/xymonhome
XYMONTOPDIR?=		${PREFIX}/libexec/xymon

XYMONSERVERNAME?=	"`uname -n`"
XYMONSERVERIP?=		127.0.0.1

XYMONLOGDIR?=		${VARBASE}/log/xymon
XYMONVAR?=		${VARBASE}/xymon

XYBINDIR?=		${XYMONTOPDIR}
XYETCDIR?=		${PKG_SYSCONFDIR.xymon}
XYEXTDIR?=		${XYMONTOPDIR}/ext
XYTMPDIR?=		${VARBASE}/xymon/tmp

BUILD_DEFS+=		VARBASE
BUILD_DEFS+=		XYMONSERVERNAME
BUILD_DEFS+=		XYMONSERVERIP

FILES_SUBST+=		XYMONHOME=${XYMONHOME:Q}
FILES_SUBST+=		XYMONLOGDIR=${XYMONLOGDIR}
FILES_SUBST+=		XYMONVAR=${XYMONVAR:Q}
FILES_SUBST+=		XYBINDIR=${XYBINDIR}
FILES_SUBST+=		XYETCDIR=${XYETCDIR}
FILES_SUBST+=		XYEXTDIR=${XYEXTDIR}
FILES_SUBST+=		XYTMPDIR=${XYTMPDIR}

CONFIGURE_ARGS+=	"--client"

CONFIGURE_ENV+=		CONFTYPE="server"
CONFIGURE_ENV+=		PKGBUILD=y
CONFIGURE_ENV+=		XYMONHOSTNAME=${XYMONSERVERNAME:Q}
CONFIGURE_ENV+=		XYMONHOSTIP=${XYMONSERVERIP:Q}
CONFIGURE_ENV+=		XYMONUSER=${XYMONUSER:Q}
CONFIGURE_ENV+=		XYMONHOME=${XYMONHOME:Q}
CONFIGURE_ENV+=		XYMONTOPDIR=${XYMONTOPDIR}
CONFIGURE_ENV+=		XYMONLOGDIR=${XYMONLOGDIR}
CONFIGURE_ENV+=		XYMONVAR=${XYMONVAR:Q}
CONFIGURE_ENV+=		INSTALLROOT=${DESTDIR}
CONFIGURE_ENV+=		INSTALLBINDIR=${XYBINDIR}
CONFIGURE_ENV+=		INSTALLETCDIR=${XYETCDIR}
CONFIGURE_ENV+=		INSTALLEXADIR=${EXAMPLEDIR}
CONFIGURE_ENV+=		INSTALLEXTDIR=${XYEXTDIR}
CONFIGURE_ENV+=		INSTALLTMPDIR=${XYTMPDIR}
CONFIGURE_ENV+=		MANROOT=${PREFIX}/${PKGMANDIR}/

USE_TOOLS+=	awk:run		cat:run		cp:run
USE_TOOLS+=	cut:run		date:run	egrep:run
USE_TOOLS+=	expr:run	find:run	grep:run
USE_TOOLS+=	head:run	id:run		ls:run
USE_TOOLS+=	mv:run		rm:run		sed
USE_TOOLS+=	sort:run	tail:run	touch:run
USE_TOOLS+=	tr:run		wc:run


OWN_DIRS+=		${XYMONTOPDIR}
MAKE_DIRS+=		${XYMONTOPDIR}/client
OWN_DIRS+=		${EXAMPLEDIR}
OWN_DIRS+=		${PKG_SYSCONFDIR.xymon}
OWN_DIRS+=		${XYMONHOME}
MAKE_DIRS+=		${XYMONHOME}/client

OWN_DIRS_PERMS+=	${XYEXTDIR}/client ${XYMONUSER} ${XYMONGROUP} 0755
OWN_DIRS_PERMS+=	${XYMONLOGDIR} ${XYMONUSER} ${XYMONGROUP} 0755
OWN_DIRS_PERMS+=	${XYTMPDIR} ${XYMONUSER} ${XYMONGROUP} 0755
OWN_DIRS_PERMS+=	${XYTMPDIR}/client ${XYMONUSER} ${XYMONGROUP} 0755

OWN_DIRS_PERMS+=	${XYMONVAR} ${XYMONUSER} ${XYMONGROUP} 0755
OWN_DIRS_PERMS+=	${XYMONVAR}/data ${XYMONUSER} ${XYMONGROUP} 0755

CFILES+=		clientlaunch.cfg localclient.cfg xymonclient.cfg
.for file in ${CFILES}
CONF_FILES_PERMS+=	${EXAMPLEDIR}/${file} ${PKG_SYSCONFDIR.xymon}/${file} ${XYMONUSER} ${XYMONGROUP} 0644
.endfor

MAKE_ENV+=		MAKE=${MAKE_PROGRAM:Q}
MAKE_ENV+=		PKGDIR=${PREFIX}
MAKE_ENV+=		INSTALLROOT=${DESTDIR}
MAKE_ENV+=		PKGBUILD=y
MAKE_ENV+=		${TOOLS_ENV}

PLIST_VARS+=		meminfo
.if ${OPSYS} == "NetBSD" || ${OPSYS} == "OpenBSD" || ${OPSYS} == "FreeBSD"
PLIST.meminfo=		yes
.endif

post-patch:
	${CP} ${WRKSRC}/build/Makefile.FreeBSD \
	      ${WRKSRC}/build/Makefile.DragonFly
	# Add dragonfly-meminfo support later (placeholder)
	${SED} -e 's|freebsd-meminfo|dragonfly-meminfo|' \
	      ${WRKSRC}/client/xymonclient-freebsd.sh > \
	      ${WRKSRC}/client/xymonclient-dragonfly.sh

.include "../../mk/bsd.pkg.mk"