[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / xtraceroute

File: [cvs.NetBSD.org] / pkgsrc / net / xtraceroute / Makefile (download)

Revision 1.21, Tue Mar 27 03:20:13 2001 UTC (23 years ago) by hubertf
Branch: MAIN
Changes since 1.20: +3 -2 lines

Change BUILD_DEPENDS semantics:
first component is now a package name+version/pattern, no more
executable/patchname/whatnot.

While there, introduce BUILD_USES_MSGFMT as shorthand to pull in
devel/gettext unless /usr/bin/msgfmt exists (i.e. on post-1.5 -current).

Patch by Alistair Crooks <agc@netbsd.org>

# $NetBSD: Makefile,v 1.21 2001/03/27 03:20:13 hubertf Exp $
#

DISTNAME=	xtraceroute-0.8.14
CATEGORIES=	net x11
MASTER_SITES=	http://www.dtek.chalmers.se/~d3august/xt/dl/
DISTFILES=	${DISTNAME}${EXTRACT_SUFX} \
		ndg_files.tar.gz

MAINTAINER=	hubertf@netbsd.org
HOMEPAGE=	http://www.dtek.chalmers.se/~d3august/xt/index.html
COMMENT=	Graphical version of traceroute, which traces the route IP packets go

BUILD_USES_MSGFMT=	yes

DEPENDS+=	gtkglarea-1.2.1:../../x11/gtkglarea
DEPENDS+=	tiff-*:../../graphics/tiff

USE_X11=	yes
#USE_MESA=	yes
GNU_CONFIGURE=	yes
USE_LIBINTL=	yes

EVAL_PREFIX+=	GTKDIR=gtk+
CONFIGURE_ARGS+= --with-gtk-prefix="${GTKDIR}"
# XXX Actually, Mesa's in X11PREFIX too, but as our tiff is in LOCALBASE
# and xtraceroute doesn't have a switch to tell it so (yet?), we abuse
# the --with-GL-prefix switch for this.
CONFIGURE_ARGS+= --with-GL-prefix=${LOCALBASE}
CONFIGURE_ARGS+= --with-lib-MesaGL

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/xtraceroute
	${INSTALL_DATA} ${WRKDIR}/hosts.cache    ${PREFIX}/share/xtraceroute/hosts.cache
	${INSTALL_DATA} ${WRKDIR}/networks.cache ${PREFIX}/share/xtraceroute/networks.cache

.include "../../mk/bsd.pkg.mk"