[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / xtraceroute

File: [cvs.NetBSD.org] / pkgsrc / net / xtraceroute / Makefile (download)

Revision 1.12, Tue Jul 11 14:53:45 2000 UTC (23 years, 9 months ago) by agc
Branch: MAIN
Changes since 1.11: +2 -2 lines

Make the determination of the pre-req package's installed directory be
a bit more user-friendly.

Introduce a show-{gtk+,imlib,kdebase,qt1,qt2,xpm}-prefix target in
bsd.pkg.mk, and use "${MAKE} show-*-prefix" in package Makefiles.

# $NetBSD: Makefile,v 1.12 2000/07/11 14:53:45 agc Exp $
#

DISTNAME=	xtraceroute-0.8.14
CATEGORIES=	net x11
MASTER_SITES=	http://www.dtek.chalmers.se/~d3august/xt/dl/
DISTFILES=	${DISTNAME}${EXTRACT_SUFX} \
		ndg_files.tar.gz

MAINTAINER=	hubertf@netbsd.org
HOMEPAGE=	http://www.dtek.chalmers.se/~d3august/xt/index.html

DEPENDS+=	gtkglarea-1.2.1:../../x11/gtkglarea
DEPENDS+=	tiff-*:../../graphics/tiff

USE_X11=	yes
GNU_CONFIGURE=	yes
CONFIGURE_ARGS+= --with-gtk-prefix="`${MAKE} show-gtk+-prefix`"
# XXX Actually, Mesa's in X11PREFIX too, but as our tiff is in LOCALBASE
# and xtraceroute doesn't have a switch to tell it so (yet?), we abuse
# the --with-GL-prefix switch for this.
CONFIGURE_ARGS+= --with-GL-prefix=${LOCALBASE}
CONFIGURE_ARGS+= --with-lib-MesaGL

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/xtraceroute
	${INSTALL_DATA} ${WRKDIR}/hosts.cache    ${PREFIX}/share/xtraceroute/hosts.cache
	${INSTALL_DATA} ${WRKDIR}/networks.cache ${PREFIX}/share/xtraceroute/networks.cache

.include "../../mk/bsd.pkg.mk"