[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / wireshark

File: [cvs.NetBSD.org] / pkgsrc / net / wireshark / Makefile (download)

Revision 1.148, Sat Jun 11 14:40:17 2016 UTC (7 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.147: +2 -2 lines

Updated wireshark to 2.0.4.

                         Wireshark 2.0.4 Release Notes
What's New

  Bug Fixes

   The following vulnerabilities have been fixed:
     * [1]wnpa-sec-2016-29
       The SPOOLS dissector could go into an infinite loop. Discovered by
       the CESG.
     * [2]wnpa-sec-2016-30
       The IEEE 802.11 dissector could crash. ([3]Bug 11585)
     * [4]wnpa-sec-2016-31
       The IEEE 802.11 dissector could crash. Discovered by Mateusz
       Jurczyk. ([5]Bug 12175)
     * [6]wnpa-sec-2016-32
       The UMTS FP dissector could crash. ([7]Bug 12191)
     * [8]wnpa-sec-2016-33
       Some USB dissectors could crash. Discovered by Mateusz Jurczyk.
       ([9]Bug 12356)
     * [10]wnpa-sec-2016-34
       The Toshiba file parser could crash. Discovered by iDefense Labs.
       ([11]Bug 12394)
     * [12]wnpa-sec-2016-35
       The CoSine file parser could crash. Discovered by iDefense Labs.
       ([13]Bug 12395)
     * [14]wnpa-sec-2016-36
       The NetScreen file parser could crash. Discovered by iDefense Labs.
       ([15]Bug 12396)
     * [16]wnpa-sec-2016-37
       The Ethernet dissector could crash. ([17]Bug 12440)

   The following bugs have been fixed:
     * Saving pcap capture file with ERF encapsulation creates an invalid
       pcap file. ([18]Bug 3606)
     * Questionable calling of Ethernet dissector by encapsulating
       protocol dissectors. ([19]Bug 9933)
     * Wireshark 1.12.0 does not dissect HTTP correctly. ([20]Bug 10335)
     * Don't copy details of hidden columns. ([21]Bug 11788)
     * RTP audio player crashes. ([22]Bug 12166)
     * Crash when saving RTP audio Telephony->RTP->RTP
       Streams->Analyze->Save->Audio. ([23]Bug 12211)
     * Edit - preferences - add column field not showing dropdown for
       choices. ([24]Bug 12321)
     * Using _ws.expert in a filter can cause a crash. ([25]Bug 12335)
     * Crash in SCCP dissector UAT (Qt UI only). ([26]Bug 12364)
     * J1939 frame without data = malformed packet ? ([27]Bug 12366)
     * The stream number in tshark's "-z follow,tcp,<stream number>"
       option is 0-origin rather than 1-origin. ([28]Bug 12383)
     * IP Header Length display filter should show calculated value.
       ([29]Bug 12387)
     * Multiple file radio buttons should be check boxes. ([30]Bug 12388)
     * Wrong check for getaddrinfo and gethostbyname on Solaris 11.
       ([31]Bug 12391)
     * ICMPv6 dissector doesn't respect actual packet length. ([32]Bug
       12400)
     * Format DIS header timestamp mm:ss.nnnnnn. ([33]Bug 12402)
     * RTP Stream Analysis can no longer be sorted in 2.0.3. ([34]Bug
       12405)
     * RTP Stream Analysis fails to complete in 2.0.3 when packets are
       sliced. ([35]Bug 12406)
     * Network-Layer Name Resolution uses first 32-bits of IPv6 DNS
       address as IPv4 address in some circumstances. ([36]Bug 12412)
     * BACnet decoder incorrectly flags a valid APDU as a "Malformed
       Packet". ([37]Bug 12422)
     * Valid ISUP messages marked with warnings. ([38]Bug 12423)
     * Profile command line switch "-C" not working in Qt interface.
       ([39]Bug 12425)
     * MRCPv2: info column not showing info correctly. ([40]Bug 12426)
     * Diameter: Experimental result code 5142. ([41]Bug 12428)
     * Tshark crashes when analyzing RTP due to pointer being freed not
       allocated. ([42]Bug 12430)
     * NFS: missing information in getattr for supported exclusive create
       attributes. ([43]Bug 12435)
     * Ethernet type field with a value of 9100 is shown as "Unknown".
       ([44]Bug 12441)
     * Documentation does not include support for Windows Server 2012 R2.
       ([45]Bug 12455)
     * Column preferences ruined too easily. ([46]Bug 12465)
     * SMB Open andX extended response decoded incorrectly. ([47]Bug
       12472)
     * SMB NtCreate andX with extended response sometimes incorrect.
       ([48]Bug 12473)
     * Viewing NFSv3 Data, checking SRTs doesn't work. ([49]Bug 12478)
     * Make wireshark with Qt enabled buildable on ARM. ([50]Bug 12483)

  Updated Protocol Support

   AFS, ANSI IS-637 A, BACapp, BT BNEP, Cisco FabricPath MiM, CSN.1,
   DCERPC SPOOLS, DIS, Ethernet, GSM A RR, ICMPv6, IEEE 802.11, IPv4,
   ISUP, J1939, JXTA, LAPSat, LPADm, LTE-RRC, MRCPv2, NFS, OpenFlow,
   SGsAP, SMB, STT, TZSP, UMTS FP, and USB

  New and Updated Capture File Support

   Aethra, Catapult DCT2000, CoSine, DBS Etherwatch, ERF, iSeries, Ixia
   IxVeriWave, NetScreen, Toshiba, and VMS TCPIPtrace

# $NetBSD: Makefile,v 1.148 2016/06/11 14:40:17 wiz Exp $

DISTNAME=	wireshark-2.0.4
CATEGORIES=	net
MASTER_SITES=	https://www.wireshark.org/download/src/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.wireshark.org/
COMMENT=	Network protocol analyzer
LICENSE=	gnu-gpl-v2

CONFLICTS+=		ethereal-[0-9]*

USE_LANGUAGES=		c c++
USE_TOOLS+=		gmake perl pkg-config yacc lex

USE_LIBTOOL=		yes
SHLIBTOOL_OVERRIDE=	# empty
CHECK_PORTABILITY_SKIP+=packaging/macosx/*/*

GNU_CONFIGURE=		yes
CONFIGURE_ARGS+=	--enable-static=no
CONFIGURE_ARGS+=	--with-ssl=${SSLBASE:Q}
CONFIGURE_ARGS+=	--with-pcap=${BUILDLINK_PREFIX.libpcap}
CONFIGURE_ARGS+=	--with-zlib=${BUILDLINK_PREFIX.zlib}
CONFIGURE_ENV+=		ac_cv_path_YACCDUMMY=${TOOLS_PATH.yacc}
CONFIGURE_ENV+=		ac_cv_path_LEXDUMMY=${TOOLS_PATH.lex}

PTHREAD_OPTS+=		require

PYTHON_FOR_BUILD_ONLY=	yes
PYTHON_VERSIONS_INCOMPATIBLE=	33 34 35 # not yet ported as of 1.10.5
REPLACE_PYTHON+=	help/faq.py
REPLACE_PYTHON+=	tools/asn2deb
REPLACE_PYTHON+=	tools/asn2wrs.py
REPLACE_PYTHON+=	tools/dfilter-test.py
REPLACE_PYTHON+=	tools/ftsanity.py
REPLACE_PYTHON+=	tools/html2text.py
REPLACE_PYTHON+=	tools/idl2deb
REPLACE_PYTHON+=	tools/indexcap.py
REPLACE_PYTHON+=	tools/make-dissector-reg.py
REPLACE_PYTHON+=	tools/make-tap-reg.py
REPLACE_PYTHON+=	tools/msnchat
REPLACE_PYTHON+=	tools/ncp2222.py
REPLACE_PYTHON+=	tools/netscreen2dump.py
REPLACE_PYTHON+=	tools/pkt-from-core.py
REPLACE_PYTHON+=	tools/rdps.py

.include "../../mk/bsd.prefs.mk"
.include "options.mk"

.if !empty(MACHINE_PLATFORM:MDarwin-[567].*-*)
USE_BUILTIN.libpcap=	no
.endif

CONFIGURE_ARGS.Darwin+=	--disable-osx-deploy-target

# Extra post install targets are in options.mk
post-install: ${POST_INSTALL_TARGETS}

# wireshark no longer builds with NetBSD 3.x provided zlib
BUILDLINK_API_DEPENDS.zlib=zlib>=1.2.1

# wireshark uses gdk_pixbuf_new_from_inline which is deprecated, but asks
# to hide deprecated prototypes. This leads to pointer truncation.
# gui_utils.c:514:12: warning: incompatible integer to pointer conversion
# assigning to 'GdkPixbuf *' (aka 'struct _GdkPixbuf *') from 'int'
# [-Wint-conversion]
BUILDLINK_TRANSFORM+=	rm:-DGDK_PIXBUF_DISABLE_DEPRECATED

.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/pcre/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../net/libpcap/buildlink3.mk"
.include "../../devel/libsmi/buildlink3.mk"
.include "../../security/libgcrypt/buildlink3.mk"
.include "../../security/gnutls/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"

.include "../../lang/python/application.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"