[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / twittering-mode

File: [cvs.NetBSD.org] / pkgsrc / net / twittering-mode / Makefile (download)

Revision 1.3, Sat May 14 22:25:40 2022 UTC (16 months, 2 weeks ago) by dholland
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, HEAD
Changes since 1.2: +2 -1 lines

Bump all elisp packages for the CONFLICTS change.

# $NetBSD: Makefile,v 1.3 2022/05/14 22:25:40 dholland Exp $

DISTNAME=	twittering-mode-3.0.0
PKGREVISION=	1
CATEGORIES=	net
MASTER_SITES+=	http://sourceforge.net/projects/twmode/files/twittering-mode-3.0.0/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/hayamiz/twittering-mode/
COMMENT=	Emacs client for twitter
LICENSE=	gnu-gpl-v2

NO_BUILD=	yes

USE_LANGUAGES=	# none

# Original shows vHEAD by M-x twittering-mode-version, but it might be nice
# to tell a user the version number by this command (mef@).
SUBST_CLASSES+=		version
SUBST_MESSAGE.version=	Replace version string 'HEAD' by ${PKGVERSION}
SUBST_STAGE.version=	pre-configure
SUBST_FILES.version=	twittering-mode.el
SUBST_SED.version=	-e '/defconst/s,HEAD,${PKGVERSION},'

.include "../../editors/emacs/modules.mk"
# Avoid single file spread out just under site-lisp directory.
# And directory name should get higher precedence, so begins with 'a'.
INSTALLATION_DIRS=	${EMACS_LISPPREFIX}/a-files

TEST_TARGET=	check

do-install:
	${INSTALL_DATA}   ${WRKSRC}/twittering-mode.el  ${DESTDIR}${INSTALLATION_DIRS}

.include "../../mk/bsd.pkg.mk"