[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / tor

Annotation of pkgsrc/net/tor/Makefile, Revision 1.158

1.158   ! wiz         1: # $NetBSD: Makefile,v 1.157 2020/09/19 18:22:01 leot Exp $
1.1       jschauma    2:
1.158   ! wiz         3: DISTNAME=      tor-0.4.4.6
1.126     adam        4: CATEGORIES=    net security
1.132     adam        5: MASTER_SITES=  https://dist.torproject.org/
1.126     adam        6:
1.143     gdt         7: MAINTAINER=    pkgsrc-users@NetBSD.org
1.150     rillig      8: HOMEPAGE=      https://www.torproject.org/
1.126     adam        9: COMMENT=       Anonymizing overlay network for TCP
                     10: LICENSE=       modified-bsd
1.1       jschauma   11:
1.79      drochner   12: USE_LANGUAGES=         c99
1.1       jschauma   13: USE_PKGLOCALEDIR=      yes
1.138     wiz        14: USE_TOOLS+=            perl:test pkg-config
1.144     gdt        15: # There are multiple reports of failure to build with BSD make, due to
                     16: # an apparent lack of firing the rule to create micro-revision.i.
                     17: # Work around this by using gmake, which is tiny compared to the
                     18: # existing perl dependency, and unlikely to be needed on any given
                     19: # system just for tor.
1.152     wiz        20: USE_TOOLS+=            gmake bash:test
1.1       jschauma   21: GNU_CONFIGURE=         yes
1.132     adam       22: CONFIGURE_ARGS+=       --localstatedir=${VARBASE}
                     23: CONFIGURE_ARGS+=       --sysconfdir=${PKG_SYSCONFBASEDIR}
1.46      obache     24: CONFIGURE_ENV+=                CPP=${CPP:Q}
                     25:
                     26: TEST_TARGET=           check
                     27:
1.6       jschauma   28: TOR_USER?=             tor
                     29: TOR_GROUP?=            tor
1.103     bsiegert   30: PKG_GECOS.${TOR_USER}= Torifier
                     31: PKG_HOME.${TOR_USER}=  ${VARBASE}/chroot/tor
1.46      obache     32: BUILD_DEFS+=           VARBASE
1.47      obache     33: PKG_SYSCONFSUBDIR=     tor
1.6       jschauma   34:
1.42      jlam       35: PKG_GROUPS_VARS+=      TOR_GROUP
1.79      drochner   36: PKG_USERS_VARS=                TOR_USER
1.42      jlam       37:
1.30      rillig     38: RCD_SCRIPTS=           tor
1.45      obache     39: RCD_SCRIPT_SRC.tor=    ${FILESDIR}/tor.in
1.6       jschauma   40: PKG_GROUPS=            ${TOR_GROUP}
1.95      jperkin    41: PKG_USERS=             ${TOR_USER}:${TOR_GROUP}
1.6       jschauma   42: USER_GROUP=            ${TOR_USER} ${TOR_GROUP}
                     43:
1.95      jperkin    44: OWN_DIRS_PERMS+=       ${PKG_HOME.${TOR_USER}} ${USER_GROUP} 0700
1.1       jschauma   45:
1.136     adam       46: CONF_FILES+=           ${PREFIX}/share/examples/tor/torrc.sample \
                     47:                        ${PKG_SYSCONFDIR}/torrc
1.1       jschauma   48:
1.121     adam       49: PRINT_PLIST_AWK+=      /^man\/man/ { $$0 = "$${PLIST.doc}" $$0 }
                     50: PRINT_PLIST_AWK+=      /^share\/doc/ { $$0 = "$${PLIST.doc}" $$0 }
1.120     leot       51:
1.95      jperkin    52: FILES_SUBST+=          PKG_HOME=${PKG_HOME.${TOR_USER}}
1.79      drochner   53: FILES_SUBST+=          TOR_USER=${TOR_USER} TOR_GROUP=${TOR_GROUP}
1.5       jschauma   54:
1.66      obache     55: INSTALL_MAKE_FLAGS+=   sysconfdir=${PREFIX}/share/examples
                     56:
1.146     rillig     57: CHECK_PORTABILITY_SKIP+=       contrib/*
1.35      tv         58:
1.153     wiz        59: REPLACE_PERL+=         scripts/maint/checkSpace.pl
                     60:
1.140     wiz        61: .include "options.mk"
                     62:
1.119     wiz        63: .include "../../mk/bsd.prefs.mk"
                     64:
1.54      wiz        65: .if !empty(PKGSRC_COMPILER:Mmipspro)
                     66: CFLAGS+=               -c99
                     67: .endif
                     68:
1.138     wiz        69: .include "../../archivers/zstd/buildlink3.mk"
1.106     wiz        70: BUILDLINK_API_DEPENDS.libevent+= libevent>=2.0
1.15      drochner   71: .include "../../devel/libevent/buildlink3.mk"
1.9       jschauma   72: .include "../../devel/zlib/buildlink3.mk"
1.54      wiz        73: .include "../../security/openssl/buildlink3.mk"
1.48      bjs        74: .include "../../mk/pthread.buildlink3.mk"
1.1       jschauma   75: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>