File:  [cvs.NetBSD.org] / pkgsrc / net / spreadlogd / Makefile
Revision 1.22: download - view: text, annotated - select for diffs
Wed Jun 8 19:24:16 2016 UTC (8 years, 6 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, HEAD
Bump PKGREVISION for perl-5.24.

# $NetBSD: Makefile,v 1.22 2016/06/08 19:24:16 wiz Exp $
#

DISTNAME=	spreadlogd
PKGNAME=	spreadlogd-2.0.0
PKGREVISION=	19
CATEGORIES=	net
MASTER_SITES=	http://www.backhand.org/mod_log_spread/
DIST_SUBDIR=	${PKGNAME_NOREV}

MAINTAINER=	mark@exonetric.com
HOMEPAGE=	http://www.backhand.org/mod_log_spread/
COMMENT=	Daemon to log to file, messages from spread toolkit clients

GNU_CONFIGURE=	yes
USE_TOOLS+=	perl:run yacc
WRKSRC=		${WRKDIR}/${PKGNAME_NOREV}

RCD_SCRIPTS=	spreadlogd
# define the "example" directory for post-install target and for the CONF_FILES
# variable used by pkginstall
EXAMPLEDIR=	${PREFIX}/share/examples/spreadlogd

# tell pkginstall where to pluck virgin configuration files from in the case of a new
# install, knowing that the post-install target in *this* Makefile will put the
# sample configuration in the example directory for us (as well as creating it)
CONF_FILES+=	${EXAMPLEDIR}/spreadlogd.conf.sample ${PKG_SYSCONFDIR}/spreadlogd.conf

INSTALLATION_DIRS+=	${EXAMPLEDIR}

# create example directory *and* put the sample configuration file here with the suffix
# .sample so that pkginstall can drop it in for us.
post-install:
	${INSTALL_DATA} ${WRKSRC}/spreadlogd.conf ${DESTDIR}${EXAMPLEDIR}/spreadlogd.conf.sample

BUILDLINK_API_DEPENDS.libevent+=libevent>=1.0c

.include "../../net/spread/buildlink3.mk"
.include "../../devel/libevent/buildlink3.mk"
.include "../../lang/perl5/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>