[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / sniffit

File: [cvs.NetBSD.org] / pkgsrc / net / sniffit / Makefile (download)

Revision 1.14, Mon Jan 8 14:59:18 2001 UTC (23 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.13: +12 -4 lines

USE_CURSES instead of DEPENDS on ncurses.

# $NetBSD: Makefile,v 1.14 2001/01/08 14:59:18 wiz Exp $
#

DISTNAME=		sniffit.0.3.5
PKGNAME=		sniffit-0.3.5
CATEGORIES=		net security
MASTER_SITES=		http://reptile.rug.ac.be/~coder/sniffit/files/

MAINTAINER=		packages@netbsd.org
HOMEPAGE=		http://reptile.rug.ac.be/~coder/sniffit/sniffit.html

NOT_FOR_PLATFORM=	*-*-alpha	# severe LP64 loss

USE_CURSES=		yes
REPLACE_NCURSES=	${WRKSRC}/configure

HAS_CONFIGURE=		YES
ALL_TARGET=

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/sniffit ${PREFIX}/sbin/sniffit
	${INSTALL_MAN}     ${WRKSRC}/sniffit.5 ${PREFIX}/man/man5
	${INSTALL_MAN}     ${WRKSRC}/sniffit.8 ${PREFIX}/man/man8

.include "../../mk/bsd.prefs.mk"

.if ${NEED_NCURSES} == "YES"
CONFIGURE_ENV+=		NCURSES_LOCATION=${LOCALBASE}/include/ncurses.h
.else
CONFIGURE_ENV+=		NCURSES_LOCATION=no
.endif

.include "../../mk/bsd.pkg.mk"