File:  [cvs.NetBSD.org] / pkgsrc / net / sdist / Makefile
Revision 1.16: download - view: text, annotated - select for diffs
Tue Oct 23 17:19:08 2012 UTC (12 years, 1 month ago) by asau
Branches: MAIN
CVS tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4, HEAD
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

# $NetBSD: Makefile,v 1.16 2012/10/23 17:19:08 asau Exp $
#

DISTNAME=		sdist-1.7
PKGREVISION=		1
CATEGORIES=		net
MASTER_SITES=		# ftp://ftp.gw.com/pub/people/kim/

MAINTAINER=		kim@tac.nyc.ny.us
COMMENT=		Invoke rdist to distribute files to a set of hosts

DEPENDS+=		netname-[0-9]*:../../net/netname
DEPENDS+=		osname-[0-9]*:../../sysutils/osname
DEPENDS+=		freerdist-[0-9]*:../../net/rdist6
DEPENDS+=		srsh-[0-9]*:../../net/srsh

.include "../../mk/bsd.prefs.mk"

SDIST_PAWD?=		pwd

BUILD_DEFS+=		SDIST_PAWD

INSTALLATION_DIRS=	sbin ${PKGMANDIR}/man8
NO_CONFIGURE=		yes
BUILD_MAKE_FLAGS+=	PREFIX=${PREFIX} PAWD=${SDIST_PAWD}
INSTALL_MAKE_FLAGS+=	PREFIX=${DESTDIR}${PREFIX}

SUBST_CLASSES+=		manpath
SUBST_STAGE.manpath=	post-extract
SUBST_FILES.manpath=	Makefile
SUBST_SED.manpath=	-e 's,/man/,/${PKGMANDIR}/,'

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>