[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / radiusd-cistron

File: [cvs.NetBSD.org] / pkgsrc / net / radiusd-cistron / Attic / Makefile (download)

Revision 1.19, Sat Mar 4 21:30:23 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.18: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.19 2006/03/04 21:30:23 jlam Exp $

DISTNAME=	radiusd-cistron-1.6.7
PKGREVISION=	1
CATEGORIES=	net
MASTER_SITES=	ftp://ftp.cistron.nl/pub/people/miquels/radius/ \
		ftp://ftp.freeradius.org/pub/radius/

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.radius.cistron.nl/
COMMENT=	RADIUS-compliant remote authentication and accounting server

CONFLICTS+=	freeradius-[0-9]*


MAKEFILE=	Makefile.BSD
BUILD_DIRS=	${WRKSRC}/src
INSTALL_DIRS=	${WRKSRC}/src

RCD_SCRIPTS=	radiusd

OWN_DIRS_PERMS=	/var/log/radacct ${ROOT_USER} ${ROOT_GROUP} 700

PKG_SYSCONFSUBDIR=	raddb
EGDIR=		${PREFIX}/share/examples/raddb
CONF_FILES=
.for cfile in	clients.sample dictionary dictionary.ascend dictionary.bay \
		dictionary.cisco dictionary.cistron dictionary.compat \
		dictionary.erx dictionary.livingston dictionary.redback \
		dictionary.shiva dictionary.tunnel dictionary.usr \
		dictionary.versanet hints.sample huntgroups.sample \
		naslist.sample naspasswd.sample realms.sample users.sample
CONF_FILES+=	${EGDIR}/${cfile} ${PKG_SYSCONFDIR}/${cfile:S/.sample//}
.endfor

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/radiusd-cistron
	${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${PREFIX}/share/doc/radiusd-cistron/
.for i in	ChangeLog README README.CVX README.Y2K README.cisco	\
		README.pam README.proxy README.radrelay README.simul	\
		README.tunnel README.usersfile
	${INSTALL_DATA} ${WRKSRC}/doc/${i} ${PREFIX}/share/doc/radiusd-cistron/
.endfor
.for i in	radclient.1 radlast.1 radtest.1 radwho.1 radzap.1
	${INSTALL_MAN} ${WRKSRC}/doc/${i} ${PREFIX}/man/man1/
.endfor
.for i in	clients.5rad naslist.5rad
	${INSTALL_MAN} ${WRKSRC}/doc/${i} ${PREFIX}/man/man5/
.endfor
.for i in	radiusd.8 radrelay.8 radwatch.8
	${INSTALL_MAN} ${WRKSRC}/doc/${i} ${PREFIX}/man/man8/
.endfor

# The sources assume <malloc.h> exists.  Create a fake one for platforms
# that don't have it.
post-wrapper:
	if ${TEST} ! -f /usr/include/malloc.h; then		\
		${ECHO} "#include <stdlib.h>"			\
			> ${BUILDLINK_DIR}/include/malloc.h;	\
	fi

.include "../../mk/bsd.pkg.mk"