[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / rabbitmq-c

File: [cvs.NetBSD.org] / pkgsrc / net / rabbitmq-c / Makefile (download)

Revision 1.3, Wed Feb 12 23:18:25 2014 UTC (10 years, 2 months ago) by tron
Branch: MAIN
Changes since 1.2: +2 -1 lines

Recursive PKGREVISION bump for OpenSSL API version bump.

# $NetBSD: Makefile,v 1.3 2014/02/12 23:18:25 tron Exp $

DISTNAME=	rabbitmq-c-0.4.1
PKGREVISION=	1
CATEGORIES=	net
MASTER_SITES=	https://github.com/alanxz/rabbitmq-c/releases/download/v${PKGVERSION_NOREV}/

MAINTAINER=	filip@joyent.com
HOMEPAGE=	https://github.com/alanxz/rabbitmq-c
COMMENT=	C-language AMQP client library for use with AMQP servers
LICENSE=	mit

BUILD_DEPENDS+=		xmlto-[0-9]*:../../textproc/xmlto

USE_CMAKE=		yes
USE_LANGUAGES+=		c99
USE_TOOLS+=		pkg-config

SUBST_CLASSES+=		man
SUBST_STAGE.man=	pre-build
SUBST_MESSAGE.man=	Fix man installation path
SUBST_FILES.man=	tools/CMakeLists.txt
SUBST_SED.man=		-e 's,share/man,${PKGMANDIR},'

CMAKE_ARGS+=		-DBUILD_TOOLS=ON
CMAKE_ARGS+=		-DBUILD_TOOLS_DOCS=ON
CMAKE_ARGS+=		-DENABLE_SSL_SUPPORT=ON

.include "../../devel/popt/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"