The NetBSD Project

CVS log for pkgsrc/net/rabbitmq-c/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / net / rabbitmq-c

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.25: download - view: text, markup, annotated - select for diffs
Tue Feb 4 09:33:35 2025 UTC (6 weeks, 2 days ago) by adam
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +5 -6 lines
rabbitmq-c: updated to 0.15.0

v0.15.0 - 2024-11-19

Fixed
- Warning on MacOS about incompatible function declaration
- Logic when decoding AMQP data after bad data may cause crash
- Use SSL_get1_peer_certificate when compiling against OpenSSL 3+

Changed
- Updates to various github actions.

Added
- Add amqp_publisher_confirm_wait function
- Add amqp_literal_bytes macro

Revision 1.24: download - view: text, markup, annotated - select for diffs
Sun Aug 25 06:19:07 2024 UTC (6 months, 3 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +4 -4 lines
*: replace CMAKE_ARGS with CMAKE_CONFIGURE_ARGS

Revision 1.23: download - view: text, markup, annotated - select for diffs
Sun Apr 7 19:26:14 2024 UTC (11 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +6 -5 lines
rabbitmq-c: updated to 0.14.0

v0.14.0 - 2024-03-18

Fixed

Fix potential stackoverflow in decoding table and array
Fix issue with Mach-O version
Make dependency on OpenSSL in rabbitmq-c.cmake match what is built
Fix pkg-config generation when CMAKE_INSTALL_DIR is absolute
Fix issue with amqp_basic_publish blocking in non-blocking mode
Fix SSL hostname check
Fix bug in amqp-consume documentation

Changed

CMake minimum version is now 3.22
OpenSSL minimum version is now 1.1.1
Minimum TLS version supported is v1.2 (v1.3 is also supported).
OpenSSL ENGINE APIs are conditionally enabled based on availability

Added

Add option to read username/password from file in tools
Add amqp_ssl_socket_enable_default_verify_paths API to allow loading from default certification paths
rabbitmq-c can be compiled against BoringSSL

Revision 1.22: download - view: text, markup, annotated - select for diffs
Tue Oct 24 22:10:32 2023 UTC (16 months, 3 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +2 -1 lines
*: bump for openssl 3

Revision 1.21: download - view: text, markup, annotated - select for diffs
Tue Jun 6 12:42:09 2023 UTC (21 months, 2 weeks ago) by riastradh
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +2 -2 lines
Mass-change BUILD_DEPENDS to TOOL_DEPENDS outside mk/.

Almost all uses, if not all of them, are wrong, according to the
semantics of BUILD_DEPENDS (packages built for target available for
use _by_ tools at build-time) and TOOL_DEPEPNDS (packages built for
host available for use _as_ tools at build-time).

No change to BUILD_DEPENDS as used correctly inside buildlink3.

As proposed on tech-pkg:
https://mail-index.netbsd.org/tech-pkg/2023/06/03/msg027632.html

Revision 1.20: download - view: text, markup, annotated - select for diffs
Mon Feb 6 11:56:33 2023 UTC (2 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +2 -2 lines
rabbitmq-c: updated to 0.13.0

v0.13.0

Fixed missing option to not install static library
Missing pkgconfig version in v0.12.0 output
Correct return value from amqp_ssl_socket_set_key_buffer

Changed

Remove OpenSSL code no longer needed when used with OpenSSL >= 1.1.0.

Added

Integration with OSS-Fuzz

Revision 1.19: download - view: text, markup, annotated - select for diffs
Thu Feb 2 13:10:05 2023 UTC (2 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +10 -10 lines
rabbitmq-c: updated to 0.12.0

rabbitmq-c v0.12.0

rabbitmq-c now compiles as C99
CMake 3.12 is new minimum required version
CMake -DBUILD_TESTS renamed to -DBUILD_TESTING
CMake -DBUILD_EXAMPLES now defaults to OFF
CMake -DBUILD_TOOLS now defaults to OFF
Unix library version now matches the release version, SONAME remains the same.
Modernized CMake scripts to better adopt modern standards
Public headers have moved to rabbitmq-c/ directory
Dropped support for MSVC older than VS 2010
Dropped support for OpenSSL v1.1.0 and older
Minimum SSL version set to TLSv1.2
Updated to RabbitMQ framing to v3.8.19

Revision 1.18: download - view: text, markup, annotated - select for diffs
Mon Apr 5 11:48:43 2021 UTC (3 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -2 lines
rabbitmq-c: updated to 0.11.0

rabbitmq-c v0.11.0

Added:

rabbitmq-c-config.cmake is now generated
rabbitmq-c can be compiled on Win32 using pthreads
Add amqp_set_ssl_engine API to allow setting OpenSSL engine
Add amqp_ssl_socket_set_key_engine API to allow setting OpenSSL engine
Add support use of password-protected SSL keys

Changed

Update OpenSSL library initialization to current best practices
Updates to OpenSSL to support v3.0.0

Fixed:

OpenSSL symbol clash when compiling on Win32
Restore correct non-blocking behavior using OpenSSL v1.1.1
Disable harmless secure CRT compile warnings on Win32
Fix unused parameter warnings on Win32
Fix invalid format in generated pkg-config file
Fix invalid AMQP_STATUS_HEARTBEAT_TIMEOUT
Fix incorrect port when using --server flag in CLI tools

Revision 1.17: download - view: text, markup, annotated - select for diffs
Wed May 27 19:37:41 2020 UTC (4 years, 9 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -2 lines
*: reset MAINTAINER for fhajny on his request

Revision 1.16: download - view: text, markup, annotated - select for diffs
Sat May 16 16:16:10 2020 UTC (4 years, 10 months ago) by rillig
Branches: MAIN
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +1 -7 lines
net/rabbitmq-c: remove no-op SUBST block

Revision 1.15: download - view: text, markup, annotated - select for diffs
Thu Feb 13 12:22:16 2020 UTC (5 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +7 -9 lines
rabbitmq-c: updated to 0.10.0

rabbitmq-c v0.10.0

Added:
amqp_ssl_socket_get_context can be used to get the current OpenSSL CTX*
associated with a connection.

Changed:
openssl: missing OpenSSL config is ignored as an OpenSSL init error
AMQP_DEFAULT_MAX_CHANNELS is now set to 2047 to follow current default channel
limit in the RabbitMQ broker.

Fixed:
add additional input validation to prevent integer overflow when parsing a
frame header. This addresses CVE-2019-18609.

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sat Jan 18 21:48:20 2020 UTC (5 years, 2 months ago) by jperkin
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -1 lines
*: Recursive revision bump for openssl 1.1.1.

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sat Dec 15 21:12:22 2018 UTC (6 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
*: update email for fhajny

Revision 1.12: download - view: text, markup, annotated - select for diffs
Mon May 14 15:51:40 2018 UTC (6 years, 10 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
net/rabbitmq-c: Update to 0.9.0.

Added:
- amqp-publish: added support for specifying headers via the -H flag
- Add support for specifying timeout for amqp_login calls via
  amqp_set_handshake_timeout
- Add support for specifying timeouts in RPC-style AMQP methods via
  amqp_set_rpc_timeout
- Add define for AMQP_DEFAULT_VHOST
- Support for SSL SNI
- Support for OpenSSL v1.1.0

Changed:
- rabbitmq-c now requires Windows Vista or better
- rabbitmq-c enables TCP keep-alive by default on platforms that
  support it
- dropped support for compiling rabbitmq-c without threading support
- OpenSSL is no longer un-intialized automatically by default. OpenSSL
  can be
  explicitly initialized by calling amqp_initialize_ssl_library and
  uninitialized by calling amqp_uninitialize_ssl_library.

Fixed:
- Correct bugs in processing of --url flag in tools
- Improve documentation on AMQP_SASL_METHOD_EXTERNAL
- Improve support for compiling under mingw-w64
- Better support for handing SIGPIPE on Linux over SSL
- Improve publish performance on Linux by not specifying MSG_MORE on
  last part of message.
- Fix connection logic where multiple hostnames won't be tried if
  connection to doesn't fail immediately

Removed:
- autotools build system has been removed
- many duplicate amqps_* examples, they did not add a lot of value

Revision 1.11: download - view: text, markup, annotated - select for diffs
Tue Apr 12 08:50:43 2016 UTC (8 years, 11 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -3 lines
Update net/rabbitmq-c to 0.8.0.

Added:
- SSL: peer certificate and hostname validation can now be
  controlled separately using amqp_ssl_socket_set_verify_peer and
  amqp_ssl_socket_set_verify_hostname.
- SSL: the desire SSL version range can now be specified using the
  amqp_ssl_socket_set_ssl_versions function.
- Add flags to SSL examples on controlling hostname verification.

Changed:
- SSL: SSLv2, and SSLv3 have been disabled by default.
- SSL: OpenSSL hostname validation has been improved.
- Win32 debug information is built with /Z7 on MSVC to embed debug
  info instead of using a .pdb

Fixed:
- Connection failure results in hang on Win32
- Rabbitmq-c may block when attempting to close an SSL socket
- amqp_parse_url does not correctly initialize default parameters
- x509 objects are leaked in verify_hostname
- TCP_NOPUSH doesn't work under cygwin

Deprecated
- SSL: amqp_ssl_socket_set_verify is being replaced by
- amqp_ssl_socket_set_verify_peer and
- amqp_ssl_socket_set_verify_hostname.

Removed:
- OpenVMS build system and related files.
- Unmaintained PolarSSL, CyaSSL, and gnuTLS SSL backends

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sat Mar 5 11:27:53 2016 UTC (9 years ago) by jperkin
Branches: MAIN
CVS tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -1 lines
Bump PKGREVISION for security/openssl ABI bump.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Sun Oct 18 08:47:46 2015 UTC (9 years, 5 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
Update net/rabbitmq-c to 0.7.1.

- Win32: Use WSAEWOULDBLOCK instead of EWOULDBLOCK on Win32 (win32
  clients would fail to connect)
- Lib: if channel_max is 0 use server's channel_max
- Lib: fix build on OpenBSD

Revision 1.8: download - view: text, markup, annotated - select for diffs
Wed Aug 26 01:01:34 2015 UTC (9 years, 6 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +5 -3 lines
Update net/rabbitmq-c to 0.7.0.

- Tools: Add support for heartbeats
- CI: Add continuous integration on Win32 using Appveyor
- Tests: only link against static libraries
- Lib: add support for EXTERNAL SASL method
- Lib: fix incorrect parameters to WSAPoll on Win32
- Lib: use non-blocking sockets internally
- Lib: simplify timer/timeout logic
- Lib: add support for heartbeat checks in blocking send calls
- Lib: Fix warnings on Win32
- Lib: Add support for RabbitMQ auth failure extension
- Lib: allow calling functions to override client-properties
- examples: replace usleep() with nanosleep()
- Lib: add AMQP_VERSION code
- Lib: fix res maybe returned uninitialized in amqp_merge_capbilities
- Lib: Fix SSL_connection status check
- Lib: Fix issues with c89 compatiblity
- Lib: perf improvements when sending small messages by hinting
  to the OS message boundaries.
- Lib: add select()-based timeout implementation
- CI: add ubsan, asan, and tsan CI builds

Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue Apr 7 08:57:32 2015 UTC (9 years, 11 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +3 -3 lines
Update net/rabbitmq-c to 0.6.0.

Changes since v0.5.2:
- Tools: Enable support for SSL in tools.
- Lib: ABI CHANGE: enable support for auto_delete, internal flags
  to amqp_exchange_declare
- Lib: check for double-close in SSL/TCP socket impl
- Lib: allocate struct when method has no field.
- Lib: add support for SANs in OpenSSL socket impl.
- Lib: add functions to get negotiated frame_max and heartbeat parms.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Thu Oct 2 10:45:36 2014 UTC (10 years, 5 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
Update rabbitmq-c to 0.5.2.

Changes in 0.5.2

fcdf0f8 Autoconf: check for htonll as declaration in a header file
5790ec7 SSL: correctly report hostname verification errors.
d60c28c Build: disable OpenSSL deprecation warnings on OSX
072191a Lib: include platform, version and copyright in AMQP handshake
8b448c6 Examples: print message body in amqp[s]_listen[q] examples
7188e5d Tools: Add flag to set prefetch for amqp-consume tool

Changes in 0.5.1

a566929 SSL: Add support for wildcards in hostname verification (Mike Steinert)
a78aa8a Lib: Use poll(2) instead of select(2) for timeouts on sockets.
357bdb3 Lib: support for specifying frame and decoding pool sizes. (Mike Stitt)
8956003 Lib: improve invalid frame detection code.
b852f84 Lib: Add missing amqp_get_server_properties() function.
7001e82 Lib: Add missing ssize_t on Win32 (emazv72)
c2ce2cb Lib: Correctly specify WINVER on Win32 when unspecified.
fe844e4 CMake: specify -DHAVE_CONFIG_H in examples.
932de5f Lib: correct time computation on Win32 (jestor)
3e83192 HPUX: use gethrtime on HP-UX for timers.
cb1b44e HPUX: correct include location of sys/uio.h
8ce585d Lib: incorrect OOM condition when 0-lenth exchange name is received.
c7716b8 CMake: correct htonll detection code on platforms defined with a macro.
4dc4eda Lib: remove unused assignment.
45302cf Lib: remove range-check of channel-ids.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sun Jun 8 17:18:03 2014 UTC (10 years, 9 months ago) by rodent
Branches: MAIN
CVS tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +3 -3 lines
Add another file to SUBST.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Feb 13 09:46:00 2014 UTC (11 years, 1 month ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +3 -4 lines
Update net/rabbitmq-c to 0.5.0. Add bl3.

- Add amqp_get_broker_properties() function
- Remove distro-specific packaging
- Add -x flag to amqp-consume utility
- Add amqp_basic_nack() public API
- Add delivery mode constants to amqp.h
- Add support for connection.blocked/connection.unblocked methods
- Examples: Destroy amqp_envelope_t in consumer example
- CMake: fix generation of librabbitmq.pc
- CMake: fix missing POPT_INCLUDE_DIRS variable in tools/
- build: provide independent locations for x64 libs
- Doc: documentation fixes
- Lib: Correct OpenSSL initialization under threaded conditions
- Examples: Handle unexpected frames in amqp_consumer.c
- CMake: Use GnuInstallDirs to generate install dirs
- Lib: correctly handle amqp_get_monotonic_timestamp on win32
- Tools: honor --persistent flag in publish utility
- Doc: improve documentation in amqp_ssl_socket functions
- autoconf: correct librabbitmq.pc generation
- Doc: improve documentation in amqp_tcp_socket functions

Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed Feb 12 23:18:25 2014 UTC (11 years, 1 month ago) by tron
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -1 lines
Recursive PKGREVISION bump for OpenSSL API version bump.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Mon Jan 27 18:41:14 2014 UTC (11 years, 1 month ago) by wiz
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +1 -3 lines
Do not set FETCH_USING, should not be set in a package Makefile.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Fri Sep 13 11:12:06 2013 UTC (11 years, 6 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Import net/rabbitmq-c.

C-language AMQP client library for use with v2.0+ of the RabbitMQ broker.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>