The NetBSD Project

CVS log for pkgsrc/net/py-tweepy/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / net / py-tweepy

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue Oct 26 11:06:45 2021 UTC (3 years, 1 month ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, HEAD
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines

net: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Not committed (merge conflicts...):

net/radsecproxy/distinfo

The following distfiles could not be fetched (fetched conditionally?):

./net/citrix_ica/distinfo citrix_ica-10.6.115659/en.linuxx86.tar.gz
./net/djbdns/distinfo dnscache-1.05-multiple-ip.patch
./net/djbdns/distinfo djbdns-1.05-test28.diff.xz
./net/djbdns/distinfo djbdns-1.05-ignoreip2.patch
./net/djbdns/distinfo djbdns-1.05-multiip.diff
./net/djbdns/distinfo djbdns-cachestats.patch

Revision 1.6: download - view: text, markup, annotated - select for diffs
Thu Oct 7 14:42:35 2021 UTC (3 years, 2 months ago) by nia
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +1 -2 lines
net: Remove SHA1 hashes for distfiles

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sun Mar 7 17:20:00 2021 UTC (3 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +5 -7 lines
py-tweepy: updated to 3.10.0

Version 3.10.0

This will be the last major and minor version to support Python 2.7
The next non-patch release should be version 4.0.0.

New Features / Improvements

Add API.search_30_day and API.search_full_archive
Update allowed parameters for API.home_timeline
Add trim_user, exclude_replies, include_entities
Remove page as erroneously documented parameter
Reorder count to be the first parameter
Update allowed parameters for API.get_oembed
Add hide_thread, theme, link_color, widget_type, dnt
Remove id
Remove API.update_profile_background_image
Add support for Python 3.9
Switch from Travis CI to GitHub Actions to run tests and deploy releases
Update and improve various documentation

Bug Fixes

Use mimetypes.guess_type as fallback for determining image file type
Use proper MIME type in Content-Type header for uploaded images
Allow file parameter to be used again for API.media_upload
Allow file parameter to be used again for API.update_profile_banner, API.update_profile_image, and API.update_with_media
Fix User.lists, User.lists_memberships, and User.lists_subscriptions to retrieve information about the user in question rather than the authenticating user


Version 3.9.0

New Features / Improvements

Add API.create_media_metadata
Update allowed parameters for API.update_status
Add exclude_reply_user_ids, attachment_url, possibly_sensitive, trim_user, enable_dmcommands, fail_dmcommands, card_uri
Remove in_reply_to_status_id_str, source
Add allowed parameters to API.get_status
trim_user, include_my_retweet, include_entities, include_ext_alt_text, include_card_uri
Add allowed parameters to API.statuses_lookup
include_ext_alt_text, include_card_uri
Improve API.lookup_users
Improve and optimize API.statuses_lookup, API.create_media_metadata, API.update_status
Add reverse as allowed parameter for API.lists_all
Add count as allowed parameter for API.lists_memberships
Add count as allowed parameter for API.lists_subscriptions
Add include_entities as allowed parameter for API.list_timeline
Add allowed parameters to API.list_subscribers
count, include_entities, skip_status
Add support for Python 3.8
Update and improve setup.py
Use requests socks extra instead of requiring PySocks directly
Allow uploading of images with file names without extensions
Support uploading WebP images
Add missing attributes to Relationship model
Update max allowed size for uploaded GIFs
Add _json attribute to DirectMessage model
Update and improve tests
Add documentation for extended Tweets
Document API.lookup_users
Add documentation for running tests
Add Korean translation of documentation
Add Polish translation of documentation
Document API.lookup_friendships
Update and improve various documentation

Bug Fixes

Fix handling of invalid credentials for API.verify_credentials
Handle boolean value for API.verify_credentials include_email parameter
Allow Cursor to be used with API.list_direct_messages by adding DMCursorIterator


Version 3.8.0

New Features / Improvements

Allow streams to use daemon threads
Remove API.set_delivery_device
Remove simplejson import and usage
Allow cursor parameter for API.blocks_ids and API.mutes_ids
Drop support for Python 3.4
Allow perform_block parameter for API.report_spam
Add API.mutes
Allow count parameter for API.friends
Remove since, from, to, and source as allowed parameters for API.search
Handle location deletion and withheld content notices for streams
Allow usage of equality and difference operators with User objects
Add _json attribute to Category, Friendship, and List models
Remove API.suggested_categories, API.suggested_users, and API.suggested_users_tweets
Update and improve tests and cassettes
Update DirectMessage model
Replace API.direct_messages and API.sent_direct_messages with API.list_direct_messages
Update API.get_direct_message, API.send_direct_message, and API.destroy_direct_message
Update and improve various documentation

Bug Fixes

Exclude examples during installation
Properly initialize OAuthHandler.request_token
Properly handle map_ parameter for API.statuses_lookup
Support cursor pagination for API.blocks_ids and API.mutes_ids
Return values for API.update_profile_background_image and API.update_profile_banner
Replace usage of root logger
Close Requests sessions


Version 3.7.0

New Features / Improvements

Allow trim_user and exclude_replies as parameters for API.user_timeline
Allow tweet_mode parameter for API.statuses_lookup
Drop support for Python 2.6 and 3.3
Discord Server
Add proxy support for streams
Add API.create_mute, API.destroy_mute, and API.mutes_ids
Allow tweet_mode parameter for API.lookup_users

Bug Fixes

Fix AttributeError during streaming
Update how requirements are specified
Fix compatibility issue with Python 3.7


Version 3.6.0

New Features / Improvements

Parse Status.quoted_status as a Status object
Allow in_reply_to_status_id_str as a parameter for API.update_status and API.update_with_media
Add stall_warnings parameter to Stream.sample
Add API.unretweet
Allow auto_populate_reply_metadata as a parameter for API.update_status and API.update_with_media
Allow profile_link_color as a parameter for API.update_profile
Add support for Python 3.6

Bug Fixes

Update file size limit for API.media_upload
Fix JSONParser.parse returning None in certain cases
Include URL parameters when accessing cache
Properly re-raise exceptions during streaming
Fix AttributeError and TypeError during streaming
Properly encode filter_level for Stream.filter

Revision 1.4: download - view: text, markup, annotated - select for diffs
Mon Feb 24 00:02:59 2020 UTC (4 years, 9 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +3 -1 lines
Don't parse requirements. Don't use 'async', which got promoted to
keyword in Python 3.7. Bump revision.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat Oct 14 10:23:01 2017 UTC (7 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +5 -5 lines
py-tweepy: update to 3.5.0

3.5.0

Features / Improvements
* Allow 'full_text' param when getting direct messages
* Explicitly return api code when parsing error
* Remove deprecated function and clean up codes

Bug Fixes
* update_status: first positional argument should be 'status'
* Fix "TypeError: Can't convert 'bytes' object to str implicitly"
* Fix duplicate raise in auth.py

Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Nov 4 00:35:32 2015 UTC (9 years, 1 month ago) by agc
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Add SHA512 digests for distfiles for net category

Problems found with existing digests:
	Package haproxy distfile haproxy-1.5.14.tar.gz
	159f5beb8fdc6b8059ae51b53dc935d91c0fb51f [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]

Problems found locating distfiles:
	Package bsddip: missing distfile bsddip-1.02.tar.Z
	Package citrix_ica: missing distfile citrix_ica-10.6.115659/en.linuxx86.tar.gz
	Package djbdns: missing distfile djbdns-1.05-test25.diff.bz2
	Package djbdns: missing distfile djbdns-cachestats.patch
	Package djbdns: missing distfile 0002-dnscache-cache-soa-records.patch
	Package gated: missing distfile gated-3-5-11.tar.gz
	Package owncloudclient: missing distfile owncloudclient-2.0.2.tar.xz
	Package poink: missing distfile poink-1.6.tar.gz
	Package ra-rtsp-proxy: missing distfile rtspd-src-1.0.0.0.tar.gz
	Package ucspi-ssl: missing distfile ucspi-ssl-0.70-ucspitls-0.1.patch
	Package waste: missing distfile waste-source.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Fri Jun 13 20:11:17 2014 UTC (10 years, 6 months ago) by riz
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Add Tweepy 2.3.0, a python API for Twitter.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>