The NetBSD Project

CVS log for pkgsrc/net/py-tldextract/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / net / py-tldextract

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.31: download - view: text, markup, annotated - select for diffs
Mon Apr 28 20:55:42 2025 UTC (41 hours, 6 minutes ago) by adam
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.30: preferred, colored
Changes since revision 1.30: +3 -3 lines
py-tldextract: updated to 5.3.0

5.3.0 (2025-04-21)

* Features
  * Add result field `registry_suffix`
    * To complement the existing public suffix field `suffix`
  * Add result property `top_domain_under_public_suffix`
  * Add result property `top_domain_under_registry_suffix`
  * Deprecate `registered_domain` property
    * Use `top_domain_under_public_suffix` instead, which has the same behavior
      but a more accurate name
* Bugfixes
  * Fix missing `reverse_domain_name` property in CLI `--json` output
* Misc.
    * Expand internal `suffix_index` return type to be richer than bools, and
      include the registry suffix during trie traversal


5.2.0 (2025-04-07)

* Features
  * Add `reverse_domain_name` result property
* Bugfixes
  * Extend exported public interface with `ExtractResult` and `update`
    * These were always meant to be public. Eases user import.
* Docs
  * Document result fields
  * Note all return values
  * Colocate usage in the usage section
  * Link to private domain docs
* Misc.
  * Update bundled snapshot

Revision 1.30: download - view: text, markup, annotated - select for diffs
Sat Apr 19 20:12:31 2025 UTC (10 days, 17 hours ago) by wiz
Branches: MAIN
Diff to: previous 1.29: preferred, colored
Changes since revision 1.29: +3 -1 lines
py-tldextract: fix build with setuptools 78

Bump PKGREVISION.

Revision 1.29: download - view: text, markup, annotated - select for diffs
Mon Nov 11 07:28:51 2024 UTC (5 months, 2 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, pkgsrc-2024Q4-base, pkgsrc-2024Q4
Diff to: previous 1.28: preferred, colored
Changes since revision 1.28: +1 -2 lines
py-*: remove unused tool dependency

py-setuptools includes the py-wheel functionality nowadays

Revision 1.28: download - view: text, markup, annotated - select for diffs
Tue Nov 5 08:37:31 2024 UTC (5 months, 3 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.27: preferred, colored
Changes since revision 1.27: +2 -4 lines
py-tldextract: updated to 5.1.3

5.1.3 (2024-11-04)

* Bugfixes
  * Reduce logging errors
  * Drop support for EOL Python 3.8
  * Support Python 3.13
  * Update bundled snapshot
* Documentation
  * Clarify how to use your own definitions
  * Clarify first-successful definitions vs. merged definitions
* Misc.
  * Switch from Black to Ruff
  * Switch from pip to uv, during tox

Revision 1.27: download - view: text, markup, annotated - select for diffs
Thu Mar 21 09:13:08 2024 UTC (13 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.26: preferred, colored
Changes since revision 1.26: +2 -2 lines
py-tldextract: updated to 5.1.2

5.1.2 (2024-03-18)

* Bugfixes
  * Remove `socket.inet_pton`, to fix platform-dependent IP parsing
  * Use non-capturing groups for IPv4 address detection, for a slight speed boost
* Misc.
  * Add CI for PyPy3.9 and PyPy3.10
  * Add script to automate package release process
  * Update LICENSE copyright years

Revision 1.26: download - view: text, markup, annotated - select for diffs
Sun Nov 19 17:35:54 2023 UTC (17 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.25: preferred, colored
Changes since revision 1.25: +2 -2 lines
py-tldextract: updated to 5.1.1

5.1.1 (2023-11-16)

* Bugfixes
  * Fix path join on Windows
  * Support Python 3.12

5.1.0 (2023-11-05)

* Features
    * Allow passing in `requests.Session`
    * Add "-j, --json" option to support output in json format
* Docs
    * Improve clarity of absolute path
* Misc.
    * Extract all testing deps from tox.ini to pyproject.toml extras
    * Work around responses type union error, in tests

Revision 1.25: download - view: text, markup, annotated - select for diffs
Fri Nov 3 08:17:32 2023 UTC (17 months, 3 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +2 -6 lines
py-tldextract: updated to 5.0.1

5.0.1 (2023-10-17)

* Bugfixes
   * Indicate MD5 not used in a security context (FIPS compliance)
* Misc.
   * Increase typecheck aggression

5.0.0 (2023-10-11)

* Breaking Changes
   * Migrate `ExtractResult` from `namedtuple` to `dataclass`
       * This means no more iterating/indexing/slicing/unpacking the result
         object returned by this library. It is no longer a tuple. You must
         directly reference the fields you're interested in.

         For example, the
         following will no longer work.
         ```python
         tldextract.extract("example.com")[1:3]
         # TypeError: 'ExtractResult' object is not subscriptable
         ```
         Instead, use the following.
         ```python
         ext = tldextract.extract("example.com")
         (ext.domain, ext.suffix)
         ```
* Bugfixes
   * Drop support for EOL Python 3.7
* Misc.
   * Switch from pycodestyle and Pylint to Ruff
   * Consolidate config files
   * Type tests
   * Require docstrings in tests
   * Remove obsolete tests

4.0.0 (2023-10-11)

* **Breaking** bugfixes
   * Always include suffix if private suffix enabled and private suffix exists
       * Add a 4th field `is_private: bool`, to the `ExtractResult`
         `namedtuple`, indicating whether the extraction came from the PSL's
         private domains or not.
       * **This could cause issues when iterating over the tuple and assuming
         only 3 fields.**
       * Previously, the docs promoted iteration to rejoin parts of the tuple.
         This is better achieved by individual access of fields of interest
         (e.g. `ExtractResult.subdomain`) or convenience properties (e.g.
         `ExtractResult.{fqdn,registered_domain}`).

This is the same content as version 3.6.0, originally released 2023-09-19,
which was yanked.

Revision 1.24: download - view: text, markup, annotated - select for diffs
Sat Oct 28 19:57:13 2023 UTC (18 months ago) by wiz
Branches: MAIN
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +2 -1 lines
python/wheel.mk: simplify a lot, and switch to 'installer' for installation

This follows the recommended bootstrap method (flit_core, build, installer).

However, installer installs different files than pip, so update PLISTs
for all packages using wheel.mk and bump their PKGREVISIONs.

Revision 1.23: download - view: text, markup, annotated - select for diffs
Wed Sep 20 07:30:28 2023 UTC (19 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +2 -2 lines
py-tldextract: updated to 3.6.0

3.6.0 (2023-09-19)

* **Breaking** bugfixes
    * Always include suffix if private suffix enabled and private suffix exists
        * Add a 4th field `is_private: bool`, to the `ExtractResult`
          `namedtuple`, indicating whether the extraction came from the PSL's
          private domains or not.
        * **This could cause issues when iterating over the tuple and assuming
          only 3 fields.**
        * Previously, the docs promoted iteration to rejoin parts of the tuple.
          This is better achieved by individual access of fields of interest
          (e.g. `ExtractResult.subdomain`) or convenience properties (e.g.
          `ExtractResult.{fqdn,registered_domain}`).

Revision 1.22: download - view: text, markup, annotated - select for diffs
Thu Sep 14 12:43:43 2023 UTC (19 months, 2 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +5 -6 lines
py-tldextract: updated to 3.5.0

3.5.0 (2023-09-06)

* Features
    * Support IPv6 addresses
* Bugfixes
    * Accept only 4 decimal octet IPv4 addresses
    * Support IPv4 addresses with unicode dots
    * Reject IPv4 addresses with trailing whitespaces + non-whitespaces
* Misc.
    * Migrate setup.py to pyproject.toml

Revision 1.21: download - view: text, markup, annotated - select for diffs
Tue Jun 6 12:42:08 2023 UTC (22 months, 3 weeks ago) by riastradh
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +2 -2 lines
Mass-change BUILD_DEPENDS to TOOL_DEPENDS outside mk/.

Almost all uses, if not all of them, are wrong, according to the
semantics of BUILD_DEPENDS (packages built for target available for
use _by_ tools at build-time) and TOOL_DEPEPNDS (packages built for
host available for use _as_ tools at build-time).

No change to BUILD_DEPENDS as used correctly inside buildlink3.

As proposed on tech-pkg:
https://mail-index.netbsd.org/tech-pkg/2023/06/03/msg027632.html

Revision 1.20: download - view: text, markup, annotated - select for diffs
Mon May 22 07:25:06 2023 UTC (23 months, 1 week ago) by adam
Branches: MAIN
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +2 -2 lines
py-tldextract: updated to 3.4.4

3.4.4
Bugfixes
  * Honor private domains flag on `self`, not only when passed to `__call__`

Revision 1.19: download - view: text, markup, annotated - select for diffs
Fri May 19 08:21:29 2023 UTC (23 months, 1 week ago) by adam
Branches: MAIN
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +2 -2 lines
py-tldextract: updated to 3.4.3

3.4.3 (2023-05-18)

* Bugfixes
  * Speed up 10-15% over all inputs
    * Refactor `suffix_index()` to use a trie
  * Docs
    * Adopt PEP257 doc style

3.4.2 (2023-05-16)

* Bugfixes
  * Speed up 10-40% on "average" inputs, and even more on pathological inputs, like long subdomains
    * Optimize `suffix_index()`
    * Optimize netloc extraction

Revision 1.18: download - view: text, markup, annotated - select for diffs
Thu Apr 27 08:21:07 2023 UTC (2 years ago) by adam
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -2 lines
py-tldextract: updated to 3.4.1

3.4.1 (2023-04-26)

* Bugfixes
  * Fix Pyright not finding tldextract public interface
  * Fix various Pyright checks
  * Use SPDX license identifier
  * Support Python 3.11
* Docs
  * Add FAQ about private domains
* Misc.
  * Update bundled snapshot
  * Fix lint in newer pylint

Revision 1.17: download - view: text, markup, annotated - select for diffs
Wed Oct 5 07:59:22 2022 UTC (2 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -2 lines
py-tldextract: updated to 3.4.0

3.4.0 (2022-10-04)

* Features
  * Add method `extract_urllib` to extract from a `urllib.parse.{ParseResult,SplitResult}`
* Bugfixes
  * Fix internal type-var error, in newer versions of mypy

Revision 1.16: download - view: text, markup, annotated - select for diffs
Mon Jul 11 06:15:10 2022 UTC (2 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2 lines
py-tldextract: updated to 3.3.1

3.3.1 (2022-07-08)

* Bugfixes
  * Fix documented types, in README and in exception message
* Misc.
  * Format source code

Revision 1.15: download - view: text, markup, annotated - select for diffs
Tue May 10 07:24:45 2022 UTC (2 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -2 lines
py-tldextract: updated to 3.3.0

3.3.0

* Features
  * Add CLI flag `--suffix_list_url` to set the suffix list URL(s) or source file(s)
  * Add CLI flag `--no_fallback_to_snapshot` to not fall back to the snapshot
  * Add alias `--include_psl_private_domains` for CLI flag `--private_domains`
* Bugfixes
  * Handle more internationalized domain name dots
* Misc.
  * Update bundled snapshot
  * Add basic CLI test coverage

Revision 1.14: download - view: text, markup, annotated - select for diffs
Tue Apr 26 10:35:44 2022 UTC (3 years ago) by adam
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +3 -3 lines
py-tldextract: updated to 3.2.1

3.2.1 (2022-04-11)

* Bugfixes
  * Fix incorrect namespace used for caching function returns
  * Remove redundant encode
  * Remove redundant lowercase
  * Remove unused `try`/`except` path
  * Add types to the private API (disallow untyped calls and defs)
  * Rely on `python_requires` instead of runtime check
* Docs
  * Fix docs with updated types
  * Fix link in Travis CI badge
  * Rewrite documentation intro
  * Remove unnecessary subheading
  * Unify case


3.2.0 (2022-02-20)

* Features
    * Add types to the public API
* Bugfixes
    * Add support for Python 3.10
    * Drop support for EOL Python 3.6
    * Remove py2 tag from wheel
    * Remove extra backtick in README

Revision 1.13: download - view: text, markup, annotated - select for diffs
Wed Jan 5 15:41:18 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +4 -2 lines
python: egg.mk: add USE_PKG_RESOURCES flag

This flag should be set for packages that import pkg_resources
and thus need setuptools after the build step.

Set this flag for packages that need it and bump PKGREVISION.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:54:33 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.11: download - view: text, markup, annotated - select for diffs
Wed Sep 15 07:29:07 2021 UTC (3 years, 7 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
py-tldextract: updated to 3.1.2

3.1.2 (2021-09-01)

* Misc.
    * Only run pylint in Tox environments, i.e. CI, not by default in tests

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sun Aug 29 08:44:22 2021 UTC (3 years, 8 months ago) by adam
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +3 -3 lines
py-tldextract: updated to 3.1.1

3.1.1:
* Bugfixes
    * Support Python 3.9
    * Drop support for EOL Python 3.5

Revision 1.9: download - view: text, markup, annotated - select for diffs
Fri Nov 27 19:36:27 2020 UTC (4 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +5 -5 lines
py-tldextract: updated to 3.1.0

3.1.0 (2020-11-22)

* Features
    * Prefer to cache in XDG cache directory in user folder, vs. in Python install folder
* Bugfixes
    * Fix `AttributeError` on `--update`

3.0.2 (2020-10-24)

* Bugfixes
    * Catch permission error when making cache dir, as well as cache file

3.0.1 (2020-10-21)

* Bugfixes
    * Fix `tlds` property `AttributeError`
    * Allow `include_psl_private_domains` in global `extract` too

3.0.0 (2020-10-20)

No changes since 3.0.0.rc1.

3.0.0.rc1 (2020-10-12)

This release fixes the long standing bug that public and private suffixes were
generated separately and could not be switched at runtime,

* Breaking Changes
    * Rename `cache_file` to `cache_dir` as it is no longer a single file but a directory
    * Rename CLI arg also, from `--cache_file` to `--cache_dir`
    * Remove Python 2.7 support
* Features
    * Can pass `include_psl_private_domains` on call, not only on construction
    * Use filelocking to support multi-processing and multithreading environments
* Bugfixes
    * Select public or private suffixes at runtime
* Removals
    * Do not `debug` log the diff during update

Revision 1.8: download - view: text, markup, annotated - select for diffs
Mon Aug 24 05:20:00 2020 UTC (4 years, 8 months ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
py-tldextract: needs setuptools-scm as build dependency

also does not need setuptools as runtime dependency

Revision 1.7: download - view: text, markup, annotated - select for diffs
Fri Aug 21 12:37:48 2020 UTC (4 years, 8 months ago) by adam
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
py-tldextract: updated to 2.2.3

2.2.3:

Bugfixes
* Fix concurrent access to cache file when using tldextract in multiple threads
* Relocate version number, to avoid costly imports
* Catch `IndexError` caused by upstream punycode bug
* Drop support for EOL Python 3.4
* Explain warning better

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sat May 16 18:00:31 2020 UTC (4 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +4 -2 lines
pytest from versioned depends

Revision 1.5: download - view: text, markup, annotated - select for diffs
Thu Nov 14 18:04:00 2019 UTC (5 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +4 -3 lines
py-tldextract: updated to 2.2.2

2.2.2:
* Bugfixes
    * Catch file not found
    * Use pkgutil instead of pkg_resources
    * Performance: avoid recomputes, a regex, and a partition
* Misc.
    * Update LICENSE from GitHub template
    * Fix warning about literal comparison
    * Modernize testing
        * Use the latest pylint that works in Python 2
        * Appease pylint with the new rules
        * Support Python 3.8-dev
        * Drop support for EOL Python 3.4

Revision 1.4: download - view: text, markup, annotated - select for diffs
Wed Mar 6 08:48:31 2019 UTC (6 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +8 -7 lines
py-tldextract: updated to 2.2.1

2.2.1:
Bugfixes
Ignore case on punycode prefix check
Drop support for EOL Python 2.6
Improve sundry doc and README bits

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sat Oct 28 06:54:23 2017 UTC (7 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +14 -7 lines
py-tldextract: updated to version 2.2.0

2.2.0
Unknown changes

Revision 1.2: download - view: text, markup, annotated - select for diffs
Thu Jun 22 09:34:47 2017 UTC (7 years, 10 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +7 -6 lines
2.1.0:
Add fqdn convenience property
Add ipv4 convenience property

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon Nov 21 11:49:55 2016 UTC (8 years, 5 months ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Import net/py-tldextract 2.0.2.

tldextract accurately separates the gTLD or ccTLD (generic or
country code top-level domain) from the registered domain and
subdomains of a URL.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>