The NetBSD Project

CVS log for pkgsrc/net/py-s3cmd/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / net / py-s3cmd

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.7: download - view: text, markup, annotated - select for diffs
Fri Jan 12 05:32:52 2024 UTC (10 months, 4 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, HEAD
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +4 -4 lines
py-s3cmd: updated to 2.4.0

s3cmd-2.4.0

* Added "setversioning" command for versioning configuration (Kuan-Chun Wang)
* Added "settagging", "gettagging", and "deltagging" commands for bucket/object tagging (Kuan-Chun Wang)
* Added "setobjectretention" and "setobjectlegalhold" commands (Etienne Adam/Withings SAS)
* Added "setownership" and "setblockpublicaccess" commands
* Added "cfinval" command to request Cloudfront to invalidate paths
* Added "--keep-dirs" option to have the folder structure preserved on remote side
* Added --skip-destination-validation option for "setnotification" command (Kuan-Chun Wang)
* Added "--max-retries" flag and "max_retries" config option
* Added FIPS support (Michael Roth)
* Added "object ownership" and block public access" values to "info" command output for buckets
* Added to "ls" command a "DIROBJ" tag for directory objects in S3 remote
* Added server profiles to run-tests.py to skip tests depending on the server type
* Fixed "TypeError: sequence item 1: expected str instance, bytes found" error with Python 3.12
* Fixed a missing return for "object_batch_delete" of S3.py  (James Hewitt)
* Fixed "object is not callable" error because of md5 FIPS test
* Fixed "compute_content_md5 is not defined" error for "setversioning"
* Fixed list objects to use NextMarker when only prefixes are returned (Albin Parou)
* Fixed upload to not retry when an S3 compatible server is full
* Fixed recursive delete of objects named with whitespace
* Fixed the mime type when uploading directories to be "application/x-directory"
* Fixed "string indices must be integers" error for sync when in dry-run mode
* Fixed SignatureDoesNotMatch error when modifying an object on Cloudflare R2
* Fixed Cloudfront invalidation issue for paths with wildcard or special characters
* Fixed Cloudfront crash because of error reporting for retries
* Fixed Cloudfront "unable to parse URL" error
* Improved the handling of "empty" files on the remote side to sync with local folders
* Improved "abortmp" command by requiring an object to avoid bad accidents when using Ceph (Joshua Haas)
* Improved file download by retrying when encountering SlowDown or TooManyRequests errors (Robin Geiger)
* Improved error messages in case of connection error or host unreachable
* Improved error messages to be more explicit for upload errors after retries
* Improved remote2local attributes setting code
* Improved remote2local with more explicit error messages when setting attributes
* Improved remote2local output messages by using the "mkdir" prefix instead of "make dir"
* Improved the SortedDict class
* Improved run-test.py by using "--include" when calling Curl instead of "-include" (Matthew James Kraai)
* Improved GitHub CI by enabling pip cache in actions/setup-python (Anton Yakutovich)
* Improved GitHub CI by adding a "codespell" check on push and PRs (Yaroslav Halchenko)
* Updated GitHub CI tests to use more recent versions of Minio and Python
* Upgraded GitHub actions (Anton Yakutovich)
* Cleanup and update of copyright headers, docs, comments and setup.py
* Cleanup to fix "invalid escape sequence" syntax warnings
* Many other bug fixes and cleanups

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sat Aug 5 06:06:07 2023 UTC (16 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +4 -4 lines
py-s3cmd: updated to 2.3.0

s3cmd-2.3.0      - 2022-10-03
===============
* Added "getnotification", "setnotification", and "delnotification" commands for notification policies (hrchu)
* Added support for AWS_STS_REGIONAL_ENDPOINTS
* Added ConnectionRefused [111] exit code to handle connection errors (Salar Nosrati-Ershad)
* Added support for IMDSv2. Should work automatically on ec2 (Anthony Foiani)
* Added --list-allow-unordered to list objects unordered. Only supported by Ceph based s3-compatible services
* Fixed --exclude dir behavior for python >= 3.6 (Daniil Tararukhin)
* Fixed Cloudfront invalidate retry issue (Yuan-Hsiang Lee)
* Fixed 0 byte cache files crashing s3cmd
* Fixed --continue behavior for the "get" command
* Fixed unicode issue with fixbucket
* Fixed CannotSendRequest and ConnectionRefusedError errors at startup
* Fixed error reporting for object info when the object does not exist
* Fixed "setup.py test" to do nothing to avoid failure that could be problematic for distribution packaging
* Improved expire command to use Rule/Filter/Prefix for LifecycleConfiguration
* Improved PASS/CHECK/INCLUDE/EXCLUDE debug log messages
* Improved setup.py with python 3.9 and 3.10 support info(Ori Avtalion)
* Many other bug fixes


s3cmd-2.2.0      - 2021-09-27
===============
* Added support for metadata modification of files bigger than 5 GiB
* Added support for remote copy of files bigger than 5 GiB using MultiPart copy (Damian Martinez, Florent Viard)
* Added progress info output for multipart copy and current-total info in output for cp, mv and modify
* Added support for all special/foreign character names in object names to cp/mv/modify
* Added support for SSL authentication (Aleksandr Chazov)
* Added the http error 429 to the list of retryable errors
* Added support for listing and resuming of multipart uploads of more than 1000 parts
* Added time based expiration for idle pool connections in order to avoid random broken pipe errors
* Added support for STS webidentity authentication (ie AssumeRole and AssumeRoleWithWebIdentity) (Samskeyti, Florent Viard)
* Added support for custom headers to the mb command
* Improved MultiPart copy to preserve acl and metadata of objects
* Improved the server errors catching and reporting for cp/mv/modify commands
* Improved resiliency against servers sending garbage responses
* Improved remote copy to have consistent copy of metadata in all cases: multipart or not, aws or not
* Improved security by revoking public-write acl when private acl is set
* Improved speed when running on an EC2 instance
* Reduced connection_max_age to 5s to avoid broken pipes as AWS closes https conns after around 6s
* Ensure that KeyboardInterrupt are always properly raised
* Changed sized of multipart copy chunks to 1 GiB
* Fixed ValueError when using more than one ":" inside add_header in config file
* Fixed extra label issue when stdin used as source of a MultiPart upload
* Fixed remote copy to allow changing the mime-type (ie content-type) of the new object
* Fixed remote_copy to ensure that meta-s3cmd-attrs will be set based on the real source and not on the copy source
* Fixed deprecation warnings due to invalid escape sequences (Karthikeyan Singaravelan)
* Fixed getbucketinfo that was broken when the bucket lifecycle uses the filter element (Liu Lan)
* Fixed RestoreRequest XML namespace URL
* Fixed PARTIAL exit code that was not properly set when needed for object_get
* Fixed a possible inifinite loop when a file is truncated during hashsum or upload
* Fixed report_exception wrong error when LANG env var was not set
* Fixed wrong wiki url in error messages (Alec Barrett)
* Py3: Fixed an AttributeError when using the "files-from" option
* Py3: Fixed compatibility issues due to the removal of getchildren() from ElementTree in python 3.9
* Py3: Fixed compatibility issues due to the removal of encodestring() in python 3.9
* Fixed a crash when the AWS_ACCESS_KEY env var is set but not AWS_SECRET_KEY
* Cleanup of check_md5 (Riccardo Magliocchetti)
* Removed legacy code for dreamhost that should be necessary anymore
* Migrated CI tests to use github actions (Arnaud Jaffre)
* Improved README with a link to INSTALL.md (Sia Karamalegos)
* Improved help content (Dmitrii Korostelev, Roland Van Laar)
* Improvements for setup and build configurations
* Many other bug fixes


s3cmd-2.1.0      - 2020-04-07
===============
* Changed size reporting using k instead of K as it a multiple of 1024
* Added "public_url_use_https" config to generate public url using https
* Added option to make connection pooling configurable and improvements (Arto Jantunen)
* Added support for path-style bucket access to signurl (Zac Medico)
* Added docker configuration and help to run test cases with multiple Python versions (Doug Crozier)
* Relaxed limitation on special chars for --add-header key names
* Fixed all regions that were automatically converted to lower case (Harshavardhana)
* Fixed size and alignment of DU and LS output reporting
* Fixes for SignatureDoesNotMatch error when host port 80 or 443 is specified, due to stupid servers
* Fixed the useless retries of requests that fail because of ssl cert checks
* Fixed a possible crash when a file disappears during cache generation
* Fixed unicode issues with IAM
* Fixed unicode errors with bucked Policy/CORS requests
* Fixed unicode issues when loading aws_credential_file
* Fixed an issue with the tenant feature of CephRGW. Url encode bucket_name for path-style requests
* Fixed signature v2 always used when bucket_name had special chars
* Allow to use signature v4 only, even for commands without buckets specified
* Fixed small open file descriptor leaks.
* Py3: Fixed hash-bang in headers to not force using python2 when setup/s3cmd/run-test scripts are executed directly.
* Py3: Fixed unicode issues with Cloudfront
* Py3: Fixed http.client.RemoteDisconnected errors
* Py3: Fixed 'dictionary changed size during iteration' error when using a cache-file
* Py3: Fixed the display of file sizes (Vlad Presnyak)
* Py3: Python 3.8 compatibility fixes (Konstantin Shalygin)
* Py2: Fixed unicode errors sometimes crashing remote2remote sync
* Added s3cmd.egg-info to .gitignore (Philip Dubé)
* Improved run-test script to not use hard-coded bucket names
* Renamed INSTALL to INSTALL.md and improvements (Nitro, Prabhakar Gupta)
* Improved the restore command help (Hrchu)
* Updated the storage-class command help with the recent aws s3 classes
* Fixed typo in the --continue-put help message (Pengyu Chen)
* Fixed typo
* Improvements for setup and build configurations
* Many other bug fixes


s3cmd-2.0.2      - 2018-07-15
===============
* Fixed unexpected timeouts encountered during requests or transfers due to AWS strange connection short timeouts
* Fixed a throttle issue slowing down too much transfers in some cases
* Added support for $AWS_PROFILE
* Added clarification comment for the socket_timeout configuration value OS limit
* Avoid distutils usage at runtime (Matthias Klose)
* Python 2 compatibility: Fixed import error of which with fallback code (Gianfranco Costamagna)
* Fixed Python 3 bytes string encoding when getting IAM credentials (Alexander Allakhverdiyev)
* Fixed handling of config tri-state bool values (like acl_public) (Brian C. Lane)
* Fixed V2 signature when restore command is used (Jan Kasiak)
* Fixed setting full_control on objects with public read access (Matthew Vernon)
* Fixed a bug when only one path is supplied with Cloudfront. (Mikael Svensson)
* Fixed signature errors with 'modify' requests (Radek Simko)
* Fixed - Fix setacl command exception (Robert Moucha)
* Fixed error reporting if deleting a source object failed after a move
* Many other bug fixes

Important info: AWS S3 doesn't allow anymore uppercases and underscores in bucket names since march 1, 2018


s3cmd-2.0.1      - 2017-10-21
===============
* Support for Python 3 is now stable
* Fixed signature issues due to upper cases in hostname
* Improved support for Minio Azure gateway (Julien Maitrehenry, Harshavardhana)
* Added signurl_use_https option to use https prefix for signurl (Julien Recurt)
* Fixed a lot of remaining issues and regressions for Python 3
* Fixed --configure option with Python 3
* Fixed non string cmdline parameters being ignored
* Windows support fixes
* Don't force anymore to have a / on last parameter for the "modify" command
* Removed the python3 support warning
* Detect and report error 403 in getpolicy for info command
* Added a specific error message when getting policy by non owner
* Many other bug fixes


s3cmd-2.0.0      - 2017-06-26
===============
* Added support for Python 3 (Shaform, Florent Viard)
* Added getlifecycle command (Daniel Gryniewicz)
* Added --cf-inval for invalidating multiple CF distributions (Joe Mifsud)
* Added --limit to "ls" and "la" commands to return the specified number of objects (Masashi Ozawa)
* Added --token-refresh and --no-token-refresh and get the access token from the environment (Marco Jakob)
* Added --restore-priority and --restore-days for S3 Glacier (Robert Palmer)
* Fixed requester pays header with HEAD requests  (Christian Rodriguez)
* Don't allow mv/cp of multiple files to single file (Guy Gur-Ari)
* Generalize wildcard certificate forgiveness (Mark Titorenko)
* Multiple fixes for SSL connections and proxies
* Added support for HTTP 100-CONTINUE
* Fixes for s3-like servers
* Big cleanup and many unicode fixes
* Many other bug fixes

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Oct 26 11:06:42 2021 UTC (3 years, 1 month ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines

net: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Not committed (merge conflicts...):

net/radsecproxy/distinfo

The following distfiles could not be fetched (fetched conditionally?):

./net/citrix_ica/distinfo citrix_ica-10.6.115659/en.linuxx86.tar.gz
./net/djbdns/distinfo dnscache-1.05-multiple-ip.patch
./net/djbdns/distinfo djbdns-1.05-test28.diff.xz
./net/djbdns/distinfo djbdns-1.05-ignoreip2.patch
./net/djbdns/distinfo djbdns-1.05-multiip.diff
./net/djbdns/distinfo djbdns-cachestats.patch

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Oct 7 14:42:33 2021 UTC (3 years, 2 months ago) by nia
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -2 lines
net: Remove SHA1 hashes for distfiles

Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed Nov 4 00:35:32 2015 UTC (9 years, 1 month ago) by agc
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -1 lines
Add SHA512 digests for distfiles for net category

Problems found with existing digests:
	Package haproxy distfile haproxy-1.5.14.tar.gz
	159f5beb8fdc6b8059ae51b53dc935d91c0fb51f [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]

Problems found locating distfiles:
	Package bsddip: missing distfile bsddip-1.02.tar.Z
	Package citrix_ica: missing distfile citrix_ica-10.6.115659/en.linuxx86.tar.gz
	Package djbdns: missing distfile djbdns-1.05-test25.diff.bz2
	Package djbdns: missing distfile djbdns-cachestats.patch
	Package djbdns: missing distfile 0002-dnscache-cache-soa-records.patch
	Package gated: missing distfile gated-3-5-11.tar.gz
	Package owncloudclient: missing distfile owncloudclient-2.0.2.tar.xz
	Package poink: missing distfile poink-1.6.tar.gz
	Package ra-rtsp-proxy: missing distfile rtspd-src-1.0.0.0.tar.gz
	Package ucspi-ssl: missing distfile ucspi-ssl-0.70-ucspitls-0.1.patch
	Package waste: missing distfile waste-source.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Mon Feb 6 00:25:42 2012 UTC (12 years, 10 months ago) by jakllsch
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +4 -4 lines
Update to s3cmd-1.0.1, with permission from ver.

Changes since 0.9.9.91:

s3cmd 1.0.1 - 2011-06-10
===========
* Increased socket_timeout from 10 sec to 5 min
* Improved compatibility with Python 2.4 on RHEL 5 / CentOS 5

s3cmd 1.0.0 - 2011-01-18
===========
* [sync] now supports --no-check-md5
* Network connections now have 10s timeout
* [sync] now supports bucket-to-bucket synchronisation
* Added [accesslog] command.
* Added access logging for CloudFront distributions using [cfmodify --log]
* Added --acl-grant and --acl-revoke [Timothee Groleau]
* Allow s3:// URI as well as cf:// URI as a distribution
  name for most CloudFront related commands.
* Support for Reduced Redundancy Storage (--reduced-redundancy)
* Follow symlinks in [put] and [sync] with --follow-symlinks
* Support for CloudFront DefaultRootObject [Luke Andrew]

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon Jul 19 16:42:12 2010 UTC (14 years, 4 months ago) by ver
Branches: MAIN
CVS tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Add s3cmd from http://s3tools.org/:
S3cmd lets you copy files from/to Amazon S3 (Simple Storage Service) using a
simple to use command line client. Supports rsync-like backup, GPG encryption,
and more. Also supports management of Amazon's CloudFront content delivery
network.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>