The NetBSD Project

CVS log for pkgsrc/net/py-paho-mqtt/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / net / py-paho-mqtt

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.8: download - view: text, markup, annotated - select for diffs
Wed Jun 19 14:03:04 2024 UTC (10 months, 1 week ago) by gdt
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, HEAD
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +4 -4 lines
net/py-paho-mqtt: Update to 2.1.0

Tested with all 0 packages in pkgsrc that depend on this package!  But
seriously, this has been on hold since 2.0.0 in February because of
the breaking changes, and it's been long enough that maintained
projects will have adapted.

packaging: convert to wheel.mk

Upstream NEWS content:

v2.1.0

    Make transition from 1.x to 2.x version smoother (Closes #831)

    Add support for Unix socket (Closes #829)


v2.0.0

This release include breaking change. See https://eclipse.dev/paho/files/paho.mqtt.python/html/migrations.html for more details on how to upgrade.

This release also introduce new documentation available online at https://eclipse.dev/paho/files/paho.mqtt.python/html/index.html

    BREAKING Added callback_api_version. This break ALL users of paho-mqtt Client class.
    See migrations.rst for details on how to upgrade.
    tl; dr; add CallbackAPIVersion.VERSION1 to first argument of Client()

    BREAKING connect_srv changed it signature to take an additional bind_port parameter.
    This is a breaking change, but in previous version connect_srv was broken anyway.
    Closes #493.

    BREAKING Remove some deprecated argument and method:
        max_packets argument in loop(), loop_write() and loop_forever() is removed
        force argument in loop_stop() is removed
        method message_retry_set() is removed

    BREAKING Remove the base62, WebsocketWrapper and ConnectionState, as user shouldn't directly use them.

    Possible breaking change: Add properties to access most Client attribute. Closes #764.
    Since this add new properties like logger, if a sub-class defined logger, the two logger
    will conflict.

    Add version 2 of user-callback which allow to access MQTTv5 reason code & properties that were
    missing from on_publish callback. Also it's more consistent in parameter order or between
    MQTTv3 and MQTTv5.

    Add types to Client class, which caused few change which should be compatible.

    Known risk of breaking changes:
        Use enum for returned error code (like MQTT_ERR_SUCCESS). It use an IntEnum
        which should be a drop-in replacement. Excepted if someone is doing "rc is 0" instead of "rc == 0".
        reason in on_connect callback when using MQTTv5 is now always a ReasonCode object. It used to possibly be
        an integer with the value 132.
        MQTTMessage field "dup" and "retain" used to be integer with value 0 and 1. They are now boolean.

    Add support for ALPN protocols on TLS connection. Closes #790 & #648.

    Add on_pre_connect() callback, which is called immediately before a
    connection attempt is made.

    Allow to manually ack QoS > 0 messages. Closes #753 & #348.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue Oct 26 11:06:40 2021 UTC (3 years, 6 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines

net: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Not committed (merge conflicts...):

net/radsecproxy/distinfo

The following distfiles could not be fetched (fetched conditionally?):

./net/citrix_ica/distinfo citrix_ica-10.6.115659/en.linuxx86.tar.gz
./net/djbdns/distinfo dnscache-1.05-multiple-ip.patch
./net/djbdns/distinfo djbdns-1.05-test28.diff.xz
./net/djbdns/distinfo djbdns-1.05-ignoreip2.patch
./net/djbdns/distinfo djbdns-1.05-multiip.diff
./net/djbdns/distinfo djbdns-cachestats.patch

Revision 1.6: download - view: text, markup, annotated - select for diffs
Fri Oct 22 13:44:40 2021 UTC (3 years, 6 months ago) by gdt
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +4 -4 lines
net/py-paho-mqtt: Update to 1.6.1

Upstream changes:

1.6.1:
  fix python27, broken in 1.6.0

1.6.0:

  - Big performance improvement when receiving large payloads,
  particularly for SSL. Closes #571,
  - Add basic MQTT v5 support to the subscribe and publish helper
  functions. Closes #575.
  - Changed default TLS version to 1.2 instead of 1.0.
  - Remove _out_packet_mutex and _current_out_packet_mutex and convert
  the _out_packet queue use to thread safe (simplifies the internals)
  - Callbacks can now be applied to client instances using decorators.
  - The `rc` parameter in the `on_disconnect` callback now has
  meaningful values in the case of an error. Closes #441.
  - Remove periodic retry checks for outgoing messages with QoS>0. This
  means that outgoing messages will only be retried on the client
  reconnecting to the server. They will *not* be retried when the client
  is still connected.
  - MQTTMessageInfo.wait_for_publish() and
  MQTTMessageInfo.is_published() will now raise exceptions if called
  when the publish call produced an error. Closes #550.
  - Raise exceptions when attempting to set MQTT v5 properties to
  forbidden values. Closes #586.
  - PUBACK messages are now sent to the broker only after the on_message
  callback has - Add timeout to
  MQTTMessageInfo:wait_for_publish().returned.
  - Add timeout to MQTTMessageInfo:wait_for_publish().
  - Removed ancient Mosquitto compatibility class.

  bugfixes

Revision 1.5: download - view: text, markup, annotated - select for diffs
Thu Oct 21 11:36:04 2021 UTC (3 years, 6 months ago) by adam
Branches: MAIN
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +4 -4 lines
py-paho-mqtt: updated to 1.6.0

1.6.0:
Unknown changes

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Oct 7 14:42:31 2021 UTC (3 years, 6 months ago) by nia
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -2 lines
net: Remove SHA1 hashes for distfiles

Revision 1.3: download - view: text, markup, annotated - select for diffs
Thu Oct 15 20:22:48 2020 UTC (4 years, 6 months ago) by gdt
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +5 -5 lines
net/py-paho-mqtt: Update to 1.5.1

Upstream changes: bugfixes

Revision 1.2: download - view: text, markup, annotated - select for diffs
Thu Oct 31 00:32:16 2019 UTC (5 years, 5 months ago) by gdt
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +5 -5 lines
net/py-paho-mqtt: Update to 1.5.0

Upstream does not include NEWS in the tarball, but on
the web it is possible to find the following:

v1.5.0 - 2019-10-30
===================

* Add support for clean_session on subscribe helper. Closes #219
* Add support for non-standard bridge connection. Closes #282
* Fix hang with QoS 2 message and clean_session = False. The fix replace hang
  with message DROP. See README for known limitation. Closes #284 and #286
* Fix connection establishement timeout. Closes #291 and #288
* Add support for connecting through a proxy. Closes #315
* Add MQTT v5 support. Closes #334
* Improve error message when sending queue is full. Closes #378
* Improve error handling during initialization on edge case. Closes #387 and #388
* Allow to specify local client port used (similar to bind_address). Closes #390
* Add method is_connected to know if MQTT connection is established. Closes #414
* Set connection timeout to keepalive. Closes #425

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sat Jul 20 23:40:05 2019 UTC (5 years, 9 months ago) by gdt
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
net: Add py-paho-mqtt version 1.4.0

The Paho Python Client provides a client class with support for both
MQTT v3.1 and v3.1.1 on Python 2.7 or 3.x. It also provides some
helper functions to make publishing one off messages to an MQTT server
very straightforward.

Packaged in wip by Kamel Derouiche.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>