The NetBSD Project

CVS log for pkgsrc/net/py-netaddr/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / net / py-netaddr

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.15: download - view: text, markup, annotated - select for diffs
Fri Jun 7 11:04:13 2024 UTC (6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, HEAD
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +4 -4 lines
py-netaddr: updated to 1.3.0

Release: 1.3.0

Added:

* Add partial address expansion in :class:`IPNetwork` via the ``expand_partial`` switch,
  this enables opting into pre-1.1.0 behavior

Fixed:

* Fix running the test suite on musl systems
* Fix :class:`IPAddress` IPv6 parsing with :data:`ZEROFILL` enabled
* Fix handling of the :data:`NOHOST` flag in the :class:`IPNetwork` copy constructor

Revision 1.14: download - view: text, markup, annotated - select for diffs
Fri Feb 23 11:35:58 2024 UTC (9 months, 2 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +4 -4 lines
py-netaddr: updated to 1.2.1

Release: 1.2.1

Fixed:

* Fix bad version 1.2.0 upload to PyPI – now yanked. No changes to the package.


Release: 1.2.0

Added:

* Add CLI tool subcommand to display :ref:`cli-network-info`.

Changed:

* Support running :ref:`interactive-shell` without IPython installed.

Fixed:

* Explicitly raise ``TypeError`` is a non-string value is passed to :func:`valid_ipv4`
  or :func:`valid_ipv6`.

Revision 1.13: download - view: text, markup, annotated - select for diffs
Fri Feb 16 22:18:45 2024 UTC (9 months, 3 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +4 -4 lines
py-netaddr: updated to 1.1.0

1.1.0
-----

Date: 2024-02-15

Added:

* Add the required Python version to the package metadata (GH :issue:`365`).
* Add :func:`expand_partial_ipv4_address` to the public API.

Fixed:

* Fix ``IPNetwork(...) in IPRange(...)`` false negatives (GH :issue:`157`).
* Fix a few :class:`IPNetwork` slicing edge cases (GH :issue:`214`).
* Fix support for partial IP addresses accidentally left in :class:`IPNetwork` in 1.0.0.

  When I removed the ``implicit_prefix`` switch I missed the fact that there was some
  partial IPv4 address expansion triggered unconditionally.

  If you need the old behavior use :func:`expand_partial_ipv4_address`.

  Related GH issue: :issue:`110`.
* Fixed an incorrect license classifier in the package metadata.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Wed Feb 14 16:32:29 2024 UTC (9 months, 3 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +4 -4 lines
py-netaddr: updated to 1.0.0

Release: 1.0.0
--------------

Date: 2024-02-10

Removed:

* Drop support for Python versions lower than 3.7.
* Remove the flag shorthands: ``N``, ``P`` and ``Z``. Use :data:`NOHOST`, :data:`INET_PTON`
  and :data:`ZEROFILL` instead.
* Remove abbreviated CIDR format support in :class:`IPNetwork` (``implicit_prefix=True``),
  use :func:`cidr_abbrev_to_verbose` if you need this behavior.
* Remove the ``IPAddress.is_private`` method.

  There are more precise replacements for subset of the addresses that used to handled by ``is_private``:

  * :meth:`IPAddress.is_link_local`
  * :meth:`IPAddress.is_ipv4_private_use`
  * :meth:`IPAddress.is_ipv6_unique_local`
  * :meth:`IPAddress.is_global`

  The following address blocks used to be handled by ``is_private`` have no dedicated
  convenience methods and you'll have to handle them manually or request a method
  addition:

  * ``100.64.0.0/10`` – Shared Address Space
  * ``192.0.0.0/24`` – IETF Protocol Assignments (watch out – there are exceptions in there)
  * ``198.18.0.0/15`` – Benchmarking
  * ``239.0.0.0``-``239.255.255.255`` – ``240.0.0.0/4`` is Reserved, ``239.0.0.0/8`` – unclear

Changed:

* Stop accepting leading zeros when parsing IPv4 addresses in :data:`INET_PTON` mode
  (it's been allowed on some platforms).

  If you need to allow and discard leading zeros use the :data:`ZEROFILL` flag.

  This change will affect implicit conversions from ``str`` in all relevant contexts. If you need
  to control the IPv4 parsing mode construct :class:`IPAddress` objects explicitly.
* Stop parsing IPv4 addresses permissively (``inet_aton()``-like) by default.

  :data:`INET_PTON` is the default mode.

  If you need to be permissive and parse using ``inet_aton()`` semantics use the
  :data:`INET_ATON` flag.

  This change will affect implicit conversions from ``str`` in all relevant contexts. If you
  need to control the IPv4 parsing mode construct :class:`IPAddress` objects explicitly.
* Apply the two changes above to :func:`valid_ipv4` as well.
* Update the address databases to the 2024-02-10 versions.

Fixed:

* Return ``False`` instead of raising :exc:`AddrFormatError` when an empty string is passed
  to :func:`valid_ipv4` or :func:`valid_ipv6`.
* Fix handling of ``dialect`` provided to :class:`EUI` during copy-construction.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Wed Jan 3 06:53:25 2024 UTC (11 months, 1 week ago) by adam
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +4 -4 lines
py-netaddr: updated to 0.10.1

Release: 0.10.1

Fixed:

* Get rid of some warnings

Deprecated:

* Deprecate the flag shorthands: ``N``, ``P`` and ``Z``. Use :data:`NOHOST`, :data:`INET_PTON`
  and :data:`ZEROFILL` instead.
* Deprecate importing objects from ``netaddr`` subpackages. Only importing things from the
  top-level ``netaddr`` namespace is supported, everything else is considered private.

  This has already been the case but we can use a reminder.
* Deprecate permissive-by-default IPv4 parsing in :func:`valid_ipv4`. The ``inet_pton()``
  semantics (with leading zeros always disallowed) will become the default. Use :data:`INET_ATON`
  and/or :data:`ZEROFILL` flags if you need the legacy behavior.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Mon Jan 1 11:43:26 2024 UTC (11 months, 1 week ago) by adam
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +4 -4 lines
py-netaddr: updated to 0.10.0

Release: 0.10.0

Added:

* Add an :data:`INET_ATON` flag to explicitly request ``inet_aton()`` IPv4 parsing semantics
  from :class:`IPAddress`.
* Add an :meth:`IPAddress.is_ipv4_private_use` convenience method.
* Add an :meth:`IPAddress.is_global` convenience method to allow determining if an address is
  considered globally reachable.
* Add an :meth:`IPAddress.is_ipv6_unique_local` convenience method.

Fixed:

* Improve Python 3.13 compatibility, thank you John Eckersberg.

Deprecated:

* Deprecate Python 3.7 support.
* Deprecate abbreviated CIDR format support in :class:`IPNetwork`
  (``implicit_prefix=True``).
* Deprecate accepting leading zeros when parsing IPv4 addresses in :data:`INET_PTON` mode
  (it's been allowed on some platforms).

  If you need to allow and discard leading zeros use the :data:`ZEROFILL` flag.

  This change will implicit conversions from ``str`` in all relevant contexts. If you need
  to control the IPv4 parsing mode construct :class:`IPAddress` objects explicitly.
* Deprecate parsing IPv4 addresses permissively (``inet_aton()``-like) by default.

  :data:`INET_PTON` will become the default mode.

  If you need to be permissive and parse using ``inet_aton()`` semantics use the
  :data:`INET_ATON` flag.

  This change will implicit conversions from ``str`` in all relevant contexts. If you need
  to control the IPv4 parsing mode construct :class:`IPAddress` objects explicitly.
* Deprecate the :meth:`IPAddress.is_private` method. Migration instructions in the
  documentation.

Other:

* Raise an exception if invalid flags are passed to ``IPAddress``, ``IPNetwork`` or ``IPRange``.
* Improve the documentation substantially.
* Update the DB files to the latest versions (2023-12-23).

Revision 1.9: download - view: text, markup, annotated - select for diffs
Wed Sep 20 07:29:14 2023 UTC (14 months, 3 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +4 -4 lines
py-netaddr: updated to 0.9.0

Release: 0.9.0

Added:

* Add hash capabilities to OUI

Fixed:

* **Backwards incompatible:** Handle RFC 6164 IPv6 addresses (don't reserve first IP
  address in point-to-point subnets) ($267, Damien Claisse)
* **Technically backwards incompatible:** Fix for is_loopback behaviour – consider
  ``IPNetwork('::1/128')`` to be loopback
* Include tutorials in source distributions
* Fix a documentation typo
* Fix print syntax in the documentation to be Python 3 compatible
* Fix the Sphinx syntax in the documentation

Revision 1.8: download - view: text, markup, annotated - select for diffs
Tue Oct 26 11:06:40 2021 UTC (3 years, 1 month ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines

net: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Not committed (merge conflicts...):

net/radsecproxy/distinfo

The following distfiles could not be fetched (fetched conditionally?):

./net/citrix_ica/distinfo citrix_ica-10.6.115659/en.linuxx86.tar.gz
./net/djbdns/distinfo dnscache-1.05-multiple-ip.patch
./net/djbdns/distinfo djbdns-1.05-test28.diff.xz
./net/djbdns/distinfo djbdns-1.05-ignoreip2.patch
./net/djbdns/distinfo djbdns-1.05-multiip.diff
./net/djbdns/distinfo djbdns-cachestats.patch

Revision 1.7: download - view: text, markup, annotated - select for diffs
Thu Oct 7 14:42:31 2021 UTC (3 years, 2 months ago) by nia
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +1 -2 lines
net: Remove SHA1 hashes for distfiles

Revision 1.6: download - view: text, markup, annotated - select for diffs
Tue Jul 7 05:33:30 2020 UTC (4 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +5 -5 lines
py-netaddr: updated to 0.8.0

Release: 0.8.0

* Fixed weak reference support in classes with ``__slots__``
* Added ``__bytes__`` to ``IPAddress`` for intuitive usage
* Added ``format()`` function to EUI
* Added ``IPNetwork.netmask`` property setter
* Added support for IABs in the ``40:D8:55`` OUI
* Drastically optimized ``spanning_cidr()``
* Fixed ``"x.x.x.x/x" in IPNetwork`` tests
* Added support for passing iterables of ``IPRange`` to ``IPSet`` and ``cidr_merge()``

Specific bug fixes addressed in this release
- N log N complexity instead of linear
- Efficiently creating a large IPSet from a list of IPRanges?
- Weak reference support

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sat Jun 20 07:27:44 2020 UTC (4 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +5 -6 lines
py-netaddr: updated to 0.7.20

Changes since 0.7.19

* Fixed returning from an iterator on Python 3.7+, by Sergey Kozlov.
* Fixed Python 3.8 SyntaxWarning on using `is not` with a string literal, by Stefan Nordhausen.
* Fixed DeprecationWarnings by using raw strings for escape characters used in regexes, by Sean McGinnis.
* Improved IPGlob documentation, by obkmeta.
* Fixed exception creation in corner cases by explicitly passin error message params as tuples, by
  Matthias Urlichs.
* Stopped manually replacing shebang of an included script.
* Stopped using __file__ in all code that's expected to run in environments that don't support it
  (like PyOxidizer-produced binaries).
* Updated all databases included in the package.

Specific bug fixes addressed in this release

FIXED Issue 182: https://github.com/netaddr/netaddr/issues/182
    - test_ip_splitter_remove_prefix_larger_than_input_range fails with python 3.7

FIXED Issue 206: https://github.com/netaddr/netaddr/issues/206
    - ""is not" with a literal." SyntaxWarning

FIXED Issue 198: https://github.com/netaddr/netaddr/issues/198
    - oui databases are outdated

FIXED Issue 188: https://github.com/netaddr/netaddr/issues/188
    - Avoid use of __file__

Miscellanea

- Python 2 versions older than 2.7 and Python 3 versions older than 3.5 should be considered
  unsupported. No incompatible code has been introduced to the best of our knowledge but
  there's no CI infrastructure in place to verify this and if there are any issues with
  those versions they won't be fixed.
- Consequently, Python 2.7 and 3.5 support should be considered deprecated as 2.7 has
  reached its end-of-life already and 3.5 will hit it soon.
- A CI setup has been introduced which allows us to test on a variety of Python versions
  on all Mac, Linux and Windows.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Sep 28 12:25:11 2017 UTC (7 years, 2 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +6 -6 lines
py-netaddr: update to 0.7.19

Release: 0.7.19:

* added a new SubnetSplitter class for those looking to divide up subnets.
  Thanks alanwill and RyPeck and those on (Stack Overflow discussion).

* removed bundled pytest dependency code for "python setup.py test".

* setup.py now uses setuptools only (no more distutils) and setup_egg.py removed.

* cleaned up INSTALL docs so they accurately reflect current Python packaging.

* fixed broken parsing, generating and reading of IEEE index files when switching
  between Python 2.x and 3.x.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Mar 6 15:07:07 2016 UTC (8 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +6 -6 lines
Changes 0.7.18:
* cidr_merge() algorithm is now O(n) and much faster.
* nmap target specification now fully supported including IPv4 CIDR
  prefixes and IPv6 addresses.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Nov 4 00:35:31 2015 UTC (9 years, 1 month ago) by agc
Branches: MAIN
CVS tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Add SHA512 digests for distfiles for net category

Problems found with existing digests:
	Package haproxy distfile haproxy-1.5.14.tar.gz
	159f5beb8fdc6b8059ae51b53dc935d91c0fb51f [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]

Problems found locating distfiles:
	Package bsddip: missing distfile bsddip-1.02.tar.Z
	Package citrix_ica: missing distfile citrix_ica-10.6.115659/en.linuxx86.tar.gz
	Package djbdns: missing distfile djbdns-1.05-test25.diff.bz2
	Package djbdns: missing distfile djbdns-cachestats.patch
	Package djbdns: missing distfile 0002-dnscache-cache-soa-records.patch
	Package gated: missing distfile gated-3-5-11.tar.gz
	Package owncloudclient: missing distfile owncloudclient-2.0.2.tar.xz
	Package poink: missing distfile poink-1.6.tar.gz
	Package ra-rtsp-proxy: missing distfile rtspd-src-1.0.0.0.tar.gz
	Package ucspi-ssl: missing distfile ucspi-ssl-0.70-ucspitls-0.1.patch
	Package waste: missing distfile waste-source.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Tue Sep 2 13:48:13 2014 UTC (10 years, 3 months ago) by he
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
py-netaddr is a Python library for representing and manipulating
network addresses.

It support the ability to work and interact with the following:
 - IPv4 and IPv6 addresses and subnets
 - MAC addresses, OUI and IAB identifiers, IEEE EUI-64 identifiers
 - arbitrary (non-aligned) IP address ranges and IP address sets
 - various non-CIDR IP range formats such as nmap and glob-style formats

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>