[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / py-lexicon

File: [cvs.NetBSD.org] / pkgsrc / net / py-lexicon / Makefile (download)

Revision 1.41, Sat Jan 11 16:17:39 2020 UTC (4 years, 3 months ago) by adam
Branch: MAIN
Changes since 1.40: +2 -2 lines

py-lexicon: updated to 3.3.16

3.3.16
Introduce Gransy provider.
Fix Subreg.cz nameserver name.

3.3.15
Update godaddy.py

3.3.14
Adds subaction as query parameter instead of using url argument.
Addresses code style.
Removes unnecessary print statement.
Adds code author info and link to API docs.
Adds test recordings for EUserv provider.
Fixes case when identifier is None. Attempts to find the identifier with the given arguments.Adds test class for EUserv with filtering.
Adds macOS specific .DS_Store file.
Fixes determining subdomain parameter. This provider automatically appends the domain name to the subdomain. Therefore, it needs to be removed from the parameter in case the name argument contains it.
Adds support for deleting records.
Adds support for updating records.
Moves TTL and priority parameter processing to helper functions.
Adds support for creating records.
Adds logger calls and small fixes.
Adds support for listing records.
Adds retrieval of actual domain ID.
Initial version of EUserv provider with working authentication.

3.3.13
Fix auto provider handling of parameters.

3.3.12
Change uri check after login for easyname.

# $NetBSD: Makefile,v 1.41 2020/01/11 16:17:39 adam Exp $

DISTNAME=	dns-lexicon-3.3.16
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:S/dns-//}
CATEGORIES=	net python
MASTER_SITES=	${MASTER_SITE_PYPI:=d/dns-lexicon/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/AnalogJ/lexicon
COMMENT=	Manipulate DNS records on various DNS providers
LICENSE=	mit

DEPENDS+=	${PYPKGPREFIX}-cryptography-[0-9]*:../../security/py-cryptography
DEPENDS+=	${PYPKGPREFIX}-future-[0-9]*:../../devel/py-future
DEPENDS+=	${PYPKGPREFIX}-requests-[0-9]*:../../devel/py-requests
DEPENDS+=	${PYPKGPREFIX}-tldextract-[0-9]*:../../net/py-tldextract
DEPENDS+=	${PYPKGPREFIX}-yaml-[0-9]*:../../textproc/py-yaml
TEST_DEPENDS+=	${PYPKGPREFIX}-mock>=2.0.0:../../devel/py-mock
TEST_DEPENDS+=	${PYPKGPREFIX}-test>=4.1.1:../../devel/py-test
TEST_DEPENDS+=	${PYPKGPREFIX}-test-xdist>=1.26.1:../../devel/py-test-xdist

MESSAGE_SUBST+=	PYPKGPREFIX=${PYPKGPREFIX}

post-install:
	cd ${DESTDIR}${PREFIX}/bin && \
	${MV} lexicon lexicon-${PYVERSSUFFIX} || ${TRUE}

# Do not test providers
do-test:
	cd ${WRKSRC}/lexicon && pytest-${PYVERSSUFFIX} tests/test_*

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"