The NetBSD Project

CVS log for pkgsrc/net/py-apache-libcloud/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / net / py-apache-libcloud

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.14 / (download) - annotate - [select for diffs], Tue Apr 2 19:32:39 2024 UTC (2 weeks, 3 days ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.13: +4 -5 lines
Diff to previous 1.13 (colored)

py-apache-libcloud: updated to 3.8.0

Changes in Apache Libcloud 3.8.0
--------------------------------

Compute
~~~~~~~

- Remove obsolete compute driver where the provider is either dead or not
  offering those services anymore: Bluebox, bsnlcloud, Cloudwatt, Enomaly,
  ElasticHosts, ElasticStack, GoGrid, Gridspot, HostVirtual, Joyent, Med-1,
  Nephoscale, 1on1, ProfitBricks, ServerLove, SkaliCloud, Softlayer, Voxel.

- [Outscale] Fix ``list_nodes()`` and ``list_volumes()`` method.

- [Azure ARM] Implement pagination in the ``list_nodes()`` method. This fixes a
  bug which would result in sometimes not all the nodes being returned.

- [Azure ARM] Implement pagination in the ``list_volumes()`` method. This fixes a
  bug which would result in sometimes not all the volumes nodes being returned.

- [Azure ARM] Bump DISK_API_VERSION from ``2018-06-01`` to ``2023-01-02`` to
  support premium v2 SSDs.

- [AWS EC2] Add support for the following new arguments to the
  ``ex_register_image()`` method:
  * ``boot_mode`` - control bios vs uefi boot
  * ``tpm_support`` - enable a tpm
  * ``uefi_data`` - provide NV UEFI vars
  * ``imds_support`` - require IMDSv2.

Storage
~~~~~~~

- Optimize ``read_in_chunks()`` function implementation.

  This should result in large performance speedups and lower memory usage when
  uploading or downloading a large file with a mismatching chunk size.

  Keep in mind that this only affects code paths where the function is called
  with ``fill_size=True`` argument (such as in the S3 driver, etc).

- [Aliyun OSS] Fix ``upload_object()`` function.

- [S3] Support all available storage classes. Previously only "standard" and
  "reduced_redundancy" were supported.

- [CloudFiles] Fix ``get_endpoint_url()`` throwing an exception when being used
  with ``use_internal_url=True`` argument.

- [CloudFiles] Update OpenStack connection handling code to only re-connect in
  case connection details (scheme, host, port) have changed.

  This should result in significant performance improvements when downloading
  objects since the underlying HTTP connection will be properly re-used.

- [Backblaze B2] Fix a bug which would result in an exception when passing
  ``extra={"meta_data": {}}`` argument to the ``upload_object()`` method.

Other
~~~~~

- Move Python tooling (pytest, bandit, pylint, mypy, coverage) config options
  from separate config files into single pyproject.yaml config files.

  NOTE: This change only affects development process and nothing else.

- Fix minor typos in the code using codespell package and enforce this check as
  part of our GHA CI system.

- Indicate we also support Python 3.12 (beta).

- Remove unused ``libcloud.security.SSL_VERSION`` constant / module level
  variable. This variable has been unused and had no affect on the behavior
  since we switched to the ``requests`` library for making HTTP(s) requests in
  2016.

- Packaging related metadata has been migrated from ``setup.py`` to
  ``pyproject.yaml`` file.

- Deprecated and unsafe ``setup.py test`` convenience alias for running tests
  using pytest has been removed in favor of running pytest directly.

- Script for building release artifacts has been updated to utilize ``build``
  Python package to build release artifacts (sdist + wheel) in an isolated
  environment.

Revision 1.13 / (download) - annotate - [select for diffs], Fri Feb 10 14:41:16 2023 UTC (14 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.12: +2 -1 lines
Diff to previous 1.12 (colored)

py-apache-libcloud: fix invalid pattern

Fixes build.

Revision 1.12 / (download) - annotate - [select for diffs], Tue Oct 26 11:06:33 2021 UTC (2 years, 5 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)


net: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Not committed (merge conflicts...):

net/radsecproxy/distinfo

The following distfiles could not be fetched (fetched conditionally?):

./net/citrix_ica/distinfo citrix_ica-10.6.115659/en.linuxx86.tar.gz
./net/djbdns/distinfo dnscache-1.05-multiple-ip.patch
./net/djbdns/distinfo djbdns-1.05-test28.diff.xz
./net/djbdns/distinfo djbdns-1.05-ignoreip2.patch
./net/djbdns/distinfo djbdns-1.05-multiip.diff
./net/djbdns/distinfo djbdns-cachestats.patch

Revision 1.11 / (download) - annotate - [select for diffs], Thu Oct 7 14:42:24 2021 UTC (2 years, 6 months ago) by nia
Branch: MAIN
Changes since 1.10: +1 -2 lines
Diff to previous 1.10 (colored)

net: Remove SHA1 hashes for distfiles

Revision 1.10 / (download) - annotate - [select for diffs], Sun May 17 19:06:47 2020 UTC (3 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.9: +5 -5 lines
Diff to previous 1.9 (colored)

py-apache-libcloud: updated to 3.0.0

Changes in Apache Libcloud 3.0.0

Common
------
Make sure auth_user_info variable on the OpenStack identify connection class is populated when using auth version 3.x_password and 3.x_oidc_access_token.

[OpenStack] Update OpenStack identity driver so a custom project can be selected using domain_name keyword argument containing a project id.

Previously this argument value could only contain a project name, now the value will be checked against project name and id.

Compute
-------
[GCE] Update create_node() method so it throws an exception if node location can't be inferred and location is not specified by the user ( either by passing datacenter constructor argument or by passing location argument to the method).

[GCE] Update ex_get_disktype method so it works if zone argument is not set.

[GiG G8] Add new driver for GiG G8 provider (https://gig.tech/).

Add new at_exit_func argument to deploy_node() method. With this argument user can specify which function will be called before exiting with the created node in question if the deploy process has been canceled after the node has been created, but before the method has fully finished.

This comes handy since it simplifies various cleanup scenarios.

[OpenStack] Fix auto assignment of volume device when using device name auto in the attach_volume method.

[Kamatera] Add new driver for Kamatera provider (https://www.kamatera.com).

Storage
-------
Add new download_object_range and download_object_range_as_stream methods for downloading part of the object content (aka range downloads) to the base storage API.

Currently those methods are implemented for the local storage Azure Blobs, CloudFiles, S3 and any other provider driver which is based on the S3 one (such as Google Storage and DigitalOcean Spaces).

Add type annotations for the base storage API.

[Google Storage] Update the driver so it supports service account HMAC credentials.

There was a bug in the code where we used the user id length check to determine the account type and that code check didn't take service account HMAC credentials (which contain a longer string) into account.

DNS
---
Add type annotations for the base DNS API.

Container
---------
[Kubernetes] Add support for the client certificate and static token based authentication to the driver.
Add type annotations for the base container API.

Revision 1.9 / (download) - annotate - [select for diffs], Fri Feb 22 08:59:49 2019 UTC (5 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.8: +5 -6 lines
Diff to previous 1.8 (colored)

py-apache-libcloud: updated to 2.4.0

Changes in Apache Libcloud 2.4.0

- Refuse installation with Python 2.6 and Python 3.3 (support was
  already dropped in Libcloud 2.3.0)
- Support Python 3.7
- Cleanup various Python files
- Allow running tests with http_proxy set

Common
- [OpenStack] Document openstack_connection_kwargs method
- [OpenStack] Handle missing user email in OpenStackIdentityUser

Compute
- [ARM] Support OS disk size definition on node creation
- [Digital Ocean] Support floating IPs
- [Digital Ocean] Support attach/detach for floating IPs
- [Digital Ocean] Add ex_get_node_details
- [Digital Ocean] Add tags extra attribute to create_node
- [Dimension Data] Fix IndexError in list_images
- [EC2] Add AWS eu-west-3 (Paris) region
- [EC2] Add description to ex_authorize_security_group_ingress
- [EC2] Added script to automatically get EC2 instance sizes
- [EC2] Update instance sizes
- [EC2] Accept tags when create a snapshot
- [GCE] Expand Firewall options coverage
- [GCE] Expand network and subnetwork options coverage
- [GCE] Extend ex_create_address to allow internal ip creation
- [GCE] Allow shared VPC in managed instance group creation
- [GCE] Support disk_size parameter for boot disk when creating instance

- [GCE] Update public image projects list
- [GCE] Fix _find_zone_or_region for >500 instances
- [GCE] Allow routing_mode=None in ex_create_network
- [OpenStack] Implement Glance Image API v2
- [OpenStack] Fix spelling in ex_files description
- [OpenStack v2] Allow listing image members
- [OpenStack v2] Allow creating and accepting image members
- [OpenStack v2] Fix image members methods
- [OpenStack] Fix API doc for delete_floating_ip
- [OpenStack] Implement port attaching/detaching
- [OpenStack] Add methods for getting and creating ports
- [OpenStack] Add get_user method
- [OpenStack] Add ex_list_subnets to OpenStack_2_NodeDriver
- [OpenStack] The OpenStack_2_NodeDriver uses two connections
- [OpenStack] The OpenStack_2_NodeDriver /v2.0/networks instead of /os-networks
- [Scaleway] New Scaleway driver
- [Scaleway] Update Scaleway default API host

DNS
- [Google Cloud DNS] Document driver instantiation

Storage
- Update docstring for storage provider class
- [Azure Blob Storage] Allow filtering lists by prefix
- [Azure Blob Storage] Update driver documentation
- [Azure Blob Storage] Fix upload/download streams
- [Azure Blob Storage] Fix PageBlob headers
- [S3] Guess s3 upload content type
- [S3] Add Amazon S3 (cn-northwest-1) Storage Driver

Other
- Fixed spelling in 2.0 changes documentation


Changes in Apache Libcloud 2.3.0
- Drop support for Python 2.6 and Python 3.3
  They're no longer supported, and the Python ecosystem is starting to
  drop support: two of our test dependencies no longer support them.
- Made pytest-runner optional

Common
- Improve warning when CA_CERTS_PATH is incorrectly passed as a list
- Cleaned up and corrected third-party drivers documentation
- Modernized a few Python examples
- [OpenStack] Authentify with updated Identity API

Compute
- Fix "wait_until_running() method so it also works correctly and doesn't
  append "None" to the addresses list if node has no IP address.
- [ARM] Fix checking for "location is None" in several functions
- [ARM] Fix error when using SSH key auth with Python 3
- [ARM] Fix API call on powerOff, understand PAUSED state
- [ARM] Delete VHDs more reliably in destroy_node(), raise exception on unhandled errors
- [ARM] Fix api version used to list and delete NICs
- [ARM] Allow faster list_nodes() with ex_fetch_power_state=False
- [ARM] Fix delete_old_vhd
- [ARM] Limit number of retries in destroy_node
- [ARM] Fix Retry-After header handling
- [CloudStack] Handle NICs without addresses
- [CloudStack] Add change size and restore
- [Digital Ocean] Add ex_enable_ipv6 in DigitalOcean_v2 driver
- [Digital Ocean] Add support for tags in list_nodes()
- [Digital Ocean] Add rebuild and resize commands
- [EC2] Add new x1.16xlarge and x1e.32xlarge instance type.
- [EC2] Add AWS EC2 c5 series
- [EC2] Add AWS EC2 M5 sizes
- [EC2] Update pricing information for EC2 instances.
- [EC2] Allow cn-north-1 even without pricing information
- [EC2] Fix EBS volume encryption
- [ECS Aliyun] Support modify_security_group_attributes
- [GCE] Allow adding labels to images
- [GCE] Allow adding license strings to images
- [GCE] Support GCE node labels.
- [GCE] Fix GCEList pagination.
- [GCE] Allow setting service account in instance templates
- [GCE] Add support for private IP addresses in GCE instance creation
- [GCE] Allow for use of shared network (VPC) and subnetwork
- [GCE] Add support for accelerators
- [ProfitBricks] Update driver and add support for the new API v4.
- [ProfitBricks] Fix list_snapshots() method
- [UpCloud] New driver for UpCloud
- [UpCloud] Use disk size and storage tier also when creating node from template
- [UpCloud] Allow to define hostname and username
- [UpCloud] Add pricing information to list_sizes

Storage
- Added Digital Ocean Spaces driver
- [Digital Ocean Spaces] Add support for AMS3 region
- [Digital Ocean Spaces] Add support for SGP1 region
- Fix a bug / regression which resulted in increased memory consumption when
  using download_object method. This method would store whole object
  content in memory even though there was no need for that.
  This regression was introduced in 2.0.0 when we moved to using requests
  library.
- Fix a regression with hash computation performance and memory usage on object
  upload inadvertently introduced in 2.0.0 and make it more efficient.

Revision 1.8 / (download) - annotate - [select for diffs], Thu Dec 27 15:05:27 2018 UTC (5 years, 3 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.7: +2 -1 lines
Diff to previous 1.7 (colored)

async is a keyword in Python 3.7, rename. Bump revision.

Revision 1.7 / (download) - annotate - [select for diffs], Tue Sep 26 17:21:10 2017 UTC (6 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.6: +5 -5 lines
Diff to previous 1.6 (colored)

py-apache-libcloud: update to 2.2.1

Libcloud 2.2.1:
Common
- Fix an issue with installation failing on some operating system and file
  systems combinations (e.g. ecryptfs layered on top of ext4) which don't
  support file names longer than 143 characters.

Compute
- [EC2] add g3 instance types
- [EC2] add 'end' to ec2 reserved_node
- Decrease sleep delay (from 1.5 to 0.2 seconds) inside paramiko client which
  is used to prevent busy waiting while waiting for data on the channel.
  This should cause deploy scripts which produce a lot of output in incremental
  manner to finish faster.
- Fix a regression in the Azure ARM driver which didn't allow custom storage
  URI suffix to be used with create_node.

Tests
- Make sure we normalize header values and cast all the numbers to strings in
  base connection classes used by tests.

Revision 1.6 / (download) - annotate - [select for diffs], Thu Sep 7 06:26:39 2017 UTC (6 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.5: +5 -5 lines
Diff to previous 1.5 (colored)

Changes in Apache Libcloud 2.2.0:

Common
* [GCE] Scrape prices for GCE Australia Region [GITHUB-1085] (Francisco Ros)

Compute
* [ARM] Add option to create static public IP [GITHUB-1091, LIBCLOUD-918] (Aki Ketolainen)
* [SOFTLAYER] Add get_image method to class [GITHUB-1066] (Francois Regnoult)
* [ARM] Add Storage support, volumes, snapshots [GITHUB-1087] (Sergey Babak)

Container
* [DOCKER] Fixes to support TLS connection [GITHUB-1067] (johnnyWalnut)

DNS
* [ROUTE53] Fix for TXT and SPF records, when user didnãàÑÕ escapsulate data in quotes, the API would fire error. As reported by @glyph [LIBCLOUD-875, GITHUB-1093] (Anthony Shaw)
* [LINODE] Add priority to the extra dictionary in record instances [GITHUB-1088] (@mete0r)

Load Balancer
* Fixed AWS ALB/ELB driver init method to instantiate nested connection object properly [LIBCLOUD-936, GITHUB-1089] (Anton Kozyrev)

Storage
* [CLOUDFILES] Update OpenStackSwiftConnection to work with auth version 3.0 [GITHUB-1068] (Hakan Carlsson)
* [CLOUDFILES] Add SSL URI support [GITHUB-1076, LIBCLOUD-458]

Revision 1.5 / (download) - annotate - [select for diffs], Tue Jul 18 05:12:27 2017 UTC (6 years, 9 months ago) by adam
Branch: MAIN
Changes since 1.4: +5 -5 lines
Diff to previous 1.4 (colored)

Changes in Apache Libcloud 2.1.0

Common
- [AWS] Update prices and fix some region names
- Fix bug in utils.decorators wrap exception method, used by vsphere driver
- Use PyTest as the unit testing runner
- Use of LXML is now disabled by defalt, use libcloud.utils.py3.DEFAULT_LXML = True to reenable. LXML has compatibility
  issues with a number of drivers and etree is a standard package
- Switch RawResponse class to use content body instead of text body, up to 10x performance improvement for methods like StorageDriver.download_object

Revision 1.4 / (download) - annotate - [select for diffs], Wed May 10 17:58:32 2017 UTC (6 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.3: +5 -5 lines
Diff to previous 1.3 (colored)

Changes in Apache Libcloud 2.0.0
--------------------------------
Common
~~~~~~
- Fix OpenStack drivers not correctly setting URLs when used with identity API, would default to 127.0.0.1 and service
  catalog URLs were not adhered to.

- Fix Aliyun ECS, Load balancer and storage adapters when using unicode UTF-8 characters in the names of resources
  in 2.0.0rc2 < it would fail as a MalformedResponseError, Python 2.7 element tree was raising a unicode error

- Refactor the test classes to use the full libcloud.http and libcloud.common.base modules, with Connection,
  Response all used with requests_mock. This increases our test coverages and catches bugs in drivers' custom
  parse_body and auth modules

- Rename libcloud.httplib_ssl to libcloud.http now that we don't use httplib

Revision 1.3 / (download) - annotate - [select for diffs], Wed Nov 4 00:35:29 2015 UTC (8 years, 5 months ago) by agc
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.2: +2 -1 lines
Diff to previous 1.2 (colored)

Add SHA512 digests for distfiles for net category

Problems found with existing digests:
	Package haproxy distfile haproxy-1.5.14.tar.gz
	159f5beb8fdc6b8059ae51b53dc935d91c0fb51f [recorded]
	da39a3ee5e6b4b0d3255bfef95601890afd80709 [calculated]

Problems found locating distfiles:
	Package bsddip: missing distfile bsddip-1.02.tar.Z
	Package citrix_ica: missing distfile citrix_ica-10.6.115659/en.linuxx86.tar.gz
	Package djbdns: missing distfile djbdns-1.05-test25.diff.bz2
	Package djbdns: missing distfile djbdns-cachestats.patch
	Package djbdns: missing distfile 0002-dnscache-cache-soa-records.patch
	Package gated: missing distfile gated-3-5-11.tar.gz
	Package owncloudclient: missing distfile owncloudclient-2.0.2.tar.xz
	Package poink: missing distfile poink-1.6.tar.gz
	Package ra-rtsp-proxy: missing distfile rtspd-src-1.0.0.0.tar.gz
	Package ucspi-ssl: missing distfile ucspi-ssl-0.70-ucspitls-0.1.patch
	Package waste: missing distfile waste-source.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.2 / (download) - annotate - [select for diffs], Mon Feb 23 10:46:31 2015 UTC (9 years, 1 month ago) by imil
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.1: +4 -4 lines
Diff to previous 1.1 (colored)

Updated py-apache-libcloud to 0.17.0

Changes with Apache Libcloud 0.17.0
General

    Use match_hostname function from backports.ssl_match_hostname package to verify the SSL certificate hostname instead of relying on our own logic. (GITHUB-374) [Alex Gaynor]

Compute

    GCE driver updated to include ex_stop_node() and ex_start_node() methods. (GITHUB-442) [Eric Johnson]
    GCE driver now raises ResourceNotFoundError when the specified image is not found in any image project. Previously, this would return None but now raises the not-found exception instead. This fixes a bug where returning None caused ex_delete_image to raise an AttributeError. (GITHUB-441) [Eric Johnson]
    GCE driver update to support JSON format Service Account files and a PY3 fix from Siim Põder for LIBCLOUD-627. (LIBCLOUD-627, LIBCLOUD-657, GITHUB-438) [Eric Johnson]
    GCE driver fixed for missing param on ex_add_access_config. (GITHUB-435) [Peter Mooshammer]
    GCE driver support for HTTP load-balancer resources. (LIBCLOUD-605, GITHUB-429) [Lee Verberne]
    GCE driver updated to make better use of GCEDiskTypes. (GITHUB-428) [Eric Johnson]
    GCE driver list_images() now returns all non-deprecated images by default. (LIBCLOUD-602, GITHUB-423) [Eric Johnson]
    Improve GCE API coverage for create_node(). (GITHUB-419) [Eric Johnson]
    GCE Licenses added to the GCE driver. (GITHUB-420) [Eric Johnson]
    GCE Projects support common instance metadata and usage export buckets. (GITHUB-409) [Eric Johnson]
    Improvements to TargetPool resource in GCE driver. (GITHUB-414) [Eric Johnson]
    Adding TargetInstances resource to GCE driver. (GITHUB-393) [Eric Johnson]
    Adding DiskTypes resource to GCE driver. (GITHUB-391) [Eric Johnson]
    Fix boot disk auto_delete in GCE driver. (GITHUB-412) [Igor Bogomazov]
    Add Routes to GCE driver. (GITHUB-410) [Eric Johnson]
    Add missing ubuntu-os-cloud images to the GCE driver. (LIBCLOUD-632, GITHUB-385) [Borja Martin]
    Add new us-east-2 and us-east-3 region to the Joyent driver. (GITHUB-386) [ZuluPro]
    Add missing t2. instance types to the us-west-1 region in the EC2 driver. (GITHUB-388) [Matt Lehman]
    Add option to expunge VM on destroy in CloudStack driver. (GITHUB-382) [Roeland Kuipers]
    Add extra attribute in list_images for CloudStack driver. (GITHUB-389) [Loic Lambiel]
    Add ex_security_group_ids argument to the create_node method in the EC2 driver. This way users can launch VPC nodes with security groups. (GITHUB-373) [Itxaka Serrano]
    Add description argument to GCE Network. (GITHUB-397) [Eric Johnson]
    GCE: Improve MachineType (size) coverage of GCE API. (GITHUB-396) [Eric Johnson]
    GCE: Improved Images coverage. (GITHUB-395) [Eric Johnson]
    GCE: Support for global IP addresses. (GITHUB-390, GITHUB-394) [Eric Johnson]
    GCE: Add missing snapshot attributes. (GITHUB-401) [Eric Johnson]
    AWS: Set proper disk size in c3.X instance types. (GITHUB-405) [Itxaka Serrano]
    Fix a bug with handling of the ex_keyname argument in the Softlayer driver. (GITHUB-416, LIBCLOUD-647) [Dustin Oberloh]
    Update CloudSigma region list (remove Las Vegas, NV region and add new San Jose, CA and Miami, FL region). (GITHUB-417) [Viktor Petersson]
    Add ex_get_node method to the Joyent driver. (GITHUB-421) [ZuluPro]
    Add support for placement group management to the EC2 driver. (GITHUB-418) [Mikhail Ovsyannikov]
    Add new tok02 region to the Softlayer driver. (GITHUB-436, LIBCLOUD-656) [Dustin Oberloh]
    Add new Honolulu, HI endpoint to the CloudSigma driver. (GITHUB-439) [Stephen D. Spencer]
    Fix a bug with config_drive attribute in the OpenStack driver. New versions of OpenStack now return a boolean and not a string. (GITHUB-433) [quilombo]
    Add support for Abiquo API v3.x, remove support for now obsolete API v2.x. (GITHUB-433, LIBCLOUD-652) [David Freedman]
    Allow rootdisksize parameter in create_node CloudStack driver (GITHUB-440, LIBCLOUD-658) [Loic Lambiel]

Storage

    Allow user to pass headers argument to the upload_object and upload_object_via_stream method.

    This way user can specify CORS headers with the drivers which support that. (GITHUB-403, GITHUB-404) [Peter Schmidt]

    Fix upload_object_via_stream so it works correctly under Python 3.x if user manually passes an iterator to the method.

    Also improve how reading a file in chunks works with drivers which support chunked encoding - always try to fill a chunk with CHUNK_SIZE bytes instead of directly streaming the chunk which iterator returns.

    Previously, if iterator returned 1 byte in one iteration, we would directly send this as a single chunk to the API. (GITHUB-408, LIBCLOUD-639) [Peter Schmidt]

Loadbalancer

    Updates to CloudStack driver. (GITHUB-434) [Jeroen de Korte]

DNS

    New driver for Softlayer DNS service. (GITHUB-413, LIBCLOUD-640) [Van Levstik]
    Fix a bug with ex_create_multi_value_record method in the Route53 driver only returning a single record. (GITHUB-431, LIBCLOUD-650) [Itxaka Serrano]

Changes with Apache Libcloud 0.16.0
General

    Add new OpenStackIdentity_3_0_Connection class for working with OpenStack Identity (Keystone) service API v3. [Tomaz Muraus]
    Add support for prettifying JSON or XML response body which is printed to a file like object when using LIBCLOUD_DEBUG environment variable. This option can be enabled by setting LIBCLOUD_DEBUG_PRETTY_PRINT_RESPONSE environment variable. [Tomaz Muraus]
    Add support for using an HTTP proxy for outgoing HTTP and HTTPS requests. [Tomaz Muraus, Philip Kershaw]

Compute

    Fix an issue with LIBCLOUD_DEBUG not working correctly with the Linode driver. [Tomaz Muraus, Juan Carlos Moreno] (LIBCLOUD-598, GITHUB-342)

    Add new driver for VMware vSphere (http://www.vmware.com/products/vsphere/) based clouds. [Tomaz Muraus]

    Add two new default node states - NodeState.SUSPENDED and NodeState.ERROR. [Tomaz Muraus]

    Fix to join networks properly in deploy_node in the CloudStack driver. (LIBCLOUD-593, GITUHB-336) [Atsushi Sasaki]

    Create CloudStackFirewallRule class and corresponding methods. (LIBCLOUD-594, GITHUB-337) [Atsushi Sasaki]

    Add support for SSD disks to Google Compute driver. (GITHUB-339) [Eric Johnson]

    Add utility get_regions and get_service_names methods to the OpenStackServiceCatalog class. [Andrew Mann, Tomaz Muraus]

    Fix a bug in ex_get_console_output in the EC2 driver which would cause an exception to be thrown if there was no console output for a particular node.

    Reported by Chris DeRamus. [Tomaz Muraus]

    Add ip_address parameter in CloudStack driver create_node method. (GITHUB-346) [Roeland Kuipers]

    Fix ParamikoSSHClient.run and deploy_node method to work correctly under Python 3. (GITHUB-347) [Eddy Reyes]

    Update OpenStack driver to map more node states to states recognized by Libcloud. [Chris DeRamus]

    Fix a bug with ex_metadata argument handling in the Google Compute Engine driver create_node method. (LIBCLOUD-544, GITHUB-349, GITHUB-353) [Raphael Theberge]

    Add SSH key pair management methods to the Softlayer driver. (GITHUB-321, GITHUB-354) [Itxaka Serrano]

    Correctly categorize node IP addresses into public and private when dealing with OpenStack floating IPs. [Andrew Mann]

    Add new t2 instance types to the EC2 driver. [Tomaz Muraus]

    Add support for Amazon GovCloud to the EC2 driver (us-gov-west-1 region). [Chris DeRamus]

    Allow user to pass "gp2" for "ex_volume_type" argument to the create_volume method in the EC2 driver.

    Reported by Xavier Barbosa. [Tomaz Muraus, Xavier Barbosa]

    Add new driver for ProfitBricks provider. (LIBCLOUD-589, GITHUB-352) [Matt Baldwin]

    Various improvements and bugs fixes in the GCE driver. For a list, see https://github.com/apache/libcloud/pull/360/commits (GITHUB-360) [Evgeny Egorochkin]

    Allow user to specify virtualization type when registering an EC2 image by passing virtualization_type argument to the ex_register_image method. (GITHUB-361) [Andy Grimm]

    Add ex_create_image method to the GCE driver. (GITHUB-358, LIBCLOUD-611) [Katriel Traum]

    Add some methods to CloudStack driver: create_volume_snapshot, list_snapshots, destroy_volume_snapshot create_snapshot_template, ex_list_os_types) (GITHUB-363, LIBCLOUD-616) [Oleg Suharev]

    Added VPC support and Egress Firewall rule support fo CloudStack (GITHUB-363) [Jeroen de Korte]

    Add additional attributes to the extra dictionary of OpenStack StorageVolume object. (GITHUB-366) [Gertjan Oude Lohuis]

    Fix create_volume method in the OpenStack driver to return a created volume object (instance of StorageVolume) on success, instead of a boolean indicating operation success. (GITHUB-365) [Gertjan Oude Lohuis]

    Add optional project parameters for ex_list_networks() to CloudStack driver (GITHUB-367, LIBCLOUD-615) [Rene Moser]

    CLOUDSTACK: option to start VM in a STOPPED state (GITHUB-368) [Roeland Kuipers]

    Support "config_drive" in the OpenStack driver. Allow users to pass ex_config_drive argument to the create_node and ex_rebuild_node method. (GITHUB-370) [Nirmal Ranganathan]

    Add support for service scopes to the create_node method in the GCE driver. (LIBCLOUD-578, GITHUB-373) [Eric Johnson]

    Update GCE driver to allow for authentication with internal metadata service. (LIBCLOUD-625, LIBCLOUD-276, GITHUB-276) [Eric Johnson]

    Fix a bug in Elasticstack node creation method where it would raise exceptions because of missing data in a response, and also fix pulling the IP from the proper data item. (GITHUB-325) [Michael Bennett]

    Fix a bug which prevented user to connect and instantiate multiple EC2 driver instances for different regions at the same time. (GITHUB-325) [Michael Bennett]

    Add methods in CloudStack driver to manage mutiple nics per vm. (GITHUB-369) [Roeland Kuipers]

    Implements VPC network ACLs for CloudStack driver. (GITHUB-371) [Jeroen de Korte]

Storage

    Fix a bug with CDN requests in the CloudFiles driver. [Tomaz Muraus]
    Fix a bug with not being able to specify meta_data / tags when uploading an object using Google Storage driver. (LIBCLOUD-612, GITHUB-356) [Stefan Friesel]

Loadbalancer

    Allow user to specify session affinity algorithm in the GCE driver by passing ex_session_affinity argument to the create_balancer method. (LIBCLOUD-595, GITHUB-341) [Lee Verberne, Eric Johnson]

DNS

    Various fixes in the Google DNS driver. (GITHUB-378) [Franck Cuny]

Changes with Apache Libcloud 0.15.1
Compute

    Allow user to limit a list of subnets which are returned by passing subnet_ids and filters argument to the ex_list_subnets method in the EC2 driver. (LIBCLOUD-571, GITHUB-306) [Lior Goikhburg]

    Allow user to limit a list of internet gateways which are returned by passing gateway_ids and filters argument to the ex_list_internet_gateways method in the EC2 driver. (LIBCLOUD-572, GITHUB-307) [Lior Goikhburg]

    Allow user to filter which nodes are returned by passing ex_filters argument to the list_nodes method in the EC2 driver. (LIBCLOUD-580, GITHUB-320) [Lior Goikhburg]

    Add network_association_id to ex_list_public_ips and CloudstackAddress object (GITHUB-327) [Roeland Kuipers]

    Allow user to specify admin password by passing ex_admin_pass argument to the create_node method in the Openstack driver. (GITHUB-315) [Marcus Devich]

    Fix a possible race condition in deploy_node which would occur if node is online and can be accessed via SSH, but the SSH key we want to use hasn't been installed yet.

    Previously, we would immediately throw if we can connect, but the SSH key hasn't been installed yet. (GITHUB-331) [David Gay]

    Propagate an exception in deploy_node method if user specified an invalid path to the private key file. Previously this exception was silently swallowed and ignored. [Tomaz Muraus]

DNS

    Include a better message in the exception which is thrown when a request in the Rackspace driver ends up in an ERROR state. [Tomaz Muraus]

Changes with Apache Libcloud 0.15.0
General

    Use lxml library (if available) for parsing XML. This should substantially reduce parsing time and memory usage for large XML responses (e.g. retrieving all the available images in the EC2 driver). [Andrew Mann]

    Use --head flag instead of -X HEAD when logging curl lines for HEAD requests in debug mode.

    Reported by Brian Metzler. (LIBCLOUD-552) [Tomaz Muraus]

    Fix Python 3 compatibility bugs in the following functions:
        import_key_pair_from_string in the EC2 driver
        publickey._to_md5_fingerprint
        publickey.get_pubkey_ssh2_fingerprint

    (GITHUB-301) [Csaba Hoch]

    Update CA_CERTS_PATH to also look for CA cert bundle which comes with openssl Homebrew formula on OS x (/usr/local/etc/openssl/cert.pem). (GITHUB-309) [Pedro Romano]

    Update Google drivers to allow simultaneous authornization for all the supported Google Services. (GITHUB-302) [Eric Johnson]

Compute

    Fix create_key_pair method which was not returning private key. (LIBCLOUD-566) [Sebastien Goasguen]

    Map "Stopped" node state in the CloudStack driver to NodeState.STOPPED instead of NodeState.TERMINATED, "Stopping" to NodeState.PENDING instead of NodeState.TERMINATED and "Expunging" to NodeState.PENDING instead of NodeState.TERMINATED. (GITHUB-246) [Chris DeRamus, Tomaz Muraus]

    Add ex_create_tags and ex_delete_tags method to the CloudStack driver. (LIBCLOUD-514, GITHUB-248) [Chris DeRamus]

    Add new G2 instances to the EC2 driver. [Tomaz Muraus]

    Add support for multiple API versions to the Eucalyptus driver and allows user to pass "api_version" argument to the driver constructor. (LIBCLOUD-516, GITHUB-249) [Chris DeRamus]

    Map "Powered Off" state in the vCloud driver from "TERMINATED" to "STOPPED". (GITHUB-251) [Ash Berlin]

    Add ex_rename_node method to the DigitalOcean driver. (GITHUB-252) [Rahul Ranjan]

    Improve error parsing in the DigitalOcean driver.

    Reported by Deni Bertovic. [Tomaz Muraus]

    Add extension methods for the VPC internet gateway management to the EC2 driver. (LIBCLOUD-525, GITHUB-255) [Chris DeRamus]

    Add CloudStackProject class to the CloudStack driver and add option to select project and disk offering on node creation. (LIBCLOUD-526, GITHUB-257) [Jim Divine]

    Fix IP address handling in the OpenStack driver. (LIBCLOUD-503, GITHUB-235) [Markos Gogoulos]

    Ad new ex_delete_image and ex_deprecate_image method to the GCE driver. (GITHUB-260) [Franck Cuny]

    Ad new ex_copy_image method to the GCE driver. (GITHUB-258) [Franck Cuny]

    Ad new ex_set_volume_auto_delete method to the GCE driver. (GITHUB-264) [Franck Cuny]

    Add ex_revoke_security_group_ingress method to the CloudStack driver. [Chris DeRamus, Tomaz Muraus]

    Allow user to pass ex_ebs_optimized argument to the create_node method in the EC2 driver. (GITHUB-272) [zerthimon]

    Add "deprecated" attribute to the Node object in the Google Compute Engine driver. (GITHUB-276) [Chris / bassdread]

    Update Softlayer driver to use "fullyQualifiedDomainName" instead of "hostname" attribute for the node name. (GITHUB-280) [RoelVanNyen]

    Allow user to specify target tags using target_tags attribute when creating a firewall rule in the GCE driver. (GITHUB-278) [zerthimon]

    Add new standard API for image management and initial implementation for the EC2 and Rackspace driver. (GITHUB-277) [Matt Lehman]

    Allow user to specify "displayname" attribute when creating a CloudStack node by passing "ex_displayname" argument to the method.

    Also allow "name" argument to be empty (None). This way CloudStack automatically uses Node's UUID for the name. (GITHUB-289) [Jeff Moody]

    Deprecate "key" argument in the SSHClient class in favor of new "key_files" argument.

    Also add a new "key_material" argument. This argument can contain raw string version of a private key.

    Note 1: "key_files" and "key_material" arguments are mutually exclusive. Note 2: "key_material" argument is not supported in the ShellOutSSHClient.

    Use node id attribute instead of the name for the "lconfig" label in the Linode driver. This way the label is never longer than 48 characters. (GITHUB-287) [earthgecko]

    Add a new driver for Outscale SAS and Outscale INC cloud (http://www.outscale.com). (GITHUB-285, GITHUB-293, LIBCLOUD-536, LIBCLOUD-553) [Benoit Canet]

    Add new driver for HP Public Cloud (Helion) available via Provider.HPCLOUD constant. [Tomaz Muraus]

    Allow user to specify availability zone when creating an OpenStack node by passing "ex_availability_zone" argument to the create_node method. Note: This will only work if the OpenStack installation is running availability zones extension. (GITHUB-295, LIBCLOUD-555) [syndicut]

    Allow user to pass filters to ex_list_networks method in the EC2 driver. (GITHUB-294) [zerthimon]

    Allow user to retrieve container images using ex_get_image method in the Google Compute Engine driver. (GITHUB-299, LIBCLOUD-562) [Magnus Andersson]

    Add new driver for Kili public cloud (http://kili.io/) [Tomaz Muraus]

    Add "timeout" argument to the ParamikoSSHClient.run method. If this argument is specified and the command passed to run method doesn't finish in the defined timeout, SSHCommandTimeoutError is throw and the connection to the remote server is closed.

    Note #1: If timed out happens, this functionality doesn't guarantee that the underlying command will be stopped / killed. The way it works it simply closes a connect to the remote server. [Tomaz Muraus]

    Note #2: "timeout" argument is only available in the Paramiko SSH client.

    Make "cidrs_ips" argument in the ex_authorize_security_group_egress method in the EC2 driver mandatory. (GITHUB-301) [Csaba Hoch]

    Add extension methods for managing floating IPs (ex_get_floating_ip, ex_create_floating_ip, ex_delete_floating_ip) to the Openstack 1.1 driver. (GITHUB-301) [Csaba Hoch]

    Fix bug in RimuHosting driver which caused driver not to work when the provider returned compressed (gzip'ed) response. (LIBCLOUD-569, GITHUB-303) [amastracci]

    Fix issue with overwriting the server memory values in the RimuHosting driver. (GUTHUB-308) [Dustin Oberloh]

    Add ex_all_tenants argument to the list_nodes method in the OpenStack driver. (GITHUB-312) [LIBCLOUD-575, Zak Estrada]

    Add support for network management for advanced zones (ex_list_network_offerings, ex_create_network, ex_delete_network) in the CloudStack driver. (GITHUB-316) [Roeland Kuipers]

    Add extension methods for routes and route table management to the EC2 driver (ex_list_route_tables, ex_create_route_table, ex_delete_route_table, ex_associate_route_table, ex_dissociate_route_table, ex_replace_route_table_association, ex_create_route, ex_delete_route, ex_replace_route) (LIBCLOUD-574, GITHUB-313) [Lior Goikhburg]

    Fix ex_list_snapshots for HP Helion OpenStack based driver. [Tomaz Muraus]

    Allow user to specify volume type and number of IOPS when creating a new volume in the EC2 driver by passing ex_volume_type and ex_iops argument to the create_volume method. [Tomaz Muraus]

    Fix ex_unpause_node method in the OpenStack driver. (GITHUB-317) [Pablo Orduña]

    Allow user to launch EC2 node in a specific VPC subnet by passing ex_subnet argument to the create_node method. (GITHUB-318) [Lior Goikhburg]

Storage

    Fix container name encoding in the iterate_container_objects and get_container_cdn_url method in the CloudFiles driver. Previously, those methods would throw an exception if user passed in a container name which contained a whitespace.

    Reported by Brian Metzler. (LIBCLOUD-552) [Tomaz MUraus]

    Fix a bug in the OpenStack Swift driver which prevented the driver to work with installations where region names in the service catalog weren't upper case. (LIBCLOUD-576, GITHUB-311) [Zak Estrada]

Load Balancer

    Add extension methods for policy managagement to the ELB driver. (LIBCLOUD-522, GITHUB-253) [Rahul Ranjan]

DNS

    Fix update_record method in the Route56 driver so it works correctly for records with multiple values. [Tomaz Muraus]
    Add ex_create_multi_value_record method to the Route53 driver which allows user to create a record with multiple values with a single call. [Tomaz Muraus]
    Add new driver for Google DNS. (GITHUB-269) [Franck Cuny]

Revision 1.1 / (download) - annotate - [select for diffs], Thu Apr 17 16:23:30 2014 UTC (10 years ago) by imil
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2

Initial import of py-apache-libcloud, version 0.14.1, into the NetBSD Packages
Collection.

Apache Libcloud is a Python library which hides differences between different
cloud provider APIs and allows you to manage different cloud resources through
a unified and easy to use API.

Resource you can manage with Libcloud are divided in the following categories:

  * Cloud Servers and Block Storage - services such as Amazon EC2 and Rackspace
    Cloud Servers (libcloud.compute.*)
  * Cloud Object Storage and CDN - services such as Amazon S3 and Rackspace
    CloudFiles (libcloud.storage.*)
  * Load Balancers as a Service, LBaaS (libcloud.loadbalancer.*)
  * DNS as a Service, DNSaaS (libcloud.dns.*)

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>