[BACK]Return to DESCR CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / proftpd-mysql

File: [cvs.NetBSD.org] / pkgsrc / net / proftpd-mysql / DESCR (download)

Revision 1.1, Fri Sep 25 10:01:36 2015 UTC (5 years, 2 months ago) by wiedi
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, HEAD

Package ProFTPD using DSO (Dynamic Shared Objects) support.

This is preferable for binary package use as it allowes the user to choose
which features to enable by changeing the configuration file instead of
recompiling. This is also how ProFTPD is usually packaged in other systems.

For details about ProFTPD and DSO see:
	http://www.proftpd.org/docs/howto/DSO.html

This change removes the following PKG_OPTIONS.proftpd:
	ban, ldap, mysql, pgsql, proftpd-readme, quota, tls and wrap

The modules that were previously compiled when enabling ban, proftpd-readme,
quota or tls are now always included. To load them use a configuration
directive like:
	LoadModule mod_ban.c

In addition the proftpd package includes by default many other modules that
were previously unavailble like: mod_load, mod_radius, mod_sftp and more.

The module that was provided by the wrap option is replaced by the wrap2 module
which is also always included.

The ldap option is superseded by the proftpd-ldap package.
The mysql option is superseded by the proftpd-mysql package.
The pgsql option is superseded by the proftpd-postgresql package.
Using proftpd-postgresql will create one binary package for each PostgreSQL
version in pkgsrc.

In addition the following added packages provide new functionality:
	- proftpd-geoip (access GeoIP details)
	- proftpd-memcached (mod_memcache and mod_tls_memcache)
	- proftpd-odbc (access any ODBC database)
	- proftpd-sqlite (access to sqlite3)

ProFTPD module that provides the MySQL (and compatible) backend for SQL
database authentication.