[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / net / php-yp

File: [cvs.NetBSD.org] / pkgsrc / net / php-yp / Attic / Makefile (download)

Revision 1.8, Fri Jun 2 18:27:57 2006 UTC (17 years, 6 months ago) by joerg
Branch: MAIN
Changes since 1.7: +4 -3 lines

Rename all PHP 4 packages to php4-*, all PHP 5 packages to php5-*,
all PEAR packages to php?-pear-* and all Apache packages to ap13-* or
ap2-* respectively. Add new variables to simplify the Makefile
handling. Add CONFLICTS on the old names. Reset revisions of bumped
packages. ap-php will now depend on the default Apache and PHP version.
All programs using it have an implicit option of the Apache version
as well.

OK from jlam@ and adrianp@.

# $NetBSD: Makefile,v 1.8 2006/06/02 18:27:57 joerg Exp $

MODNAME=		yp
CATEGORIES+=		net
COMMENT=		PHP extension for YP domain support

CONFLICTS=	php-yp-[0-9]

# yp extension has been unbundled in PHP 5.1.1, it's only available
# in CVS and isn't available through have PECL; thus, mark this
# PHP4-only for now
PHP_VERSIONS_ACCEPTED=	4

CONFIGURE_ARGS+=	--enable-${MODNAME}=shared,${BUILDLINK_DIR}

.include "../../lang/php/ext.mk"
.include "../../mk/bsd.pkg.mk"