The NetBSD Project

CVS log for pkgsrc/net/p5-Net-Server-Coro/Attic/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / net / p5-Net-Server-Coro

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.10, Fri Jul 31 17:53:14 2015 UTC (3 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: HEAD
Changes since 1.9: +1 -1 lines
FILE REMOVED

Remove p5-Coro and packages depending on it.

Upstream says that it "can not" work with perl 5.22 and has even
forked perl as "stableperl" to allow his package to work instead
of fixing it differently.

See http://blog.schmorp.de/2015-06-06-stableperl-faq.html

Ok bsiegert@

Revision 1.9 / (download) - annotate - [select for diffs], Fri Jun 12 10:50:49 2015 UTC (3 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.8: +2 -1 lines
Diff to previous 1.8 (colored)

Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.

Revision 1.8 / (download) - annotate - [select for diffs], Fri Feb 27 15:03:20 2015 UTC (4 years, 1 month ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.7: +3 -4 lines
Diff to previous 1.7 (colored)

(pkgsrc)
  - Version requirement updated. (See Changes 1.3 below)
   -DEPENDS+=      p5-Net-Server-[0-9]*:../../net/p5-Net-Server
   +DEPENDS+=      p5-Net-Server>=2.0:../../net/p5-Net-Server
(upstream)
  - Update 0.8 to 1.3
-----------------
1.3    Mon Nov 12 03:11:17 2012
        * Require Net::Server 2.0, and adjust to its API

1.2    Sat Oct 29 02:26:17 2011
        * Net::SSLeay is now an optional dependency

1.1    Mon Sep  5 01:15:17 2011
        * Fix SIGNATURE; no code changes

1.0    Mon Sep  5 00:03:17 2011
        * Catch and warn of possible CVE-2011-0411 attacks
        * No longer make use of a bug in perl pre 5.14 wherein TIEHANDLE
          happened to be called on scalars containing typeglobs

0.9    Sun Nov 15 11:53:17 2010
        * Change socket code to work with Net::Server >= 0.99

Revision 1.7 / (download) - annotate - [select for diffs], Thu May 29 23:37:09 2014 UTC (4 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.

Revision 1.6 / (download) - annotate - [select for diffs], Fri May 31 12:41:40 2013 UTC (5 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.

Revision 1.5 / (download) - annotate - [select for diffs], Tue Oct 23 17:18:51 2012 UTC (6 years, 6 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.4: +1 -3 lines
Diff to previous 1.4 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.4 / (download) - annotate - [select for diffs], Wed Oct 3 21:57:05 2012 UTC (6 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Bump all packages that use perl, or depend on a p5-* package, or
are called p5-*.

I hope that's all of them.

Revision 1.3 / (download) - annotate - [select for diffs], Sun Aug 14 14:14:46 2011 UTC (7 years, 8 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Revision bump after updating perl5 to 5.14.1.

Revision 1.2 / (download) - annotate - [select for diffs], Sat Aug 21 16:35:28 2010 UTC (8 years, 8 months ago) by seb
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.1: +2 -1 lines
Diff to previous 1.1 (colored)

Bump the PKGREVISION for all packages which depend directly on perl,
to trigger/signal a rebuild for the transition 5.10.1 -> 5.12.1.

The list of packages is computed by finding all packages which end
up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
or PERL5_PACKLIST defined in their make setup (tested via
"make show-vars VARNAMES=..."), minus the packages updated after
the perl package update.

sno@ was right after all, obache@ kindly asked and he@ led the
way. Thanks!

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Mon Apr 19 22:47:11 2010 UTC (9 years ago) by seb
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2010Q2-base, pkgsrc-2010Q2
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial import of p5-Net-Server-Coro version 0.8 in the NetBSD
Packages Collection.

The Perl 5 module Net::Server::Coro implements multithreaded server
for the Net::Server architecture, using Coro and Coro::Socket to
make all reads and writes non-blocking. Additionally, it supports
non-blocking SSL negotiation.

Revision 1.1 / (download) - annotate - [select for diffs], Mon Apr 19 22:47:11 2010 UTC (9 years ago) by seb
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>